summaryrefslogtreecommitdiffstats
path: root/ipa-server/ipa-gui/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2008-01-18 16:20:36 -0500
committerRob Crittenden <rcritten@redhat.com>2008-01-18 16:20:36 -0500
commit042fb11fa107718a831d468d16188e02f6ae3712 (patch)
treee0e8ee6701800b8f03702cb338f8efa211b18046 /ipa-server/ipa-gui/Makefile.am
parentaaa3cfd58ca0c62325d7637b67c6711660624f5d (diff)
downloadfreeipa-042fb11fa107718a831d468d16188e02f6ae3712.tar.gz
freeipa-042fb11fa107718a831d468d16188e02f6ae3712.tar.xz
freeipa-042fb11fa107718a831d468d16188e02f6ae3712.zip
Fix issues reported by rpmlint.
- Removing shebangs (#!) from a bunch of python libraries - Don't use a variable name in init scripts for the lock file - Keep the init script name consistent with the binary name, so renamed ipa-kpasswd.init to ipa_kpasswd.init - Add status option to the init scripts - Move most python scripts out of /usr/share/ipa and into the python site-packages directories (ipaserver and ipaclient) - Remove unnecessary sys.path.append("/usr/share/ipa") - Fix the license string in the spec files - Rename ipa-webgui to ipa_webgui everywhere - Fix a couple of issues reported by pychecker in ipa-python
Diffstat (limited to 'ipa-server/ipa-gui/Makefile.am')
-rw-r--r--ipa-server/ipa-gui/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/ipa-server/ipa-gui/Makefile.am b/ipa-server/ipa-gui/Makefile.am
index 35f9ff9fd..c09a5c141 100644
--- a/ipa-server/ipa-gui/Makefile.am
+++ b/ipa-server/ipa-gui/Makefile.am
@@ -6,19 +6,19 @@ SUBDIRS = \
$(NULL)
sbin_SCRIPTS = \
- ipa-webgui \
+ ipa_webgui \
$(NULL)
appdir = $(IPA_DATA_DIR)
app_DATA = \
- ipa-webgui.cfg \
+ ipa_webgui.cfg \
$(NULL)
EXTRA_DIST = \
README.txt \
$(sbin_SCRIPTS) \
$(app_DATA) \
- ipa-webgui.init \
+ ipa_webgui.init \
dev.cfg \
sample-prod.cfg \
setup.py \
@@ -32,13 +32,13 @@ MAINTAINERCLEANFILES = \
initdir=$(sysconfdir)/rc.d/init.d
-install-data-hook: ipa-webgui.init
+install-data-hook: ipa_webgui.init
if test '!' -d $(DESTDIR)$(initdir); then \
$(mkinstalldirs) $(DESTDIR)$(initdir); \
chmod 755 $(DESTDIR)$(initdir); \
fi
- $(INSTALL_SCRIPT) $(srcdir)/ipa-webgui.init $(DESTDIR)$(initdir)/ipa-webgui
+ $(INSTALL_SCRIPT) $(srcdir)/ipa_webgui.init $(DESTDIR)$(initdir)/ipa_webgui
uninstall-hook:
- rm -f $(DESTDIR)$(initdir)/ipa-webgui
+ rm -f $(DESTDIR)$(initdir)/ipa_webgui