summaryrefslogtreecommitdiffstats
path: root/ipa-server/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <ssorce@redhat.com>2008-03-27 19:01:38 -0400
committerSimo Sorce <ssorce@redhat.com>2008-03-27 19:01:38 -0400
commitaac086582aee79ccf72206faf118e997c623170c (patch)
tree7c806025ad651531015b62ca806db7a32f55c2a8 /ipa-server/Makefile.am
parentb7924139d895c7ebe019fbfc9c85fed3baae642e (diff)
downloadfreeipa-aac086582aee79ccf72206faf118e997c623170c.tar.gz
freeipa-aac086582aee79ccf72206faf118e997c623170c.tar.xz
freeipa-aac086582aee79ccf72206faf118e997c623170c.zip
Move sysrestore to ipa-python so it can be used by client scripts too.
Change backup format so files are all in a single directory (no dir hierarchies) and use an index file so we can save also ownership and permission info for the restore (and eventually other data later on).
Diffstat (limited to 'ipa-server/Makefile.am')
-rw-r--r--ipa-server/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/ipa-server/Makefile.am b/ipa-server/Makefile.am
index d26aa2900..35d3074e1 100644
--- a/ipa-server/Makefile.am
+++ b/ipa-server/Makefile.am
@@ -15,12 +15,14 @@ SUBDIRS = \
$(NULL)
install-exec-local:
- mkdir -p $(DESTDIR)$(localstatedir)/cache/ipa/sysrestore
+ mkdir -p $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
+ chmod 700 $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
mkdir -p $(DESTDIR)$(localstatedir)/cache/ipa/sessions
chmod 700 $(DESTDIR)$(localstatedir)/cache/ipa/sessions
uninstall-local:
- -rmdir $(DESTDIR)$(localstatedir)/cache/ipa/sysrestore
+ -rmdir $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
+ -rmdir $(DESTDIR)$(localstatedir)/lib/ipa
-rmdir $(DESTDIR)$(localstatedir)/cache/ipa/sessions
-rmdir $(DESTDIR)$(localstatedir)/cache/ipa