summaryrefslogtreecommitdiffstats
path: root/ipa-client/Makefile.am
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2008-05-01 09:57:32 -0400
committerSimo Sorce <ssorce@redhat.com>2008-05-01 09:59:43 -0400
commit29ddbc610ccc14eb70dcb7ffde7c1f5cc2b95203 (patch)
tree39e068a8915beb83b88baa8bb652c0d6cfe02f95 /ipa-client/Makefile.am
parent274eb708c28abf25087c3656ec93370c2000efd3 (diff)
downloadfreeipa-29ddbc610ccc14eb70dcb7ffde7c1f5cc2b95203.tar.gz
freeipa-29ddbc610ccc14eb70dcb7ffde7c1f5cc2b95203.tar.xz
freeipa-29ddbc610ccc14eb70dcb7ffde7c1f5cc2b95203.zip
This patch begins the process of replacing OpenLDAP with mozldap.
FreeIPA relies on RedHat's Directory Server, which uses mozldap. A FreeIPA build using mozldap would reduce the project's dependencies and redundant code. In addition, mozldap uses NSS instead of OpenSSL. This is beneficial for the reasons listed in [1]. [1] http://fedoraproject.org/wiki/FedoraCryptoConsolidation
Diffstat (limited to 'ipa-client/Makefile.am')
-rw-r--r--ipa-client/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/ipa-client/Makefile.am b/ipa-client/Makefile.am
index 3379eea8c..639dbb813 100644
--- a/ipa-client/Makefile.am
+++ b/ipa-client/Makefile.am
@@ -13,7 +13,8 @@ INCLUDES = \
-DLIBEXECDIR=\""$(libexecdir)"\" \
-DDATADIR=\""$(datadir)"\" \
$(KRB5_CFLAGS) \
- $(LDAP_CFLAGS) \
+ $(OPENLDAP_CFLAGS) \
+ $(MOZLDAP_CFLAGS) \
$(SASL_CFLAGS) \
$(POPT_CFLAGS) \
$(WARN_CFLAGS) \
@@ -29,7 +30,8 @@ ipa_getkeytab_SOURCES = \
ipa_getkeytab_LDADD = \
$(KRB5_LIBS) \
- $(LDAP_LIBS) \
+ $(OPENLDAP_LIBS) \
+ $(MOZLDAP_LIBS) \
$(SASL_LIBS) \
$(POPT_LIBS) \
$(NULL)