summaryrefslogtreecommitdiffstats
path: root/install/configure.ac
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2009-02-02 13:50:53 -0500
committerRob Crittenden <rcritten@redhat.com>2009-02-03 15:29:20 -0500
commit2d7e0de5ea7a2923708006bc58dae4b35b65fe63 (patch)
tree64a3332f7996f0db70d3fd793312da887b34e8cf /install/configure.ac
parent3274577cd608f947d6b07e6dfcbde393edf5a249 (diff)
downloadfreeipa-2d7e0de5ea7a2923708006bc58dae4b35b65fe63.tar.gz
freeipa-2d7e0de5ea7a2923708006bc58dae4b35b65fe63.tar.xz
freeipa-2d7e0de5ea7a2923708006bc58dae4b35b65fe63.zip
Get merged tree into an installalble state.
I have only tested the all, rpms and *clean targets directly. install may work but the rpm moves a lot of things around for us. The Apache configuration file isn't in its final state but it works with the new mod_python configuration.
Diffstat (limited to 'install/configure.ac')
-rw-r--r--install/configure.ac43
1 files changed, 43 insertions, 0 deletions
diff --git a/install/configure.ac b/install/configure.ac
new file mode 100644
index 000000000..7f96812f0
--- /dev/null
+++ b/install/configure.ac
@@ -0,0 +1,43 @@
+AC_PREREQ(2.59)
+m4_include(../version.m4)
+AC_INIT([ipa-server],
+ IPA_VERSION,
+ [https://hosted.fedoraproject.org/projects/freeipa/newticket])
+
+#AC_CONFIG_SRCDIR([ipaserver/ipaldap.py])
+AC_CONFIG_HEADERS([config.h])
+
+AM_INIT_AUTOMAKE
+
+AM_MAINTAINER_MODE
+#AC_PROG_CC
+#AC_STDC_HEADERS
+#AC_DISABLE_STATIC
+#AC_PROG_LIBTOOL
+
+#AC_HEADER_STDC
+
+AC_SUBST(VERSION)
+
+dnl ---------------------------------------------------------------------------
+dnl - Set the data install directory since we don't use pkgdatadir
+dnl ---------------------------------------------------------------------------
+
+IPA_DATA_DIR="$datadir/ipa"
+IPA_SYSCONF_DIR="$sysconfdir/ipa"
+AC_SUBST(IPA_DATA_DIR)
+AC_SUBST(IPA_SYSCONF_DIR)
+
+# Files
+
+AC_CONFIG_FILES([
+ Makefile
+ conf/Makefile
+ html/Makefile
+ share/Makefile
+ tools/Makefile
+ tools/man/Makefile
+ updates/Makefile
+])
+
+AC_OUTPUT