summaryrefslogtreecommitdiffstats
path: root/freeipa.spec.in
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2011-04-05 16:28:59 -0400
committerRob Crittenden <rcritten@redhat.com>2011-04-05 21:46:32 -0400
commitb9a2c11d6f6be6e7e599a48c70e798b720222b35 (patch)
tree3f49173bcc53d76bdedd545b0ecd6ba2539f5cf5 /freeipa.spec.in
parent86995509a1d29497fb1c95f810337a567e1d5634 (diff)
downloadfreeipa-b9a2c11d6f6be6e7e599a48c70e798b720222b35.zip
freeipa-b9a2c11d6f6be6e7e599a48c70e798b720222b35.tar.gz
freeipa-b9a2c11d6f6be6e7e599a48c70e798b720222b35.tar.xz
Fix ORDERING in some attributetypes and remove other unnecessary elements.
Looking at the schema in 60basev2.ldif there were many attributes that did not have an ORDERING matching rule specified correctly. There were also a number of attributeTypes that should have been just SUP distinguishedName that had a combination of SUP, SYNTAX, ORDERING, etc. This requires 389-ds-base-1.2.8.0-1+ ticket 1153
Diffstat (limited to 'freeipa.spec.in')
-rw-r--r--freeipa.spec.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/freeipa.spec.in b/freeipa.spec.in
index 53bfb80..9568012 100644
--- a/freeipa.spec.in
+++ b/freeipa.spec.in
@@ -68,7 +68,7 @@ Requires: %{name}-python = %{version}-%{release}
Requires: %{name}-client = %{version}-%{release}
Requires: %{name}-admintools = %{version}-%{release}
Requires(post): %{name}-server-selinux = %{version}-%{release}
-Requires: 389-ds-base >= 1.2.8
+Requires(pre): 389-ds-base >= 1.2.8.0-1
Requires: openldap-clients
Requires: nss
Requires: nss-tools
@@ -481,10 +481,13 @@ fi
%ghost %attr(0644,root,apache) %config(noreplace) %{_sysconfdir}/ipa/default.conf
%changelog
-* Thu Mar 17 2011 Rob Crittenden <rcritten@redhat.com> - 1.99-46
+* Tue Apr 5 2011 Rob Crittenden <rcritten@redhat.com> - 1.99-47
+- Set min version of 389-ds-base to 1.2.8.0-1 for fix in BZ 693466.
+
+* Thu Mar 17 2011 Rob Crittenden <rcritten@redhat.com> - 1.99-46
- Automatically apply updates when the package is upgraded.
-* Thu Feb 17 2011 Jakub Hrozek <jhrozek@redhat.com> - 1.99-45
+* Thu Feb 17 2011 Jakub Hrozek <jhrozek@redhat.com> - 1.99-45
- Set minimum version of python-nss to 0.11 to make sure IPv6 support is in
* Wed Feb 9 2011 Rob Crittenden <rcritten@redhat.com> - 1.99-44