summaryrefslogtreecommitdiffstats
path: root/rubygem-google-protobuf.spec
diff options
context:
space:
mode:
authorJarek Prokop <jprokop@redhat.com>2023-03-16 15:56:09 +0100
committerJarek Prokop <jprokop@redhat.com>2023-03-16 15:56:09 +0100
commit37dec3669012e20d210a66974ae695fbb6b491d9 (patch)
tree89887c17084b77c0b588abbdfdee62d4f2457391 /rubygem-google-protobuf.spec
parent62d98c6684dba2c015f00adcc3d4ddfc99ae82ae (diff)
downloadrubygem-google-protobuf-37dec3669012e20d210a66974ae695fbb6b491d9.tar.gz
rubygem-google-protobuf-37dec3669012e20d210a66974ae695fbb6b491d9.tar.xz
rubygem-google-protobuf-37dec3669012e20d210a66974ae695fbb6b491d9.zip
Add specfile and first needed patch
Diffstat (limited to 'rubygem-google-protobuf.spec')
-rw-r--r--rubygem-google-protobuf.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/rubygem-google-protobuf.spec b/rubygem-google-protobuf.spec
new file mode 100644
index 0000000..18cce53
--- /dev/null
+++ b/rubygem-google-protobuf.spec
@@ -0,0 +1,88 @@
+# Generated from google-protobuf-3.22.2.gem by gem2rpm -*- rpm-spec -*-
+%global gem_name google-protobuf
+
+Name: rubygem-%{gem_name}
+Version: 3.22.2
+Release: 1%{?dist}
+Summary: Protocol Buffers
+License: BSD-3-Clause
+URL: https://developers.google.com/protocol-buffers
+Source0: %{gem_name}-%{version}.gem
+
+# Wrapping does not work with LTO.
+# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=88643
+# Additionaly the wrapping exists for extending compatibility with
+# multiple glibc versions. We do not care about that.
+# https://github.com/protocolbuffers/protobuf/issues/11935
+Patch0: 0001-Disable-wrapping-memcpy-for-Fedora.patch
+
+BuildRequires: ruby(release)
+BuildRequires: rubygems-devel
+BuildRequires: ruby-devel
+# Compiler is required for build of gem binary extension.
+# https://fedoraproject.org/wiki/Packaging:C_and_C++#BuildRequires_and_Requires
+BuildRequires: gcc
+# BuildRequires: rubygem(rake-compiler-dock) = 1.2.1
+# BuildRequires: rubygem(rake-compiler) >= 1.1.0
+# BuildRequires: rubygem(rake-compiler) < 1.2
+BuildRequires: rubygem(test-unit)
+# BuildRequires: rubygem(test-unit) >= 3.0
+# BuildRequires: rubygem(test-unit) < 4
+# BuildRequires: rubygem(test-unit) >= 3.0.9
+
+%description
+Protocol Buffers are Google's data interchange format.
+
+
+%package doc
+Summary: Documentation for %{name}
+Requires: %{name} = %{version}-%{release}
+BuildArch: noarch
+
+%description doc
+Documentation for %{name}.
+
+%prep
+%setup -q -n %{gem_name}-%{version}
+
+%patch0 -p2
+
+%build
+# Create the gem as gem install only works on a gem file
+gem build ../%{gem_name}-%{version}.gemspec
+
+# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
+# by default, so that we can move it into the buildroot in %%install
+%gem_install
+
+%install
+mkdir -p %{buildroot}%{gem_dir}
+cp -a .%{gem_dir}/* \
+ %{buildroot}%{gem_dir}/
+
+mkdir -p %{buildroot}%{gem_extdir_mri}
+cp -a .%{gem_extdir_mri}/{gem.build_complete,*.so} %{buildroot}%{gem_extdir_mri}/
+
+# Prevent dangling symlink in -debuginfo (rhbz#878863).
+rm -rf %{buildroot}%{gem_instdir}/ext/
+
+
+%check
+pushd .%{gem_instdir}
+# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
+popd
+
+%files
+%dir %{gem_instdir}
+%{gem_extdir_mri}
+%{gem_libdir}
+%exclude %{gem_cache}
+%{gem_spec}
+
+%files doc
+%doc %{gem_docdir}
+
+
+%changelog
+* Thu Mar 16 2023 Jarek Prokop <jprokop@redhat.com> - 3.22.2-1
+- Initial package