summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index f2d7638..9264902 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,4 +1,12 @@
SUBDIRS = clients
+
+noinst_PROGRAMS = wrappers.so
+wrappers_so_SOURCES = wrap-nsswitch.c wrap-pam.c
+wrappers_so_CFLAGS = $(AM_CFLAGS) -fPIC
+wrappers_so_LDADD = -ldl
+wrappers_so_LDFLAGS = -shared
+wrappers_so_LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(wrappers_so_LDFLAGS) $(LDFLAGS) -o $@
+
EXTRA_DIST = run-tests.sh test*/*.ldif test*/*.sh test*/*.txt config/slapd-collations.conf config/userRoot.ldif config/schema *.supp
if CAN_TEST
check: