summaryrefslogtreecommitdiffstats
path: root/groff.spec
diff options
context:
space:
mode:
authorPeter Schiffer <pschiffe@redhat.com>2013-02-12 15:41:50 +0100
committerPeter Schiffer <pschiffe@redhat.com>2013-02-12 15:41:50 +0100
commite9d343f9e92a0807ad331ccc6899e22c43b4afab (patch)
treed94e13577435c4cf39cc59e9e0f4bc19a0faf65c /groff.spec
parent0de3911ebd21b6cb7819f409feb16bda3a60b54a (diff)
downloadgroff-e9d343f9e92a0807ad331ccc6899e22c43b4afab.tar.gz
groff-e9d343f9e92a0807ad331ccc6899e22c43b4afab.tar.xz
groff-e9d343f9e92a0807ad331ccc6899e22c43b4afab.zip
- cleaned .spec file
Diffstat (limited to 'groff.spec')
-rw-r--r--groff.spec86
1 files changed, 28 insertions, 58 deletions
diff --git a/groff.spec b/groff.spec
index f5b3a9e..0d1e2ed 100644
--- a/groff.spec
+++ b/groff.spec
@@ -6,23 +6,20 @@ Version: 1.22.2
Release: 1%{?dist}
License: GPLv3+ and GFDL and BSD and MIT
Group: Applications/Publishing
-URL: http://groff.ffii.org
-Source0: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
+URL: http://www.gnu.org/software/groff/
+Source: ftp://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
-Patch1: 0001-missing-groff-x11-info-message-when-gxditview-not-fo.patch
-Patch2: 0002-load-site-font-and-site-tmac-from-etc-groff.patch
-Patch3: 0003-various-security-fixes.patch
+# resolves: #530788
+Patch0: 0001-missing-groff-x11-info-message-when-gxditview-not-fo.patch
+Patch1: 0002-load-site-font-and-site-tmac-from-etc-groff.patch
+# resolves: #709413, #720058, #720057
+Patch2: 0003-various-security-fixes.patch
-Requires: coreutils
-Requires: /sbin/install-info
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Provides: nroff-i18n = %{version}-%{release}
-BuildRequires: git
-BuildRequires: netpbm-progs psutils ghostscript
-# when building from CVS add: BuildRequires: texinfo byacc
-Requires: groff-base = %{version}-%{release}
+Requires: coreutils, /sbin/install-info, groff-base = %{version}-%{release}
Requires(post): info
Requires(preun): info
+BuildRequires: git, netpbm-progs, psutils, ghostscript
+Provides: nroff-i18n = %{version}-%{release}
%description
Groff is a document formatting system. Groff takes standard text and
@@ -63,8 +60,8 @@ roff2html roff2pdf roff2ps roff2text roff2x (roff code converters).
%package x11
Summary: Parts of the groff formatting system that require X Windows System
Group: Applications/Publishing
-BuildRequires: libXaw-devel libXmu-devel
Requires: groff-base = %{version}-%{release}
+BuildRequires: libXaw-devel, libXmu-devel
Provides: groff-gxditview = %{version}-%{release}
Obsoletes: groff-gxditview < 1.20.1
@@ -98,77 +95,60 @@ git commit -n -m "release %{version}"
git am %{patches}
for file in NEWS src/devices/grolbp/grolbp.man doc/{groff.info*,webpage.ms} \
- contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom,mom.vim} ; do
- iconv -f iso-8859-1 -t utf-8 < "$file" > "${file}_"
- mv "${file}_" "$file"
+ contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom,mom.vim}; do
+ iconv -f iso-8859-1 -t utf-8 < "$file" > "${file}_"
+ mv "${file}_" "$file"
done
%build
%configure \
- --docdir=%{_docdir}/%{name}-%{version} \
- --with-appresdir=%{_datadir}/X11/app-defaults \
- --with-grofferdir=%{_datadir}/%{name}/%{version}/groffer
-make
+ --docdir=%{_docdir}/%{name}-%{version} \
+ --with-appresdir=%{_datadir}/X11/app-defaults \
+ --with-grofferdir=%{_datadir}/%{name}/%{version}/groffer
+make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
-
make install DESTDIR=%{buildroot}
# some binaries need alias with 'g' or 'z' prefix
-
for file in g{nroff,troff,tbl,pic,eqn,neqn,refer,lookbib,indxbib,soelim} zsoelim; do
- ln -s ${file#?} %{buildroot}%{_bindir}/${file}
- ln -s ${file#?}.1.gz %{buildroot}%{_mandir}/man1/${file}.1.gz
+ ln -s ${file#?} %{buildroot}%{_bindir}/${file}
+ ln -s ${file#?}.1.gz %{buildroot}%{_mandir}/man1/${file}.1.gz
done
# fix absolute symlink to relative symlink
-
rm -f %{buildroot}%{_docdir}/%{name}-%{version}/pdf/mom-pdf.pdf
ln -s ../examples/mom/mom-pdf.pdf %{buildroot}%{_docdir}/%{name}-%{version}/pdf/mom-pdf.pdf
-# another documentation files
-
-cp BUG-REPORT COPYING FDL LICENSES MORE.STUFF NEWS PROBLEMS %{buildroot}%{_docdir}/%{name}-%{version}
-
-# rename groff downloadable postscript fonts to meet Fedora Font Packaging guidelines, as these files
-# are more PS instructions, than general-purpose fonts (bz #477394)
-
+# rename groff downloadable postscript fonts to meet Fedora Font Packaging guidelines,
+# as these files are more PS instructions, than general-purpose fonts (bz #477394)
for file in $(find %{buildroot}%{_datadir}/%{name}/%{version}/font/devps -name "*.pfa"); do
- mv ${file} ${file}_
+ mv ${file} ${file}_
done
-
sed --in-place 's/\.pfa$/.pfa_/' %{buildroot}%{_datadir}/%{name}/%{version}/font/devps/download
# remove unnecessary files
-
rm -f %{buildroot}%{_infodir}/dir
# fix privileges
-
chmod 755 %{buildroot}%{_datadir}/groff/%{version}/groffer/version.sh
chmod 755 %{buildroot}%{_datadir}/groff/%{version}/font/devlj4/generate/special.awk
# remove CreationDate from documentation
-
pushd %{buildroot}%{_docdir}/%{name}-%{version}
- find -name "*.html" | xargs sed -i "/^<!-- CreationDate: /d"
- find -name "*.ps" | xargs sed -i "/^%%%%CreationDate: /d"
+ find -name "*.html" | xargs sed -i "/^<!-- CreationDate: /d"
+ find -name "*.ps" | xargs sed -i "/^%%%%CreationDate: /d"
popd
-%clean
-rm -rf %{buildroot}
-
%post
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
%preun
if [ $1 = 0 ]; then
- /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
+ /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
fi
%files
-%defattr(-,root,root,-)
# data
%{_datadir}/%{name}/%{version}/font/devdvi/
%{_datadir}/%{name}/%{version}/font/devhtml/
@@ -255,15 +235,7 @@ fi
%{_infodir}/groff.info*
%files base
-%defattr(-,root,root,-)
-%dir %{_docdir}/%{name}-%{version}/
-%doc %{_docdir}/%{name}-%{version}/BUG-REPORT
-%doc %{_docdir}/%{name}-%{version}/COPYING
-%doc %{_docdir}/%{name}-%{version}/FDL
-%doc %{_docdir}/%{name}-%{version}/LICENSES
-%doc %{_docdir}/%{name}-%{version}/MORE.STUFF
-%doc %{_docdir}/%{name}-%{version}/NEWS
-%doc %{_docdir}/%{name}-%{version}/PROBLEMS
+%doc BUG-REPORT COPYING FDL LICENSES MORE.STUFF NEWS PROBLEMS
# configuration
%dir %{_sysconfdir}/groff/
%config(noreplace) %{_sysconfdir}/groff/*
@@ -369,7 +341,6 @@ fi
%{_mandir}/man1/zsoelim.*
%files perl
-%defattr(-,root,root,-)
# data
%{_datadir}/%{name}/%{version}/font/devpdf/
%{_datadir}/%{name}/%{version}/groffer/
@@ -404,7 +375,6 @@ fi
%if %{with_x}
%files x11
-%defattr(-,root,root,-)
# data
%{_datadir}/%{name}/%{version}/font/devX*/
%{_datadir}/%{name}/%{version}/tmac/X.tmac
@@ -419,7 +389,6 @@ fi
%endif
%files doc
-%defattr(-,root,root,-)
%doc %{_docdir}/%{name}-%{version}/*.me
%doc %{_docdir}/%{name}-%{version}/*.ps
%doc %{_docdir}/%{name}-%{version}/*.ms
@@ -431,6 +400,7 @@ fi
* Tue Feb 12 2013 Peter Schiffer <pschiffe@redhat.com> 1.22.2-1
- resolves: #909154
updated to 1.22.2
+- cleaned .spec file
* Tue Jan 01 2013 Jan Vcelak <jvcelak@redhat.com> 1.22.1-1
- new upstream release (#890973)