summaryrefslogtreecommitdiffstats
path: root/cygwin-pkg-config.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cygwin-pkg-config.spec')
-rw-r--r--cygwin-pkg-config.spec13
1 files changed, 10 insertions, 3 deletions
diff --git a/cygwin-pkg-config.spec b/cygwin-pkg-config.spec
index 8a2cc3a..7573c24 100644
--- a/cygwin-pkg-config.spec
+++ b/cygwin-pkg-config.spec
@@ -1,6 +1,6 @@
Name: cygwin-pkg-config
Version: 0.28
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: A tool for determining compilation options
License: GPLv2+
@@ -53,7 +53,9 @@ pushd build_cyg32
--disable-shared \
--disable-host-tool \
--program-prefix=%{cygwin32_target}- \
- --with-pc-path=%{cygwin32_libdir}/pkgconfig:%{cygwin32_datadir}/pkgconfig:%{_datadir}/pkgconfig
+ --with-pc-path=%{cygwin32_libdir}/pkgconfig:%{cygwin32_datadir}/pkgconfig:%{_datadir}/pkgconfig \
+ --with-system-include-path=%{cygwin32_includedir} \
+ --with-system-library-path=%{cygwin32_libdir}
make %{?_smp_mflags}
popd
@@ -64,7 +66,9 @@ pushd build_cyg64
--disable-shared \
--disable-host-tool \
--program-prefix=%{cygwin64_target}- \
- --with-pc-path=%{cygwin64_libdir}/pkgconfig:%{cygwin64_datadir}/pkgconfig:%{_datadir}/pkgconfig
+ --with-pc-path=%{cygwin64_libdir}/pkgconfig:%{cygwin64_datadir}/pkgconfig:%{_datadir}/pkgconfig \
+ --with-system-include-path=%{cygwin64_includedir} \
+ --with-system-library-path=%{cygwin64_libdir}
make %{?_smp_mflags}
popd
@@ -91,5 +95,8 @@ rm -rf ${RPM_BUILD_ROOT}%{_datadir}/doc/pkg-config
%changelog
+* Thu Jun 27 2013 Yaakov Selkowitz <cygwin-ports-general@lists.sourceforge.net> - 0.28-2
+- Configure system include and library paths to avoid -I and -L flags.
+
* Wed Jun 26 2013 Yaakov Selkowitz <cygwin-ports-general@lists.sourceforge.net> - 0.28-1
- Initial spec file, largely based on mingw-pkg-config.