summaryrefslogtreecommitdiffstats
path: root/cygwin-clang.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cygwin-clang.spec')
-rw-r--r--cygwin-clang.spec35
1 files changed, 20 insertions, 15 deletions
diff --git a/cygwin-clang.spec b/cygwin-clang.spec
index f92db22..5334197 100644
--- a/cygwin-clang.spec
+++ b/cygwin-clang.spec
@@ -1,7 +1,5 @@
-%define gccdir %{_libdir}/gcc/%{_cygwin_target}/4.5.3
-
Name: cygwin-clang
-Version: 3.0
+Version: 3.1
Release: 1%{?dist}
Summary: Clang compiler for Cygwin toolchain
@@ -10,8 +8,10 @@ License: NCSA
URL: http://clang.llvm.org
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Source0: http://www.llvm.org/releases/%{version}/llvm-%{version}.tar.gz
-Source1: http://www.llvm.org/releases/%{version}/clang-%{version}.tar.gz
+Source0: http://www.llvm.org/releases/%{version}/llvm-%{version}.src.tar.gz
+Source1: http://www.llvm.org/releases/%{version}/clang-%{version}.src.tar.gz
+Patch0: clang-3.0-cygwin-dllexport.patch
+Patch1: clang-3.1-cygwin-includes.patch
BuildRequires: cygwin-filesystem
BuildRequires: gcc-c++
@@ -31,19 +31,20 @@ Clang C/C++/ObjC compiler for the Cygwin toolchain
%prep
%setup -q -T -b 0 -a 1 -n llvm-%{version}.src
mv clang-%{version}.src tools/clang
+%patch0 -p2
+%patch1 -p2
%build
-%{configure} --target=%{_cygwin_target} --enable-targets=x86,cbe,cpp \
- --disable-assertions --enable-optimized --enable-libffi \
- --disable-embed-stdcxx --disable-bindings \
- --with-clang-resource-dir=../%{_lib}/clang/%{_cygwin_target}/%{version} \
- --with-c-include-dirs=%{gccdir}/include:%{_cygwin_includedir}:%{_cygwin_includedir}/w32api \
- --with-cxx-include-root=%{gccdir}/include/c++ \
- --with-cxx-include-arch=%{_cygwin_target}
+%{configure} --target=%{_cygwin_target} --enable-targets=host,cpp \
+ --disable-assertions --enable-optimized --enable-debug-runtime \
+ --enable-debug-symbols --enable-libffi \
+ --disable-embed-stdcxx --disable-bindings --disable-shared \
+ --with-gcc-toolchain=/usr --with-default-sysroot=%{_cygwin_sysroot} \
+ --with-clang-resource-dir=../%{_lib}/clang/%{_cygwin_target}/%{version}
-make %{?_smp_mflags} REQUIRES_RTTI=1 ENABLE_DOCS=0
-make -C tools/clang/docs/tools clang.1
+make %{?_smp_mflags} clang-only REQUIRES_RTTI=1 ENABLE_DOCS=0
+make -C tools/clang/docs/tools man
%install
@@ -52,7 +53,7 @@ rm -rf $RPM_BUILD_ROOT
make install -C tools/clang/lib/Headers \
PROJ_headers=$RPM_BUILD_ROOT%{_libdir}/clang/%{_cygwin_target}/%{version}/include
-install -D -m0755 Release/bin/clang $RPM_BUILD_ROOT%{_bindir}/%{_cygwin_target}-clang
+install -D -m0755 Release+Debug/bin/clang $RPM_BUILD_ROOT%{_bindir}/%{_cygwin_target}-clang
ln -s %{_cygwin_target}-clang $RPM_BUILD_ROOT%{_bindir}/%{_cygwin_target}-clang++
install -D -m0644 tools/clang/docs/tools/clang.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{_cygwin_target}-clang.1
@@ -71,5 +72,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
+* Fri Jul 13 2012 Yaakov Selkowitz <cygwin-ports-general@lists.sourceforge.net> - 3.1-1
+- Version bump.
+- Add patch to support dllexport/dllimport attributes.
+
* Sun Feb 05 2012 Yaakov Selkowitz <cygwin-ports-general@lists.sourceforge.net> - 3.0-1
- Initial RPM release.