summaryrefslogtreecommitdiffstats
path: root/rubygem-activejob.spec
diff options
context:
space:
mode:
authorVít Ondruch <vondruch@redhat.com>2015-01-23 13:36:31 +0100
committerVít Ondruch <vondruch@redhat.com>2015-01-23 13:36:31 +0100
commit1b43d7e7c19ecd6e8dbf0ec44802e198a204945a (patch)
tree2e75c7bb91109f53da2865073f72d8def5327325 /rubygem-activejob.spec
parent6c1ae1e77ff7a73e1cdfceda998873ad1d612324 (diff)
downloadrubygem-activejob-1b43d7e7c19ecd6e8dbf0ec44802e198a204945a.tar.gz
rubygem-activejob-1b43d7e7c19ecd6e8dbf0ec44802e198a204945a.tar.xz
rubygem-activejob-1b43d7e7c19ecd6e8dbf0ec44802e198a204945a.zip
Initial packageHEADmaster
Diffstat (limited to 'rubygem-activejob.spec')
-rw-r--r--rubygem-activejob.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/rubygem-activejob.spec b/rubygem-activejob.spec
new file mode 100644
index 0000000..4a7726d
--- /dev/null
+++ b/rubygem-activejob.spec
@@ -0,0 +1,87 @@
+# Generated from activejob-4.2.0.gem by gem2rpm -*- rpm-spec -*-
+%global gem_name activejob
+
+Name: rubygem-%{gem_name}
+Version: 4.2.0
+Release: 1%{?dist}
+Summary: Job framework with pluggable queues
+Group: Development/Languages
+License: MIT
+URL: http://www.rubyonrails.org
+Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
+# git clone https://github.com/rails/rails.git && cd rails/activejob && git checkout v4.2.0
+# tar czvf activejob-4.2.0-tests.tgz test/
+Source1: %{gem_name}-%{version}-tests.tgz
+BuildRequires: ruby(release)
+BuildRequires: rubygems-devel
+BuildRequires: ruby >= 1.9.3
+BuildRequires: rubygem(activesupport)
+BuildRequires: rubygem(globalid)
+BuildArch: noarch
+
+%description
+Declare job classes that can be run by a variety of queueing backends.
+
+
+%package doc
+Summary: Documentation for %{name}
+Group: Documentation
+Requires: %{name} = %{version}-%{release}
+BuildArch: noarch
+
+%description doc
+Documentation for %{name}.
+
+%prep
+gem unpack %{SOURCE0}
+
+%setup -q -D -T -n %{gem_name}-%{version}
+
+gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
+
+%build
+# Create the gem as gem install only works on a gem file
+gem build %{gem_name}.gemspec
+
+# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
+# by default, so that we can move it into the buildroot in %%install
+%gem_install
+
+%install
+mkdir -p %{buildroot}%{gem_dir}
+cp -a .%{gem_dir}/* \
+ %{buildroot}%{gem_dir}/
+
+
+
+
+# Run the test suite
+%check
+pushd .%{gem_instdir}
+tar xzvf %{SOURCE1}
+
+# ActiveSupport::TestCase.test_order is not available in AS 4.1.
+sed -i "/\.test_order/ s/^/#/" test/helper.rb
+
+# This is just helper used in official repository.
+sed -i "/load_paths/ s/^/#/" test/helper.rb
+
+# Do not exexute integration tests, otherwise Railse's generators are requires.
+AJADAPTER=inline ruby -Ilib:test -e 'Dir.glob "./test/cases/**/*_test.rb", &method(:require)'
+popd
+
+%files
+%license %{gem_instdir}/MIT-LICENSE
+%dir %{gem_instdir}
+%{gem_libdir}
+%exclude %{gem_cache}
+%{gem_spec}
+
+%files doc
+%doc %{gem_docdir}
+%doc %{gem_instdir}/CHANGELOG.md
+%doc %{gem_instdir}/README.md
+
+%changelog
+* Thu Jan 22 2015 Vít Ondruch <vondruch@redhat.com> - 4.2.0-1
+- Initial package