summaryrefslogtreecommitdiffstats
path: root/perl-Module-Pluggable.spec
diff options
context:
space:
mode:
Diffstat (limited to 'perl-Module-Pluggable.spec')
-rw-r--r--perl-Module-Pluggable.spec62
1 files changed, 62 insertions, 0 deletions
diff --git a/perl-Module-Pluggable.spec b/perl-Module-Pluggable.spec
new file mode 100644
index 0000000..3e7edf1
--- /dev/null
+++ b/perl-Module-Pluggable.spec
@@ -0,0 +1,62 @@
+Name: perl-Module-Pluggable
+# Epoch to compete with perl.spec
+Epoch: 1
+Version: 4.6
+Release: 1%{?dist}
+Summary: Automatically give your module the ability to have plugins
+License: GPL+ or Artistic
+Group: Development/Libraries
+URL: http://search.cpan.org/dist/Module-Pluggable/
+Source0: http://www.cpan.org/authors/id/S/SI/SIMONW/Module-Pluggable-%{version}.tar.gz
+BuildArch: noarch
+BuildRequires: perl
+BuildRequires: perl(FindBin)
+BuildRequires: perl(Module::Build)
+# Run-time:
+BuildRequires: perl(base)
+BuildRequires: perl(Carp)
+BuildRequires: perl(Exporter)
+BuildRequires: perl(File::Basename)
+BuildRequires: perl(File::Find)
+BuildRequires: perl(File::Spec::Functions) >= 3.00
+BuildRequires: perl(if)
+# Tests:
+BuildRequires: perl(Data::Dumper)
+BuildRequires: perl(lib)
+BuildRequires: perl(Test::More) >= 0.62
+Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
+Requires: perl(File::Basename)
+Requires: perl(File::Spec::Functions) >= 3.00
+
+# Filter under-specified dependencies
+%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(File::Spec::Functions\\)$
+
+%description
+This package provides a simple but, hopefully, extensible way of having
+'plugins' for your module. Essentially all it does is export a method into
+your name space that looks through a search path for .pm files and turn those
+into class names. Optionally it instantiates those classes for you.
+
+%prep
+%setup -q -n Module-Pluggable-%{version}
+find -type f -exec chmod -x {} +
+
+%build
+perl Build.PL installdirs=vendor
+./Build
+
+%install
+./Build install destdir=$RPM_BUILD_ROOT create_packlist=0
+%{_fixperms} $RPM_BUILD_ROOT/*
+
+%check
+./Build test
+
+%files
+%doc Changes README
+%{perl_vendorlib}/*
+%{_mandir}/man3/*
+
+%changelog
+* Thu Jan 24 2013 Petr Pisar <ppisar@redhat.com> 1:4.6-1
+- Specfile autogenerated by cpanspec 1.78.