summaryrefslogtreecommitdiffstats
path: root/libstatgrab.spec
diff options
context:
space:
mode:
authorOliver Falk <oliver@fedoraproject.org>2005-07-08 07:22:42 +0000
committerOliver Falk <oliver@fedoraproject.org>2005-07-08 07:22:42 +0000
commit0d06789f499e1d4f762abeacb5716f22cfe0609e (patch)
treeb3e84d894ae464e296444e3e3da4f9011a6d9269 /libstatgrab.spec
parentdfe010e0a827227da2ff17642ec45388fdc023dc (diff)
downloadlibstatgrab-0d06789f499e1d4f762abeacb5716f22cfe0609e.tar.gz
libstatgrab-0d06789f499e1d4f762abeacb5716f22cfe0609e.tar.xz
libstatgrab-0d06789f499e1d4f762abeacb5716f22cfe0609e.zip
libstatgrab-0.11.1-3.src.rpm
Diffstat (limited to 'libstatgrab.spec')
-rw-r--r--libstatgrab.spec150
1 files changed, 150 insertions, 0 deletions
diff --git a/libstatgrab.spec b/libstatgrab.spec
new file mode 100644
index 0000000..4ada438
--- /dev/null
+++ b/libstatgrab.spec
@@ -0,0 +1,150 @@
+%define shortname statgrab
+
+Summary: Make system statistics
+Name: libstatgrab
+
+Version: 0.11.1
+Release: 3%{?dist}
+
+Source0: ftp://ftp.i-scream.org/pub/i-scream/%{name}/%{name}-%{version}.tar.gz
+Patch0: %{name}.nochmod.patch
+
+License: LGPL
+Group: System Environment/Libraries
+URL: http://www.i-scream.org/%{name}/
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: libtool ncurses-devel
+
+%description
+Libstatgrab is a library that provides cross platform access to statistics
+about the system on which it's run. It's written in C and presents a selection
+of useful interfaces which can be used to access key system statistics. The
+current list of statistics includes CPU usage, memory utilisation, disk usage,
+process counts, network traffic, disk I/O, and more.
+
+The current list of platforms is Solaris 2.x, Linux, and FreeBSD 4.x/5.x.
+The aim is to extend this to include as many operating systems as possible.
+
+The package also includes a couple of useful tools. The first, saidar,
+provides a curses-based interface to viewing the current state of the
+system. The second, statgrab, gives a sysctl-style interface to the
+statistics gathered by libstatgrab. This extends the use of libstatgrab
+to people writing scripts or anything else that can't easily make C
+function calls. Included with statgrab is a script to generate an MRTG
+configuration file to use statgrab.
+
+%package -n %{shortname}-tools
+Summary: Tools from %{name} to monitoring the system
+Group: Applications/System
+
+%description -n %{shortname}-tools
+This package contains a few tools shiped with libstatgrab.
+Eg. A tool called saidar, which shows various system
+information like top, but - of course - OTHER informations.
+
+%package devel
+Summary: The development files from %{name}
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+Requires: pkgconfig
+
+%description devel
+This package contains header files and man pages for those
+use to develop libstatgrab based applications.
+
+%package examples
+Summary: The example files from %{name}
+Group: Development/Tools
+Requires: %{name} = %{version}-%{release}
+
+%description examples
+This package contains various examples used to show how
+to develop libstatgrab based applications.
+
+%prep
+%setup -q
+%patch0 -p0
+
+%build
+%configure --with-ncurses
+make %{?_smp_mflags}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+cd examples/.libs
+install -m 755 cpu_usage disk_traffic load_stats network_iface_stats \
+ network_traffic os_info page_stats process_snapshot \
+ process_stats user_list vm_stats $RPM_BUILD_ROOT%{_bindir}
+chmod 755 $RPM_BUILD_ROOT%{_bindir}/statgrab-make-mrtg-config
+chmod 755 $RPM_BUILD_ROOT%{_bindir}/saidar
+chmod 755 $RPM_BUILD_ROOT%{_bindir}/statgrab
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%files -n %shortname-tools
+%defattr(-,root,root)
+%doc COPYING
+%{_bindir}/saidar
+%{_bindir}/statgrab
+%{_bindir}/statgrab-make-mrtg-config
+%{_bindir}/statgrab-make-mrtg-index
+%{_mandir}/*/statgrab*
+
+%files
+%defattr(-,root,root)
+%doc AUTHORS INSTALL README ChangeLog NEWS COPYING.LGPL examples/*.c
+%{_libdir}/*.so.*
+
+%files devel
+%defattr(-,root,root)
+%{_libdir}/*.so
+%{_libdir}/*.a
+%{_libdir}/*.la
+%{_includedir}/*.h
+%{_libdir}/pkgconfig/%name.pc
+%{_mandir}/*/sg_*
+
+%files examples
+%defattr(-,root,root)
+%{_bindir}/cpu_usage
+%{_bindir}/disk_traffic
+%{_bindir}/load_stats
+%{_bindir}/network_iface_stats
+%{_bindir}/network_traffic
+%{_bindir}/os_info
+%{_bindir}/page_stats
+%{_bindir}/process_snapshot
+%{_bindir}/process_stats
+%{_bindir}/user_list
+%{_bindir}/vm_stats
+
+%changelog
+* Fri Jul 08 2005 Oliver Falk <oliver@linux-kernel.at> - 0.11.1-3
+- Included examples/*.c in doc
+
+* Wed Jul 6 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.11.1-2
+- a lot of fixes for Fedora Extras
+
+* Thu May 19 2005 Oliver Falk <oliver@linux-kernel.at> - 0.11.1-1.1
+- Specfile cleanup
+
+* Sun Apr 03 2005 Oliver Falk <oliver@linux-kernel.at> - 0.11.1-1
+- Update
+
+* Fri Mar 25 2005 Oliver Falk <oliver@linux-kernel.at> - 0.11-2.1
+- Fix rpmlint warnings
+
+* Tue Feb 15 2005 Oliver Falk <oliver@linux-kernel.at> - 0.11-2
+- Don't require coreutils. They are normally installed on Fedora, but
+ not available on RH 8, where the tools are usually also installed.
+ Yes, rebuilding with nodeps would also do it, but it's not fine...
+
+* Tue Feb 15 2005 Oliver Falk <oliver@linux-kernel.at> - 0.11-1
+- Initial build for Fedora Core