summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am62
1 files changed, 30 insertions, 32 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e0fbe33..0af58fc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,42 +1,40 @@
lib_LTLIBRARIES = libgpod.la
-libgpod_la_SOURCES = \
- db-artwork-debug.c \
- db-artwork-debug.h \
- db-artwork-parser.c \
- db-artwork-parser.h \
- db-artwork-writer.c \
- db-image-parser.c \
- db-image-parser.h \
- db-itunes-parser.h \
- db-parse-context.c \
- db-parse-context.h \
- glib-compat.h \
- itdb.h \
- itdb_artwork.c \
- itdb_device.c \
- itdb_device.h \
- itdb_endianness.h \
- itdb_itunesdb.c \
- itdb_photoalbum.c \
- itdb_playlist.c \
- itdb_private.h \
- itdb_sha1.c \
- itdb_sha1.h \
- itdb_sysinfo.c \
- itdb_track.c \
- ithumb-writer.c \
- pixmaps.c \
- pixmaps.h \
+libgpod_la_SOURCES = \
+ db-artwork-debug.c \
+ db-artwork-parser.c \
+ db-artwork-writer.c \
+ db-image-parser.c \
+ db-parse-context.c \
+ itdb_artwork.c \
+ itdb_device.c \
+ itdb_itunesdb.c \
+ itdb_photoalbum.c \
+ itdb_playlist.c \
+ itdb_sha1.c \
+ itdb_sysinfo.c \
+ itdb_track.c \
+ ithumb-writer.c \
+ pixmaps.c \
sha1.c
-
-libgpod_la_headers = itdb.h
-libgpod_la_noinst_headers = itdb_private.h hal-common.h sha1.h itdb-sha1.h
libgpod_la_LDFLAGS = -version-info $(LIBGPOD_SO_VERSION) -no-undefined
libgpodincludedir = $(includedir)/gpod-1.0/gpod
-libgpodinclude_HEADERS = $(libgpod_la_headers)
+libgpodinclude_HEADERS = itdb.h
+noinst_HEADERS = \
+ db-artwork-debug.h \
+ db-artwork-parser.h \
+ db-image-parser.h \
+ db-itunes-parser.h \
+ db-parse-context.h \
+ glib-compat.h \
+ itdb_device.h \
+ itdb_endianness.h \
+ itdb_private.h \
+ itdb_sha1.h \
+ pixmaps.h \
+ sha1.h
INCLUDES=$(LIBGPOD_CFLAGS)
LIBS=$(LIBGPOD_LIBS)