summaryrefslogtreecommitdiffstats
path: root/bindings/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/python/Makefile.am')
-rw-r--r--bindings/python/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/bindings/python/Makefile.am b/bindings/python/Makefile.am
index 9373edc..b5d23f4 100644
--- a/bindings/python/Makefile.am
+++ b/bindings/python/Makefile.am
@@ -18,6 +18,14 @@ DISTCLEANFILES = \
README \
gpod.i
+README: README.in gpod.i
+ WRAPPER_LIST=`grep 'PyObject\* sw_[^_].*;' gpod.i | awk -F "[ (]" '{ print $$2 }' | sort -u | tr '\n' ' '`; \
+ sed \
+ -e "s/@WRAPPER_LIST@/$${WRAPPER_LIST}/" \
+ -e "/^sw_/ s/ $$//" \
+ -e "/^sw_/ s/ /\n/g" \
+ $< > $@
+
if HAVE_PYTHON
MODULE_CFLAGS = `$(PKG_CONFIG) --cflags $(top_builddir)/libgpod-1.0.pc` $(PYTHON_INCLUDES)
MODULE_LIBS = `$(PKG_CONFIG) --libs $(top_builddir)/libgpod-1.0.pc` -L$(top_srcdir)/src/.libs
@@ -45,14 +53,6 @@ install-pythonDATA: $(python_DATA)
uninstall-pythonDATA: $(python_DATA)
rm -rf $(DESTDIR)$(pyexecdir)/gpod
-README: README.in gpod.i
- WRAPPER_LIST=`grep 'PyObject\* sw_[^_].*;' gpod.i | awk -F "[ (]" '{ print $$2 }' | sort -u | tr '\n' ' '`; \
- sed \
- -e "s/@WRAPPER_LIST@/$${WRAPPER_LIST}/" \
- -e "/^sw_/ s/ $$//" \
- -e "/^sw_/ s/ /\n/g" \
- $< > $@
-
test:
cd tests && python tests.py
endif