summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2007-09-27 18:22:24 +0000
committerChristophe Fergeau <teuf@gnome.org>2007-09-27 18:22:24 +0000
commitc740d9f8b25f36d20b404cb99085cc853b0908fe (patch)
treeb943480d6dca526634a454181e897ea51fdd7d5d /configure.ac
parent9a2a5fd8fb42f334131a5a98fe0db9a88714224a (diff)
downloadlibgpod-c740d9f8b25f36d20b404cb99085cc853b0908fe.tar.gz
libgpod-c740d9f8b25f36d20b404cb99085cc853b0908fe.tar.xz
libgpod-c740d9f8b25f36d20b404cb99085cc853b0908fe.zip
2007-09-27 Christophe Fergeau <teuf@gnome.org>
* configure.ac: build tool to generate the iPod SysInfoExtended file if sgutils is detected * Makefile.am: * tools/ * tools/Makefile.am: changes to optionally build the sgutils-based tool * tools/read-sysinfoextended-sgutils.c: (do_sg_inquiry), (read_sysinfo_extended), (main): new file, reads the SysInfoExtended file from the iPod using SCSI queries git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1703 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ef845fe..60fa565 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,15 @@ PKG_CHECK_MODULES(LIBGPOD, glib-2.0 >= 2.4.0 gobject-2.0)
LIBGPOD_CFLAGS="$LIBGPOD_CFLAGS -Wall"
dnl **************************************************
+dnl * sgutils is necessary to get the xml device file from the ipod
+dnl **************************************************
+AC_CHECK_LIB(sgutils, sg_ll_inquiry,
+ [SGUTILS_LIBS="-lsgutils"; have_sgutils=yes],
+ have_sgutils=no)
+AC_SUBST(SGUTILS_LIBS)
+AM_CONDITIONAL(HAVE_SGUTILS, test x"$have_sgutils" = xyes)
+
+dnl **************************************************
dnl * TagLib is only used by test-rebuild-db
dnl **************************************************
PKG_CHECK_MODULES(TAGLIB, taglib, have_taglib=yes, have_taglib=no)
@@ -200,6 +209,7 @@ docs/reference/version.xml
m4/Makefile
po/Makefile.in
src/Makefile
+tools/Makefile
tests/Makefile
libgpod-1.0.pc
])