summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2006-04-10 18:38:10 +0000
committerChristophe Fergeau <teuf@gnome.org>2006-04-10 18:38:10 +0000
commitdcc1cef6e0085f01e2c045c565f8cf667b223d2d (patch)
tree5f3629829d382928a834449f1e374d4132195b10 /configure.ac
parent8201d5330e1d70d1627094792a8c7d5d1d5dd1f2 (diff)
downloadlibgpod-dcc1cef6e0085f01e2c045c565f8cf667b223d2d.tar.gz
libgpod-dcc1cef6e0085f01e2c045c565f8cf667b223d2d.tar.xz
libgpod-dcc1cef6e0085f01e2c045c565f8cf667b223d2d.zip
* tests/test-ls.c: new test program reading and displaying the iPod
content * tests/test-rebuild-db.cc: new test program which looks for mp3 files on the iPod in the Music dir and rebuild an iPod database from that (it uses taglib to parse the tags, so it's conditionnally built depending on taglib's availability) * configure.ac: * tests/Makefile.am: build system changes to accomodate the 2 new test programs git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1245 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9b8a28d..1ad397c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,19 @@ PKG_CHECK_MODULES(LIBGPOD, glib-2.0 >= 2.4.0 gobject-2.0)
LIBGPOD_CFLAGS="$LIBGPOD_CFLAGS -Wall"
dnl **************************************************
+dnl * TagLib is only used by test-rebuild-db
+dnl **************************************************
+PKG_CHECK_MODULES(TAGLIB, taglib, have_taglib=yes, have_taglib=no)
+if test x"$have_taglib" = xyes; then
+ AH_TEMPLATE([HAVE_TAGLIB], [Whether TagLib is installed, it's only used in a test program])
+ AC_DEFINE_UNQUOTED(HAVE_TAGLIB, 1)
+fi
+AC_SUBST(TAGLIB_CFLAGS)
+AC_SUBST(TAGLIB_LIBS)
+AM_CONDITIONAL(HAVE_TAGLIB, test x"$have_taglib" = xyes)
+
+
+dnl **************************************************
dnl * GDKPIXBUF is optional
dnl **************************************************