summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJorg Schuler <jcsjcs@users.sourceforge.net>2005-10-09 16:27:46 +0000
committerJorg Schuler <jcsjcs@users.sourceforge.net>2005-10-09 16:27:46 +0000
commit5b02248eb39cb1cdd1ca6f7daf0ce34585c4225c (patch)
tree380208d30975c2562189c0f518c48f1db55b3584 /configure.ac
parent1e6147b63567fd2c0f424dda4a05323b21991f03 (diff)
downloadlibgpod-5b02248eb39cb1cdd1ca6f7daf0ce34585c4225c.tar.gz
libgpod-5b02248eb39cb1cdd1ca6f7daf0ce34585c4225c.tar.xz
libgpod-5b02248eb39cb1cdd1ca6f7daf0ce34585c4225c.zip
* bindings/python/gpod.i: applied Kelvin Lawson's patch to query
integers. * src/ipod-device.[ch],hal-common.[ch],Makefile.am: code ported from libipoddevice to retrieve information about the iPod without libhal dependence. * tests/test-ipod-device.c: small script to show how to to query the iPod for information. * tests/Makefile.am: initialize <LIBS> with better default * configure.ac: add dependency for libgobject git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1113 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8670f7c..6242295 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,7 +52,7 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_INTLTOOL([0.21])
-PKG_CHECK_MODULES(LIBGPOD, glib-2.0)
+PKG_CHECK_MODULES(LIBGPOD, glib-2.0 gobject-2.0)
LIBGPOD_CFLAGS="$LIBGPOD_CFLAGS -Wall"
AC_SUBST(LIBGPOD_CFLAGS)
AC_SUBST(LIBGPOD_LIBS)
@@ -70,6 +70,12 @@ AC_SUBST(GDKPIXBUF_CFLAGS)
AC_SUBST(GDKPIXBUF_LIBS)
dnl **************************************************
+dnl * hal is optional
+dnl **************************************************
+
+AC_CHECK_LIB([hal], [libhal_device_get_property_uint64])
+
+dnl **************************************************
dnl * internationalization support
dnl **************************************************
ALL_LINGUAS="de fr he it ja sv"