summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2005-11-08 09:22:07 +0000
committerChristophe Fergeau <teuf@gnome.org>2005-11-08 09:22:07 +0000
commit1e11739a2d1cdd202700f78e358fc315533659a3 (patch)
treeea3f5682a898f2a00aa67944d18772b4dcf0b3b2 /configure.ac
parentbf46e1695894bba62a06e8e22f4cca29f7ae033a (diff)
downloadlibgpod-1e11739a2d1cdd202700f78e358fc315533659a3.tar.gz
libgpod-1e11739a2d1cdd202700f78e358fc315533659a3.tar.xz
libgpod-1e11739a2d1cdd202700f78e358fc315533659a3.zip
2005-11-08 Christophe Fergeau <teuf@gnome.org>
* configure.ac: fixed hal detection, stole a bit more autoconf-fu from libipoddevice so that ipod-device.c compiles when hal is detected git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1146 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 22 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8642b01..1fd18fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,13 +72,32 @@ dnl **************************************************
dnl * hal is optional
dnl **************************************************
-PKG_CHECK_MODULES(HAL, hal >= 0.5.2 hal < 0.6, enable_hal05=yes, enable_hal05=no)
-if test x$enable_hal05 != xyes; then
- AC_DEFINE_UNQUOTED(HAVE_HAL, 1, [Whether HAL is available or not])
+PKG_CHECK_MODULES(HAL, dbus-1 dbus-glib-1 hal >= 0.5.2 hal < 0.6, enable_hal05=yes, enable_hal05=no)
+if test x$enable_hal05 == xyes; then
+ AC_DEFINE_UNQUOTED(HAVE_LIBHAL, 1, [Whether HAL is available or not])
fi
LIBGPOD_CFLAGS="$LIBGPOD_CFLAGS $HAL_CFLAGS"
LIBGPOD_LIBS="$LIBGPOD_LIBS $HAL_LIBS"
+dnl **************************************************
+dnl * necessary for the HAL libipoddevice code
+dnl **************************************************
+AC_PATH_PROG(EJECT_PATH, eject, eject)
+AC_PATH_PROG(UNMOUNT_PATH, pumount, no)
+
+if test "x$UNMOUNT_PATH" = "xno"; then
+ AC_PATH_PROG(UNMOUNT_PATH_ALT, umount, umount)
+ UNMOUNT_PATH=$UNMOUNT_PATH_ALT
+fi
+
+AC_ARG_WITH(eject-command, AC_HELP_STRING(--with-eject-command], [Command to invoke in order to eject a device]),
+ eject_command="$withval", eject_command="${EJECT_PATH} %d")
+AC_DEFINE_UNQUOTED([EJECT_COMMAND], ["${eject_command}"], [eject command])
+
+AC_ARG_WITH(unmount-command, AC_HELP_STRING(--with-unmount-command], [Command to invoke in order to unmount a device]),
+ unmount_command="$withval", unmount_command="${UNMOUNT_PATH} %d")
+AC_DEFINE_UNQUOTED([UNMOUNT_COMMAND], ["${unmount_command}"], [unmount command])
+
dnl **************************************************
dnl * internationalization support