summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <teuf@gnome.org>2007-11-06 19:44:12 +0000
committerChristophe Fergeau <teuf@gnome.org>2007-11-06 19:44:12 +0000
commitff2ab777950a4b2bc8ce1719c0a73114a5445ceb (patch)
tree29077505b80812cf51abbed540c28c55e788825f /tools/Makefile.am
parentecae67fbdfacd08e474298447ce978f4318c5e0d (diff)
downloadlibgpod-tmz-ff2ab777950a4b2bc8ce1719c0a73114a5445ceb.tar.gz
libgpod-tmz-ff2ab777950a4b2bc8ce1719c0a73114a5445ceb.tar.xz
libgpod-tmz-ff2ab777950a4b2bc8ce1719c0a73114a5445ceb.zip
* configure.ac:
* tools/20-libgpod-sysinfo-extended.fdi: * tools/Makefile.am: * tools/hal-callout.c: * tools/ipod-scsi-inquiry.c: * tools/read-sysinfoextended-sgutils.c: add hal callout which automatically write SysinfoExtended to iPods when they are plugged if it's properly installed git-svn-id: https://gtkpod.svn.sf.net/svnroot/gtkpod/libgpod/trunk@1760 f01d2545-417e-4e96-918e-98f8d0dbbcb6
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am24
1 files changed, 22 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index bbd5159..18c24bd 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -2,8 +2,28 @@ if HAVE_SGUTILS
bin_PROGRAMS=ipod-read-sysinfo-extended
-ipod_read_sysinfo_extended_SOURCES = read-sysinfoextended-sgutils.c
+ipod_read_sysinfo_extended_SOURCES = \
+ read-sysinfoextended-sgutils.c \
+ ipod-scsi-inquiry.c
ipod_read_sysinfo_extended_CFLAGS=$(LIBGPOD_CFLAGS) $(SGUTILS_CFLAGS) -I$(top_srcdir)/src
ipod_read_sysinfo_extended_LDADD=$(LIBGPOD_LIBS) $(SGUTILS_LIBS) $(top_builddir)/src/libgpod.la
-endif \ No newline at end of file
+if HAVE_HAL
+haldir = $(HALCALLOUTSDIR)
+hal_PROGRAMS = libgpod-callout
+
+libgpod_callout_SOURCES = \
+ hal-callout.c \
+ ipod-scsi-inquiry.c
+libgpod_callout_CFLAGS=$(LIBGPOD_CFLAGS) $(SGUTILS_CFLAGS) -I$(top_srcdir)/src
+libgpod_callout_LDADD=$(LIBGPOD_LIBS) $(SGUTILS_LIBS) $(top_builddir)/src/libgpod.la
+
+fdidir = $(datadir)/hal/fdi/policy/20thirdparty
+fdi_DATA = 20-libgpod-sysinfo-extended.fdi
+
+EXTRA_DIST = $(fdi_DATA)
+
+endif
+
+endif
+