summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec351
1 files changed, 300 insertions, 51 deletions
diff --git a/kernel.spec b/kernel.spec
index f2c8d8c73..7240fdbbd 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -1,4 +1,30 @@
-# We have to override the new %%install behavior because, well... the kernel is special.
+# All Global changes to build and install go here.
+# Per the below section about __spec_install_pre, any rpm
+# environment changes that affect %%install need to go
+# here before the %%install macro is pre-built.
+
+# Disable LTO in userspace packages.
+%global _lto_cflags %{nil}
+
+
+
+# The kernel's %%install section is special
+# Normally the %%install section starts by cleaning up the BUILD_ROOT
+# like so:
+#
+# %%__spec_install_pre %%{___build_pre}\
+# [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf "${RPM_BUILD_ROOT}"\
+# mkdir -p `dirname "$RPM_BUILD_ROOT"`\
+# mkdir "$RPM_BUILD_ROOT"\
+# %%{nil}
+#
+# But because of kernel variants, the %%build section, specifically
+# BuildKernel(), moves each variant to its final destination as the
+# variant is built. This violates the expectation of the %%install
+# section. As a result we snapshot the current env variables and
+# purposely leave out the removal section. All global wide changes
+# should be added above this line otherwise the %%install section
+# will not see them.
%global __spec_install_pre %{___build_pre}
# Short-term fix so the package builds with GCC 10.
@@ -30,7 +56,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
-%global distro_build 36
+%global distro_build 98
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -57,6 +83,8 @@ Summary: The Linux kernel
%if %{zipmodules}
%global zipsed -e 's/\.ko$/\.ko.xz/'
+# for parallel xz processes, replace with 1 to go back to single process
+%global zcpu `nproc --all`
%endif
# define buildid .local
@@ -70,21 +98,20 @@ Summary: The Linux kernel
%define primary_target rhel
%endif
-%define rpmversion 5.9.1
-%define pkgrelease 350
+%define rpmversion 5.10.1
+%define pkgrelease 98
# This is needed to do merge window version magic
-%define patchlevel 9
+%define patchlevel 10
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 36%{?buildid}%{?dist}
+%define specrelease 98%{?buildid}%{?dist}
%define pkg_release %{specrelease}
-# What parts do we want to build? We must build at least one kernel.
-# These are the kernels that are built IF the architecture allows it.
-# All should default to 1 (enabled) and be flipped to 0 (disabled)
-# by later arch-specific checks.
+# What parts do we want to build? These are the kernels that are built IF the
+# architecture allows it. All should default to 1 (enabled) and be flipped to
+# 0 (disabled) by later arch-specific checks.
# The following build options are enabled by default.
# Use either --without <opt> in your rpmbuild command or force values
@@ -171,7 +198,7 @@ Summary: The Linux kernel
%define debugbuildsenabled 1
# The kernel tarball/base version
-%define kversion 5.9
+%define kversion 5.10
%if 0%{?fedora}
# Kernel headers are being split out into a separate package
@@ -184,10 +211,10 @@ Summary: The Linux kernel
# no whitelist
%define with_kernel_abi_whitelists 0
# Fedora builds these separately
-%endif
%define with_perf 0
%define with_tools 0
%define with_bpftool 0
+%endif
%if %{with_verbose}
%define make_opts V=1
@@ -478,9 +505,7 @@ BuildRequires: kmod, patch, bash, tar, git-core
BuildRequires: bzip2, xz, findutils, gzip, m4, perl-interpreter, perl-Carp, perl-devel, perl-generators, make, diffutils, gawk
BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc, bison, flex
BuildRequires: net-tools, hostname, bc, elfutils-devel
-%if 0%{?fedora}
BuildRequires: dwarves
-%endif
BuildRequires: python3-devel
%if %{with_headers}
BuildRequires: rsync
@@ -501,6 +526,7 @@ BuildRequires: numactl-devel
%endif
%if %{with_tools}
BuildRequires: gettext ncurses-devel
+BuildRequires: libcap-devel libcap-ng-devel
%ifnarch s390x
BuildRequires: pciutils-devel
%endif
@@ -520,9 +546,7 @@ BuildConflicts: rhbuildsys(DiskFree) < 500Mb
%if %{with_debuginfo}
BuildRequires: rpm-build, elfutils
BuildConflicts: rpm < 4.13.0.1-19
-%if 0%{?fedora}
BuildConflicts: dwarves < 1.13
-%endif
# Most of these should be enabled after more investigation
%undefine _include_minidebuginfo
%undefine _find_debuginfo_dwz_opts
@@ -568,7 +592,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.9.tar.xz
+Source0: linux-5.10.tar.xz
Source1: Makefile.rhelver
@@ -697,8 +721,8 @@ Source211: Module.kabi_dup_ppc64le
Source212: Module.kabi_dup_s390x
Source213: Module.kabi_dup_x86_64
-Source300: kernel-abi-whitelists-5.9.0-%{distro_build}.tar.bz2
-Source301: kernel-kabi-dw-5.9.0-%{distro_build}.tar.bz2
+Source300: kernel-abi-whitelists-5.10.0-%{distro_build}.tar.bz2
+Source301: kernel-kabi-dw-5.10.0-%{distro_build}.tar.bz2
# Sources for kernel-tools
Source2000: cpupower.service
@@ -715,7 +739,7 @@ Source4000: README.rst
## Patches needed for building this package
-Patch1: patch-5.9.1.xz
+Patch1: patch-5.10.1.xz
%if !%{nopatches}
@@ -1214,13 +1238,13 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.9 -c
-mv linux-5.9 linux-%{KVERREL}
+%setup -q -n kernel-5.10 -c
+mv linux-5.10 linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
-ApplyPatch patch-5.9.1.xz
+ApplyPatch patch-5.10.1.xz
head Makefile
%if !%{nopatches}
@@ -1259,7 +1283,7 @@ pathfix.py -i "%{__python3} %{py3_shbang_opts}" -p -n \
tools/perf/scripts/python/sched-migration.py \
tools/testing/selftests/drivers/net/mlxsw/sharedbuffer_configuration.py \
Documentation \
- scripts/gen_compile_commands.py
+ scripts/clang-tools
# only deal with configs if we are going to build for the arch
%ifnarch %nobuildarches
@@ -1345,33 +1369,18 @@ cp_vmlinux()
%define make %{__make} %{?cross_opts} %{?make_opts} HOSTCFLAGS="%{?build_hostcflags}" HOSTLDFLAGS="%{?build_hostldflags}"
-BuildKernel() {
- MakeTarget=$1
- KernelImage=$2
- Flavour=$4
- DoVDSO=$3
- Flav=${Flavour:++${Flavour}}
- InstallName=${5:-vmlinuz}
+InitBuildVars() {
+ # Initialize the kernel .config file and create some variables that are
+ # needed for the actual build process.
- DoModules=1
- if [ "$Flavour" = "zfcpdump" ]; then
- DoModules=0
- fi
+ Flavour=$1
+ Flav=${Flavour:++${Flavour}}
- # Pick the right config file for the kernel we're building
+ # Pick the right kernel config file
Config=kernel-%{version}-%{_target_cpu}${Flavour:+-${Flavour}}.config
DevelDir=/usr/src/kernels/%{KVERREL}${Flav}
- # When the bootable image is just the ELF kernel, strip it.
- # We already copy the unstripped file into the debuginfo package.
- if [ "$KernelImage" = vmlinux ]; then
- CopyKernel=cp_vmlinux
- else
- CopyKernel=cp
- fi
-
KernelVer=%{version}-%{release}.%{_target_cpu}${Flav}
- echo BUILDING A KERNEL FOR ${Flavour} %{_target_cpu}...
# make sure EXTRAVERSION says what we want it to say
# Trim the release if this is a CI build, since KERNELVERSION is limited to 64 characters
@@ -1382,8 +1391,6 @@ BuildKernel() {
# if we are post rc1 this should match anyway so this won't matter
perl -p -i -e 's/^PATCHLEVEL.*/PATCHLEVEL = %{patchlevel}/' Makefile
- # and now to start the build process
-
%{make} %{?_smp_mflags} mrproper
cp configs/$Config .config
@@ -1400,6 +1407,32 @@ BuildKernel() {
if [ "$Flavour" == "" ]; then
KCFLAGS="$KCFLAGS %{?kpatch_kcflags}"
fi
+}
+
+BuildKernel() {
+ MakeTarget=$1
+ KernelImage=$2
+ Flavour=$4
+ DoVDSO=$3
+ Flav=${Flavour:++${Flavour}}
+ InstallName=${5:-vmlinuz}
+
+ DoModules=1
+ if [ "$Flavour" = "zfcpdump" ]; then
+ DoModules=0
+ fi
+
+ # When the bootable image is just the ELF kernel, strip it.
+ # We already copy the unstripped file into the debuginfo package.
+ if [ "$KernelImage" = vmlinux ]; then
+ CopyKernel=cp_vmlinux
+ else
+ CopyKernel=cp
+ fi
+
+ InitBuildVars $Flavour
+
+ echo BUILDING A KERNEL FOR ${Flavour} %{_target_cpu}...
%{make} ARCH=$Arch olddefconfig >/dev/null
@@ -1926,6 +1959,14 @@ BuildKernel %make_target %kernel_image %{use_vdso} lpae
BuildKernel %make_target %kernel_image %{_use_vdso}
%endif
+%ifnarch noarch i686
+%if !%{with_debug} && !%{with_zfcpdump} && !%{with_up}
+# If only building the user space tools, then initialize the build environment
+# and some variables so that the various userspace tools can be built.
+InitBuildVars
+%endif
+%endif
+
%global perf_make \
%{__make} -s EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 prefix=%{_prefix} PYTHON=%{__python3}
%if %{with_perf}
@@ -2026,7 +2067,7 @@ find Documentation -type d | xargs chmod u+w
fi \
fi \
if [ "%{zipmodules}" -eq "1" ]; then \
- find $RPM_BUILD_ROOT/lib/modules/ -type f -name '*.ko' | %{SOURCE79} %{?_smp_mflags}; \
+ find $RPM_BUILD_ROOT/lib/modules/ -type f -name '*.ko' | xargs -P%{zcpu} xz; \
fi \
%{nil}
@@ -2643,10 +2684,218 @@ fi
#
#
%changelog
-* Mon Oct 12 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-35]
+* Mon Dec 14 2020 Justin M. Forbes <jforbes@fedoraproject.org> [5.10.0-98]
+- Add missing '$' sign to (GIT) in redhat/Makefile (Augusto Caringi)
+
+* Sat Dec 12 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.20201212git7f376f1917d7.97]
+- Remove filterdiff and use native git instead (Don Zickus)
+- New configs in net/sched ("Justin M. Forbes")
+
+* Fri Dec 11 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.20201211git33dc9614dc20.96]
+- redhat: explicitly disable CONFIG_IMA_APPRAISE_SIGNED_INIT (Bruno Meneguele)
+- redhat: enable CONFIG_EVM_LOAD_X509 on ARK (Bruno Meneguele)
+- redhat: enable CONFIG_EVM_ATTR_FSUUID on ARK (Bruno Meneguele)
+- redhat: enable CONFIG_EVM in all arches and flavors (Bruno Meneguele)
+- redhat: enable CONFIG_IMA_LOAD_X509 on ARK (Bruno Meneguele)
+- redhat: set CONFIG_IMA_DEFAULT_HASH to SHA256 (Bruno Meneguele)
+- redhat: enable CONFIG_IMA_SECURE_AND_OR_TRUSTED_BOOT (Bruno Meneguele)
+- redhat: enable CONFIG_IMA_READ_POLICY on ARK (Bruno Meneguele)
+- redhat: set default IMA template for all ARK arches (Bruno Meneguele)
+- redhat: enable CONFIG_IMA_DEFAULT_HASH_SHA256 for all flavors (Bruno Meneguele)
+- redhat: disable CONFIG_IMA_DEFAULT_HASH_SHA1 (Bruno Meneguele)
+- redhat: enable CONFIG_IMA_ARCH_POLICY for ppc and x86 (Bruno Meneguele)
+- redhat: enable CONFIG_IMA_APPRAISE_MODSIG (Bruno Meneguele)
+- redhat: enable CONFIG_IMA_APPRAISE_BOOTPARAM (Bruno Meneguele)
+- redhat: enable CONFIG_IMA_APPRAISE (Bruno Meneguele)
+- redhat: enable CONFIG_INTEGRITY for aarch64 (Bruno Meneguele)
+- Temporarily backout parallel xz script ("Justin M. Forbes")
+- New configs in drivers/mfd (Fedora Kernel Team)
+- New configs in drivers/mfd ("CKI@GitLab")
+- New configs in drivers/firmware (Fedora Kernel Team)
+
+* Thu Dec 10 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.20201210gita2f5ea9e314b.95]
+- kernel: Update some missing KASAN/KCSAN options (Jeremy Linton)
+- kernel: Enable coresight on aarch64 (Jeremy Linton)
+
+* Wed Dec 09 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.20201209gita68a0262abda.94]
+- Update CONFIG_INET6_ESPINTCP (Justin Forbes)
+- New configs in net/ipv6 ("Justin M. Forbes")
+
+* Tue Dec 08 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.93]
+- fedora: move CONFIG_RTC_NVMEM options from ark to common (Peter Robinson)
+
+* Mon Dec 07 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc7.92]
+- configs: Enable CONFIG_DEBUG_INFO_BTF (Don Zickus)
+
+* Thu Dec 03 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc6.20201203git34816d20f173.91]
+- fedora: some minor arm audio config tweaks (Peter Robinson)
+- Ship xpad with default modules on Fedora and RHEL (Bastien Nocera)
+
+* Wed Dec 02 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc6.20201202git509a15421674.90]
+- Fedora config update ("Justin M. Forbes")
+- Fedora config change because CONFIG_FSL_DPAA2_ETH now selects CONFIG_FSL_XGMAC_MDIO ("Justin M. Forbes")
+- Fedora: Only enable legacy serial/game port joysticks on x86 (Peter Robinson)
+- Fedora: Enable the options required for the Librem 5 Phone (Peter Robinson)
+
+* Fri Nov 20 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc4.20201120git4d02da974ea8.81]
+- Fedora config update ("Justin M. Forbes")
+- redhat: generic enable CONFIG_INET_MPTCP_DIAG (Davide Caratti)
+
+* Thu Nov 19 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc4.20201119gitc2e7554e1b85.79.test]
+- c2e7554e1b85 rebase
+- Enable NANDSIM for Fedora ("Justin M. Forbes")
+- Re-enable CONFIG_ACPI_TABLE_UPGRADE for Fedora since upstream disables this if secureboot is active ("Justin M. Forbes")
+
+* Wed Nov 18 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc4.20201118git0fa8ee0d9ab9.78.test]
+- 0fa8ee0d9ab9 rebase
+
+* Tue Nov 17 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc4.20201117git9c87c9f41245.77.test]
+- 9c87c9f41245 rebase
+
+* Mon Nov 16 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc4.76.test]
+- v5.10-rc4 rebase
+- Ath11k related config updates ("Justin M. Forbes")
+- Fedora config updates for ath11k ("Justin M. Forbes")
+
+* Sun Nov 15 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc3.20201115gite28c0d7c92c8.74.test]
+- e28c0d7c92c8 rebase
+
+* Sat Nov 14 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc3.20201114gitf01c30de86f1.73.test]
+- f01c30de86f1 rebase
+- Turn on ATH11K for Fedora ("Justin M. Forbes")
+
+* Fri Nov 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc3.20201113git585e5b17b92d.72.test]
+- 585e5b17b92d rebase
+
+* Thu Nov 12 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc3.20201112git3d5e28bff7ad.71.test]
+- 3d5e28bff7ad rebase
+
+* Wed Nov 11 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc3.20201111giteccc87672492.68.test]
+- eccc87672492 rebase
+- redhat: enable CONFIG_INTEL_IOMMU_SVM (Jerry Snitselaar)
+
+* Tue Nov 10 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc3.67.test]
+- More Fedora config fixes ("Justin M. Forbes")
+- Fedora 5.10 config updates ("Justin M. Forbes")
+
+* Mon Nov 09 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc3.66.test]
+- v5.10-rc3 rebase
+
+* Sun Nov 08 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc2.20201108git4429f14aeea9.65.test]
+- 4429f14aeea9 rebase
+
+* Sat Nov 07 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc2.20201107git659caaf65dc9.64.test]
+- 659caaf65dc9 rebase
+
+* Fri Nov 06 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc2.20201106git521b619acdc8.63.test]
+- 521b619acdc8 rebase
+- Fedora 5.10 configs round 1 ("Justin M. Forbes")
+
+* Wed Nov 04 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc2.20201104git4ef8451b3326.62.test]
+- 4ef8451b3326 rebase
+
+* Mon Nov 02 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc2.61.test]
+- v5.10-rc2 rebase
+
+* Sun Nov 01 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc1.20201101gitc2dc4c073fb7.60.test]
+- c2dc4c073fb7 rebase
+
+* Sat Oct 31 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc1.20201031git5fc6b075e165.59.test]
+- 5fc6b075e165 rebase
+- Allow building of kernel-tools standalone (Don Zickus)
+- Allow kernel-tools to build without selftests (Don Zickus)
+
+* Fri Oct 30 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc1.20201030git07e088730245.58.test]
+- 07e088730245 rebase
+- Fix LTO issues with kernel-tools (Don Zickus)
+- New configs in drivers/mfd (Fedora Kernel Team)
+- arm64/defconfig: Enable CONFIG_KEXEC_FILE (Bhupesh Sharma) [https://bugzilla.redhat.com/show_bug.cgi?id=1821565]
+- redhat/configs: Cleanup CONFIG_CRYPTO_SHA512 (Prarit Bhargava)
+- redhat: ark: disable CONFIG_NET_ACT_CTINFO (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_TEQL (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_SFB (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_QFQ (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_PLUG (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_PIE (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_MULTIQ (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_HHF (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_DSMARK (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_DRR (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_CODEL (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_CHOKE (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_CBQ (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_SCH_ATM (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_EMATCH and sub-targets (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_CLS_TCINDEX (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_CLS_RSVP6 (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_CLS_RSVP (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_CLS_ROUTE4 (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_CLS_BASIC (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_ACT_SKBMOD (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_ACT_SIMP (Davide Caratti)
+- redhat: ark: disable CONFIG_NET_ACT_NAT (Davide Caratti)
+
+* Thu Oct 29 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc1.20201029git23859ae44402.57.test]
+- 23859ae44402 rebase
+
+* Thu Oct 29 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc1.20201029gited8780e3f2ec.56.test]
+- Point pathfix to the new location for gen_compile_commands.py ("Justin M. Forbes")
- Filter out LTO build options from the perl ccopts ("Justin M. Forbes")
-- Temporarily remove cdomain from sphinx documentation ("Justin M. Forbes")
-- Work around for gcc bug https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96377 ("Justin M. Forbes")
+
+* Wed Oct 28 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc1.20201028gited8780e3f2ec.55.test]
+- ed8780e3f2ec rebase
+- Fix up a merge issue with rxe.c ("Justin M. Forbes")
+- configs: Disable CONFIG_SECURITY_SELINUX_DISABLE (Ondrej Mosnacek)
+
+* Mon Oct 26 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc1.54.test]
+- v5.10-rc1 rebase
+
+* Sat Oct 24 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201024git96485e446260.51.test]
+- [Automatic] Handle config dependency changes (Don Zickus)
+
+* Thu Oct 22 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201022git96485e446260.49.test]
+- 96485e446260 rebase
+
+* Thu Oct 22 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201022gitf804b3159482.48.test]
+- f804b3159482 rebase
+- New configs in kernel/trace (Fedora Kernel Team)
+- configs/iommu: Add config comment to empty CONFIG_SUN50I_IOMMU file (Jerry Snitselaar)
+
+* Tue Oct 20 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201020git071a0578b0ce.47.test]
+- Fix Fedora config locations ("Justin M. Forbes")
+- Fedora config updates ("Justin M. Forbes")
+
+* Sat Oct 17 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201017git071a0578b0ce.44.test]
+- 071a0578b0ce rebase
+- configs: enable CONFIG_CRYPTO_CTS=y so cts(cbc(aes)) is available in FIPS mode (Vladis Dronov)
+
+* Fri Oct 16 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201016git9ff9b0d392ea.43.test]
+- 9ff9b0d392ea rebase
+- Partial revert: Add master merge check (Don Zickus)
+
+* Fri Oct 16 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201016git578a7155c5a1.42.test]
+- 578a7155c5a1 rebase
+- Update Maintainers doc to reflect workflow changes (Don Zickus)
+
+* Thu Oct 15 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201015git3e4fb4346c78.41.test]
+- 3e4fb4346c78 rebase
+- WIP: redhat/docs: Update documentation for single branch workflow (Prarit Bhargava)
+
+* Thu Oct 15 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201015gitb5fc7a89e58b.40.test]
+- Add CONFIG_ARM64_MTE which is not picked up by the config scripts for some reason ("Justin M. Forbes")
+
+* Wed Oct 14 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201014gitb5fc7a89e58b.39.test]
+- b5fc7a89e58b rebase
+
+* Tue Oct 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201013gitc4439713e82a.38.test]
+- c4439713e82a rebase
+
+* Tue Oct 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201013git865c50e1d279.37.test]
+- 865c50e1d279 rebase
+
+* Tue Oct 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-35.test]
+- Disable Speakup synth DECEXT ("Justin M. Forbes")
+- Enable Speakup for Fedora since it is out of staging ("Justin M. Forbes")
* Mon Oct 12 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-34.test]
- v5.9 rebase