summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec41
1 files changed, 21 insertions, 20 deletions
diff --git a/kernel.spec b/kernel.spec
index 2d8a3e8f1..efe1690df 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -105,6 +105,8 @@ Summary: The Linux kernel
%endif
# define buildid .local
+%define packager Thorsten Leemhuis https://fedoraproject.org/wiki/Kernel_Vanilla_Repositories
+%define buildid .vanilla.1
%if 0%{?fedora}
@@ -112,6 +114,7 @@ Summary: The Linux kernel
%else
%define primary_target rhel
%endif
+%define fedorabase 5.13.1
# The kernel tarball/base version
%define kversion 5.13
@@ -124,7 +127,7 @@ Summary: The Linux kernel
%define patchlevel 13
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 300%{?buildid}%{?dist}
+%define specrelease 325%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -141,7 +144,7 @@ Summary: The Linux kernel
# kernel PAE (only valid for ARM (lpae))
%define with_pae %{?_without_pae: 0} %{?!_without_pae: 1}
# kernel-debug
-%define with_debug %{?_without_debug: 0} %{?!_without_debug: 1}
+%define with_debug %{?_with_debug: 1} %{?!_with_debug: 0}
# kernel-zfcpdump (s390 specific kernel for zfcpdump)
%define with_zfcpdump %{?_without_zfcpdump: 0} %{?!_without_zfcpdump: 1}
# kernel-doc
@@ -156,7 +159,7 @@ Summary: The Linux kernel
# bpf tool
%define with_bpftool %{?_without_bpftool: 0} %{?!_without_bpftool: 1}
# kernel-debuginfo
-%define with_debuginfo %{?_without_debuginfo: 0} %{?!_without_debuginfo: 1}
+%define with_debuginfo %{?_with_debuginfo: 1} %{?!_with_debuginfo: 0}
# kernel-abi-whitelists
%define with_kernel_abi_whitelists %{?_without_kernel_abi_whitelists: 0} %{?!_without_kernel_abi_whitelists: 1}
# internal samples and selftests
@@ -192,7 +195,7 @@ Summary: The Linux kernel
%define with_cross %{?_with_cross: 1} %{?!_with_cross: 0}
#
# build a release kernel on rawhide
-%define with_release %{?_with_release: 1} %{?!_with_release: 0}
+%define with_release %{?_without_release: 0} %{?!_without_release: 1}
# verbose build, i.e. no silent rules and V=1
%define with_verbose %{?_with_verbose: 1} %{?!_with_verbose: 0}
@@ -210,7 +213,7 @@ Summary: The Linux kernel
%define with_ipaclones %{?_without_ipaclones: 0} %{?!_without_ipaclones: 1}
# Want to build a vanilla kernel build without any non-upstream patches?
-%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
+%define with_vanilla %{?_without_vanilla: 0} %{?!_without_vanilla: 1}
%if 0%{?fedora}
# Kernel headers are being split out into a separate package
@@ -778,8 +781,8 @@ Source211: Module.kabi_dup_ppc64le
Source212: Module.kabi_dup_s390x
Source213: Module.kabi_dup_x86_64
-Source300: kernel-abi-whitelists-%{rpmversion}-%{distro_build}.tar.bz2
-Source301: kernel-kabi-dw-%{rpmversion}-%{distro_build}.tar.bz2
+Source300: kernel-abi-whitelists-%{fedorabase}-%{distro_build}.tar.bz2
+Source301: kernel-kabi-dw-%{fedorabase}-%{distro_build}.tar.bz2
# Sources for kernel-tools
Source2000: cpupower.service
@@ -1319,7 +1322,7 @@ ApplyOptionalPatch()
mv linux-5.13.2 linux-%{KVERREL}
cd linux-%{KVERREL}
-cp -a %{SOURCE1} .
+# cp -a %{SOURCE1} .
%if !%{nopatches}
@@ -1330,6 +1333,8 @@ ApplyOptionalPatch linux-kernel-test.patch
# END OF PATCH APPLICATIONS
+head Makefile
+
# Any further pre-build tree manipulations happen here.
chmod +x scripts/checkpatch.pl
@@ -1649,7 +1654,6 @@ BuildKernel() {
(cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
# dirs for additional modules per module-init-tools, kbuild/modules.txt
mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
- mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/weak-updates
# CONFIG_KERNEL_HEADER_TEST generates some extra files in the process of
# testing so just delete
find . -name *.h.s -delete
@@ -2578,12 +2582,6 @@ fi\
#
%define kernel_variant_posttrans() \
%{expand:%%posttrans %{?1:%{1}-}core}\
-%if 0%{!?fedora:1}\
-if [ -x %{_sbindir}/weak-modules ]\
-then\
- %{_sbindir}/weak-modules --add-kernel %{KVERREL}%{?1:+%{1}} || exit $?\
-fi\
-%endif\
/bin/kernel-install add %{KVERREL}%{?1:+%{1}} /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz || exit $?\
%{nil}
@@ -2613,10 +2611,6 @@ fi}\
%define kernel_variant_preun() \
%{expand:%%preun %{?1:%{1}-}core}\
/bin/kernel-install remove %{KVERREL}%{?1:+%{1}} /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz || exit $?\
-if [ -x %{_sbindir}/weak-modules ]\
-then\
- %{_sbindir}/weak-modules --remove-kernel %{KVERREL}%{?1:+%{1}} || exit $?\
-fi\
%{nil}
%kernel_variant_preun
@@ -2832,7 +2826,6 @@ fi
/lib/modules/%{KVERREL}%{?3:+%{3}}/build\
/lib/modules/%{KVERREL}%{?3:+%{3}}/source\
/lib/modules/%{KVERREL}%{?3:+%{3}}/updates\
-/lib/modules/%{KVERREL}%{?3:+%{3}}/weak-updates\
%{_datadir}/doc/kernel-keys/%{KVERREL}%{?3:+%{3}}\
%if %{1}\
/lib/modules/%{KVERREL}%{?3:+%{3}}/vdso\
@@ -3782,6 +3775,14 @@ fi
- [initial commit] Add configs (Laura Abbott)
- [initial commit] Add Makefiles (Laura Abbott)
+* Sat Oct 20 2012 Thorsten Leemhuis <fedora@leemhuis.info>
+- add buildid ".vanilla.knurd.1"
+- switch defines to build
+ - a vanilla kernel without debuging
+ - no debug kernel and no debuginfo packages, to big to handle for me right now
+- disable the variant macro as that adds "-vanilla" to %%name, which confuses
+ fedpkg and prevents installonly handling of packages in yum
+
# The following bit is important for automation so please do not remove
# END OF CHANGELOG