summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec37
1 files changed, 31 insertions, 6 deletions
diff --git a/kernel.spec b/kernel.spec
index 0eedb874a..774d6810c 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -54,6 +54,8 @@ Summary: The Linux kernel
%endif
# define buildid .local
+%define packager Thorsten Leemhuis https://fedoraproject.org/wiki/Kernel_Vanilla_Repositories
+%define buildid .vanilla.knurd.1
%if 0%{?fedora}
%define primary_target fedora
@@ -77,7 +79,8 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 101
+%global baserelease 150
+
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
@@ -88,12 +91,19 @@ Summary: The Linux kernel
## If this is a released kernel ##
%if 0%{?released_kernel}
+# Is it a -stable RC?
+%define stable_rc 0
+
# Do we have a -stable update to apply?
%define stable_update 6
# Set rpm version accordingly
%if 0%{?stable_update}
%define stablerev %{stable_update}
%define stable_base %{stable_update}
+%if 0%{?stable_rc}
+# stable RCs are incremental patches, so we need the previous stable patch
+%define stable_base %(echo $((%{stable_update} - 1)))
+%endif
%endif
%define rpmversion 5.%{base_sublevel}.%{stable_update}
@@ -124,7 +134,7 @@ Summary: The Linux kernel
# kernel PAE (only valid for ARM (lpae))
%define with_pae %{?_without_pae: 0} %{?!_without_pae: 1}
# kernel-debug
-%define with_debug %{?_without_debug: 0} %{?!_without_debug: 1}
+%define with_debug %{?_with_debug: 1} %{?!_with_debug: 0}
# kernel-doc
%define with_doc %{?_without_doc: 0} %{?!_without_doc: 1}
# kernel-headers
@@ -137,7 +147,7 @@ Summary: The Linux kernel
# bpf tool
%define with_bpftool %{?_without_bpftool: 0} %{?!_without_bpftool: 1}
# kernel-debuginfo
-%define with_debuginfo %{?_without_debuginfo: 0} %{?!_without_debuginfo: 1}
+%define with_debuginfo %{?_with_debuginfo: 1} %{?!_with_debuginfo: 0}
# Want to build a the vsdo directories installed
%define with_vdso_install %{?_without_vdso_install: 0} %{?!_without_vdso_install: 1}
# kernel-zfcpdump (s390 specific kernel for zfcpdump)
@@ -174,7 +184,7 @@ Summary: The Linux kernel
%define with_cross %{?_with_cross: 1} %{?!_with_cross: 0}
#
# build a release kernel on rawhide
-%define with_release %{?_with_release: 1} %{?!_with_release: 0}
+%define with_release %{?_without_release: 0} %{?!_without_release: 1}
# verbose build, i.e. no silent rules and V=1
%define with_verbose %{?_with_verbose: 1} %{?!_with_verbose: 0}
@@ -221,10 +231,18 @@ Summary: The Linux kernel
%define make_opts -s
%endif
+# Want to build a vanilla kernel build without any non-upstream patches?
+%define with_vanilla %{?_without_vanilla: 0} %{?!_without_vanilla: 1}
+
# pkg_release is what we'll fill in for the rpm Release: field
%if 0%{?released_kernel}
+%if 0%{?stable_rc}
+%define stable_rctag .rc%{stable_rc}
+%define pkg_release 0%{stable_rctag}.%{fedora_build}%{?buildid}%{?dist}
+%else
%define pkg_release %{fedora_build}%{?buildid}%{?dist}
+%endif
%else
@@ -287,7 +305,7 @@ Summary: The Linux kernel
%endif
%if %{nopatches}
-%define variant -vanilla
+#define variant -vanilla
%endif
%if !%{debugbuildsenabled}
@@ -513,7 +531,7 @@ Release: %{pkg_release}
# DO NOT CHANGE THE 'ExclusiveArch' LINE TO TEMPORARILY EXCLUDE AN ARCHITECTURE BUILD.
# SET %%nobuildarches (ABOVE) INSTEAD
%if 0%{?fedora}
-ExclusiveArch: x86_64 s390x %{arm} aarch64 ppc64le
+ExclusiveArch: %{all_x86} x86_64 s390x %{arm} aarch64 ppc64le
%else
ExclusiveArch: noarch i386 i686 x86_64 s390x %{arm} aarch64 ppc64le
%endif
@@ -774,6 +792,10 @@ Source1000: kernel-local
%define stable_patch_00 patch-5.%{base_sublevel}.%{stable_base}.xz
Source5000: %{stable_patch_00}
%endif
+%if 0%{?stable_rc}
+%define stable_patch_01 patch-3.%{base_sublevel}.%{stable_update}-rc%{stable_rc}.xz
+Patch01: %{stable_patch_01}
+%endif
# non-released_kernel case
# These are automagically defined by the rcrev and gitrev values set up
@@ -1525,6 +1547,9 @@ fi
xzcat %{SOURCE5000} | patch -p1 -F1 -s
git commit -a -m "Stable update"
%endif
+%if 0%{?stable_rc}
+ApplyPatch %{stable_patch_01}
+%endif
# Note: Even in the "nopatches" path some patches (build tweaks and compile
# fixes) will always get applied; see patch defition above for details