summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec494
1 files changed, 255 insertions, 239 deletions
diff --git a/kernel.spec b/kernel.spec
index d53c8bd7f..7cb3d58a6 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -42,19 +42,19 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 300
+%global baserelease 1
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
# which yields a base_sublevel of 0.
-%define base_sublevel 9
+%define base_sublevel 10
## If this is a released kernel ##
%if 0%{?released_kernel}
# Do we have a -stable update to apply?
-%define stable_update 2
+%define stable_update 0
# Set rpm version accordingly
%if 0%{?stable_update}
%define stablerev %{stable_update}
@@ -67,7 +67,7 @@ Summary: The Linux kernel
# The next upstream release sublevel (base_sublevel+1)
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
# The rc snapshot level
-%define rcrev 0
+%global rcrev 0
# The git snapshot level
%define gitrev 0
# Set rpm version accordingly
@@ -313,8 +313,10 @@ Summary: The Linux kernel
# printed out?
%if %{nopatches}
%define listnewconfig_fail 0
+%define configmismatch_fail 0
%else
%define listnewconfig_fail 1
+%define configmismatch_fail 1
%endif
# To temporarily exclude an architecture from being built, add it to
@@ -425,38 +427,35 @@ Source98: filter-ppc64p7.sh
Source99: filter-modules.sh
%define modsign_cmd %{SOURCE18}
-Source19: Makefile.release
-Source20: Makefile.config
-Source21: config-debug
-Source22: config-nodebug
-Source23: config-generic
-Source24: config-no-extra
-
-Source30: config-x86-generic
-Source31: config-i686-PAE
-Source32: config-x86-32-generic
-
-Source40: config-x86_64-generic
-
-Source50: config-powerpc64-generic
-Source53: config-powerpc64
-Source54: config-powerpc64p7
-Source55: config-powerpc64le
-
-Source70: config-s390x
-
-Source100: config-arm-generic
-
-# Unified ARM kernels
-Source101: config-armv7-generic
-Source102: config-armv7
-Source103: config-armv7-lpae
-
-Source110: config-arm64
+Source20: kernel-aarch64.config
+Source21: kernel-aarch64-debug.config
+Source22: kernel-armv7hl.config
+Source23: kernel-armv7hl-debug.config
+Source24: kernel-armv7hl-lpae.config
+Source25: kernel-armv7hl-lpae-debug.config
+Source26: kernel-i686.config
+Source27: kernel-i686-debug.config
+Source28: kernel-i686-PAE.config
+Source29: kernel-i686-PAEdebug.config
+Source30: kernel-ppc64.config
+Source31: kernel-ppc64-debug.config
+Source32: kernel-ppc64le.config
+Source33: kernel-ppc64le-debug.config
+Source34: kernel-ppc64p7.config
+Source35: kernel-ppc64p7-debug.config
+Source36: kernel-s390x.config
+Source37: kernel-s390x-debug.config
+Source38: kernel-x86_64.config
+Source39: kernel-x86_64-debug.config
+
+Source40: generate_all_configs.sh
+Source41: generate_debug_configs.sh
+
+Source42: check_configs.awk
# This file is intentionally left empty in the stock kernel. Its a nicety
# added for those wanting to do custom rebuilds with altered config opts.
-Source1000: config-local
+Source1000: kernel-local
# Sources for kernel-tools
Source2000: cpupower.service
@@ -498,43 +497,49 @@ Source5005: kbuild-AFTER_LINK.patch
# Standalone patches
# a tempory patch for QCOM hardware enablement. Will be gone by end of 2016/F-26 GA
-Patch421: qcom-QDF2432-tmp-errata.patch
+Patch420: qcom-QDF2432-tmp-errata.patch
# http://www.spinics.net/lists/arm-kernel/msg490981.html
-Patch422: geekbox-v4-device-tree-support.patch
-
-# http://www.spinics.net/lists/linux-pci/msg53991.html
-# https://patchwork.kernel.org/patch/9337113/
-Patch425: arm64-pcie-quirks.patch
+Patch421: geekbox-v4-device-tree-support.patch
# http://www.spinics.net/lists/linux-tegra/msg26029.html
-Patch426: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
+Patch422: usb-phy-tegra-Add-38.4MHz-clock-table-entry.patch
# Fix OMAP4 (pandaboard)
-Patch427: arm-revert-mmc-omap_hsmmc-Use-dma_request_chan-for-reque.patch
-Patch428: ARM-OMAP4-Fix-crashes.patch
+Patch423: arm-revert-mmc-omap_hsmmc-Use-dma_request_chan-for-reque.patch
# Not particularly happy we don't yet have a proper upstream resolution this is the right direction
# https://www.spinics.net/lists/arm-kernel/msg535191.html
-Patch429: arm64-mm-Fix-memmap-to-be-initialized-for-the-entire-section.patch
+Patch424: arm64-mm-Fix-memmap-to-be-initialized-for-the-entire-section.patch
# http://patchwork.ozlabs.org/patch/587554/
-Patch430: ARM-tegra-usb-no-reset.patch
+Patch425: ARM-tegra-usb-no-reset.patch
-Patch431: bcm2837-initial-support.patch
+Patch426: AllWinner-net-emac.patch
-Patch432: bcm283x-vc4-fixes.patch
+# http://www.spinics.net/lists/arm-kernel/msg557831.html
+Patch427: arm64-dma-mapping-Fix-dma_mapping_error-when-bypassing-SWIOTLB.patch
-Patch433: bcm283x-fixes.patch
+# http://www.spinics.net/lists/devicetree/msg163238.html
+Patch430: bcm2837-initial-support.patch
# http://www.spinics.net/lists/linux-mmc/msg41151.html
-Patch434: bcm283x-mmc-imp-speed.patch
+Patch431: bcm283x-mmc-imp-speed.patch
+
+Patch432: bcm283x-VEC.patch
-Patch440: AllWinner-net-emac.patch
+# http://www.spinics.net/lists/dri-devel/msg132235.html
+Patch433: drm-vc4-Fix-OOPSes-from-trying-to-cache-a-partially-constructed-BO..patch
-Patch442: ARM-Drop-fixed-200-Hz-timer-requirement-from-Samsung-platforms.patch
+# Fix RPi3 from crashing. Nowhere near a final fix but provides breathing room while that is sorted
+# https://github.com/anholt/linux/issues/89
+Patch434: 0001-i2c-bcm2835-Debug-test-for-curr_msg.patch
-Patch443: imx6sx-Add-UDOO-Neo-support.patch
+# Upstream fixes for i2c/serial/ethernet MAC addresses
+Patch435: bcm283x-fixes.patch
+
+# http://www.spinics.net/lists/arm-kernel/msg552554.html
+Patch438: arm-imx6-hummingboard2.patch
Patch460: lib-cpumask-Make-CPUMASK_OFFSTACK-usable-without-deb.patch
@@ -550,33 +555,7 @@ Patch471: Kbuild-Add-an-option-to-enable-GCC-VTA.patch
Patch472: crash-driver.patch
-Patch473: Add-secure_modules-call.patch
-
-Patch474: PCI-Lock-down-BAR-access-when-module-security-is-ena.patch
-
-Patch475: x86-Lock-down-IO-port-access-when-module-security-is.patch
-
-Patch476: ACPI-Limit-access-to-custom_method.patch
-
-Patch477: asus-wmi-Restrict-debugfs-interface-when-module-load.patch
-
-Patch478: Restrict-dev-mem-and-dev-kmem-when-module-loading-is.patch
-
-Patch479: acpi-Ignore-acpi_rsdp-kernel-parameter-when-module-l.patch
-
-Patch480: kexec-Disable-at-runtime-if-the-kernel-enforces-modu.patch
-
-Patch481: x86-Restrict-MSR-access-when-module-loading-is-restr.patch
-
-Patch482: Add-option-to-automatically-enforce-module-signature.patch
-
-Patch483: efi-Add-SHIM-and-image-security-database-GUID-defini.patch
-
-Patch484: efi-Disable-secure-boot-if-shim-is-in-insecure-mode.patch
-
-Patch485: efi-Add-EFI_SECURE_BOOT-bit.patch
-
-Patch486: hibernate-Disable-in-a-signed-modules-environment.patch
+Patch473: efi-lockdown.patch
Patch487: Add-EFI-signature-data-types.patch
@@ -591,16 +570,12 @@ Patch490: MODSIGN-Import-certificates-from-UEFI-Secure-Boot.patch
Patch491: MODSIGN-Support-not-importing-certs-from-db.patch
-Patch492: Add-sysrq-option-to-disable-secure-boot-mode.patch
-
Patch493: drm-i915-hush-check-crtc-state.patch
Patch494: disable-i8042-check-on-apple-mac.patch
Patch495: lis3-improve-handling-of-null-rate.patch
-Patch496: watchdog-Disable-watchdog-on-virtual-machines.patch
-
Patch497: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
Patch498: criu-no-expert.patch
@@ -615,8 +590,6 @@ Patch502: firmware-Drop-WARN-from-usermodehelper_read_trylock-.patch
# Patch503: drm-i915-turn-off-wc-mmaps.patch
-Patch508: kexec-uefi-copy-secure_boot-flag-in-boot-params.patch
-
Patch509: MODSIGN-Don-t-try-secure-boot-if-EFI-runtime-is-disa.patch
#CVE-2016-3134 rhbz 1317383 1317384
@@ -625,8 +598,17 @@ Patch665: netfilter-x_tables-deal-with-bogus-nextoffset-values.patch
#ongoing complaint, full discussion delayed until ksummit/plumbers
Patch849: 0001-iio-Use-event-header-from-kernel-tree.patch
-# Request from dwalsh
-Patch850: selinux-namespace-fix.patch
+# Fix build issue with armada_trace
+Patch851: Armada-trace-build-fix.patch
+
+# selinux: allow context mounts on tmpfs, ramfs, devpts within user namespaces
+Patch852: selinux-allow-context-mounts-on-tmpfs-etc.patch
+
+# See http://lists.infradead.org/pipermail/linux-arm-kernel/2016-October/461597.html
+Patch853: 0001-Work-around-for-gcc7-and-arm64.patch
+
+#CVE-2017-2596 rhbz 1417812 1417813
+Patch854: kvm-fix-page-struct-leak-in-handle_vmon.patch
# END OF PATCH DEFINITIONS
@@ -1199,19 +1181,24 @@ git commit -a -m "Stable update"
%endif
# Drop some necessary files from the source dir into the buildroot
-cp $RPM_SOURCE_DIR/config-* .
+cp $RPM_SOURCE_DIR/kernel-*.config .
+cp %{SOURCE1000} .
cp %{SOURCE15} .
+cp %{SOURCE40} .
+cp %{SOURCE41} .
%if !%{debugbuildsenabled}
-%if %{with_release}
# The normal build is a really debug build and the user has explicitly requested
# a release kernel. Change the config files into non-debug versions.
-make -f %{SOURCE19} config-release
-%endif
+%if !%{with_release}
+VERSION=%{version} ./generate_debug_configs.sh
+%else
+VERSION=%{version} ./generate_all_configs.sh
%endif
-# Dynamically generate kernel .config files from config-* files
-make -f %{SOURCE20} VERSION=%{version} configs
+%else
+VERSION=%{version} ./generate_all_configs.sh
+%endif
# Merge in any user-provided local config option changes
%ifnarch %nobuildarches
@@ -1253,9 +1240,21 @@ rm -f kernel-%{version}-*debug.config
%define make make %{?cross_opts}
+CheckConfigs() {
+ ./check_configs.awk $1 $2 > .mismatches
+ if [ -s .mismatches ]
+ then
+ echo "Error: Mismatches found in configuration files"
+ cat .mismatches
+ exit 1
+ fi
+}
+
+cp %{SOURCE42} .
# now run oldconfig over all the config files
for i in *.config
do
+ cat $i > temp-$i
mv $i .config
Arch=`head -1 .config | cut -b 3-`
make ARCH=$Arch listnewconfig | grep -E '^CONFIG_' >.newoptions || true
@@ -1269,6 +1268,10 @@ do
make ARCH=$Arch oldnoconfig
echo "# $Arch" > configs/$i
cat .config >> configs/$i
+%if %{configmismatch_fail}
+ CheckConfigs configs/$i temp-$i
+%endif
+ rm temp-$i
done
# end of kernel config
%endif
@@ -1671,9 +1674,11 @@ BuildKernel %make_target %kernel_image
%endif
%global perf_make \
- make -s EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 prefix=%{_prefix}
+ make -s EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 NO_JVMTI=1 prefix=%{_prefix}
%if %{with_perf}
# perf
+# make sure check-headers.sh is executable
+chmod +x tools/perf/check-headers.sh
%{perf_make} DESTDIR=$RPM_BUILD_ROOT all
%endif
@@ -2173,208 +2178,219 @@ fi
# plz don't put in a version string unless you're going to tag
# and build.
#
-#
+#
%changelog
-* Mon Jan 09 2017 Laura Abbott <labbott@fedoraproject.org>
-- Linux v4.9.2
+* Mon Feb 20 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-1
+- Disable debugging options.
+- Linux v4.10
-* Mon Jan 9 2017 Peter Robinson <pbrobinson@fedoraproject.org>
-- Add patch to improve MMC/SD speed on Raspberry Pi (bcm283x)
+* Sat Feb 18 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- Update some Raspberry Pi patches
+- Add Raspberry Pi fixes for UART/i2c/stable eth MAC
-* Tue Dec 20 2016 Peter Robinson <pbrobinson@fedoraproject.org>
-- Update some ARM options
-- Enable some Qualcomm QDF2432 server platform options
-- Add upstream bcm283x i2c and clock fixes
+* Fri Feb 17 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc8.git2.1
+- Linux v4.10-rc8-62-g6dc39c5
-* Thu Dec 15 2016 Laura Abbott <labbott@fedoraproject.org>
-- Linux v4.9 rebase
+* Thu Feb 16 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc8.git1.1
+- Linux v4.10-rc8-39-g5a81e6a
-* Mon Aug 15 2016 Peter Robinson <pbrobinson@fedoraproject.org>
-- Enable Atmel i2c TPM on ARM platforms
-- Add upstream patch to fix boot on Jetson TK1
+* Wed Feb 15 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- Enable PWRSEQ_SIMPLE module (fixes rhbz 1377816)
+- Add patch to work around crash on RPi3
-* Mon Aug 08 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Build CONFIG_POWERNV_CPUFREQ in on ppc64* (rhbz 1351346)
+* Tue Feb 14 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc8.git0.2
+- Reenable debugging options.
+- CVE-2017-5967 Disable CONFIG_TIMER_STATS (rhbz 1422138 1422140)
-* Tue Aug 2 2016 Hans de Goede <jwrdegoede@fedoraproject.org>
-- Sync skylake hdaudio __unclaimed_reg WARN_ON fix with latest upstream version
-- Drop drm-i915-skl-Add-support-for-the-SAGV-fix-underrun-hangs.patch for now
+* Mon Feb 13 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc8.git0.1
+- Disable debugging options.
+- Linux v4.10-rc8
-* Thu Jul 28 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-5412 powerpc: kvm: Infinite loop in HV mode (rhbz 1349916 1361040)
+* Fri Feb 10 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc7.git4.1
+- Linux v4.10-rc7-127-g3d88460
-* Thu Jul 28 2016 Peter Robinson <pbrobinson@fedoraproject.org> 4.8.0-0.rc0.git1.1
-- Filter nvme rdma modules to extras
-- Fix IP Wireless driver filtering (rhbz 1356043) thanks lkundrak
-- Build IIO tools
+* Thu Feb 09 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc7.git3.1
+- Linux v4.10-rc7-114-g55aac6e
-* Fri Jun 24 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Linux v4.6.3
+* Thu Feb 9 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- Fix OOPSes in vc4 (Raspberry Pi)
-* Tue Jun 21 2016 Peter Robinson <pbrobinson@fedoraproject.org>
-- Update patch from 4.5 with missing bits for bcm238x support
+* Wed Feb 08 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc7.git2.1
+- Linux v4.10-rc7-65-g926af627
-* Mon Jun 20 2016 Hans de Goede <jwrdegoede@fedoraproject.org>
-- Bring in patch-series from drm-next to fix skl_update_other_pipe_wm issues
- (rhbz 1305038)
-- Cherry pick some other drm / kms fixes from upstream
+* Tue Feb 07 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc7.git1.1
+- Linux v4.10-rc7-29-g8b1b41e
+- Reenable debugging options.
+- CVE-2017-5897 ip6_gre: Invalid reads in ip6gre_err (rhbz 1419848 1419851)
-* Wed Jun 15 2016 Laura Abbott <labbott@fedoraproject.org>
-- hp-wmi: fix wifi cannot be hard-unblock (rhbz 1338025)
+* Mon Feb 06 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc7.git0.1
+- Disable debugging options.
+- Linux v4.10-rc7
-* Wed Jun 15 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-4470 keys: uninitialized variable crash (rhbz 1341716 1346626)
+* Fri Feb 03 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc6.git3.1
+- Linux v4.10-rc6-110-g34e00ac
-* Tue Jun 14 2016 Peter Robinson <pbrobinson@fedoraproject.org>
-- Enable Infiniband on ARM now we have HW
+* Wed Feb 01 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc6.git2.1
+- Linux v4.10-rc6-85-g6d04dfc
+- enable CONFIG_SENSORS_JC42 (rhbz 1417454)
-* Mon Jun 13 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-1583 stack overflow via ecryptfs and /proc (rhbz 1344721 1344722)
+* Tue Jan 31 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc6.git1.1
+- Linux v4.10-rc6-24-gf1774f4
+- Reenable debugging options.
+- Fix kvm nested virt CVE-2017-2596 (rhbz 1417812 1417813)
-* Wed Jun 08 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Linux v4.6.2
+* Mon Jan 30 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc6.git0.1
+- Linux v4.10-rc6
+- Disable debugging options.
-* Tue Jun 07 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-5244 info leak in rds (rhbz 1343338 1343337)
-- CVE-2016-5243 info leak in tipc (rhbz 1343338 1343335)
+* Sat Jan 28 2017 Laura Abbott <labbott@redhat.com> - 4.10.0-0.rc5.git4.2
+- Temporary workaround for gcc7 and arm64
-* Wed Jun 01 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Linux v4.6.1
+* Fri Jan 27 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc5.git4.1
+- Linux v4.10-rc5-367-g1b1bc42
-* Mon May 30 2016 Peter Robinson <pbrobinson@fedoraproject.org>
-- Minor ARM cleanups and power/cpufreq management tweaks
-- Update Utilite patch
-- Initial Qualcomm ARM64 support (Dragonboard 410c)
+* Thu Jan 26 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc5.git3.1
+- Linux v4.10-rc5-122-gff9f8a7
-* Mon May 23 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-4951 null ptr deref in tipc_nl_publ_dump (rhbz 1338625 1338626)
+* Thu Jan 26 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- arm64: dma-mapping: Fix dma_mapping_error() when bypassing SWIOTLB
-* Fri May 20 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-4440 kvm: incorrect state leading to APIC register access (rhbz 1337806 1337807)
+* Wed Jan 25 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc5.git2.1
+- Linux v4.10-rc5-107-g883af14
+- CVE-2017-5576 CVE-2017-5577 vc4 overflows (rhbz 1416436 1416437 1416439)
-* Tue May 17 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Linux v4.6
-- Disable CONFIG_DEBUG_VM_PGFLAGS on non debug kernels (rhbz 1335173)
-- CVE-2016-3713 kvm: out-of-bounds access in set_var_mtrr_msr (rhbz 1332139 1336410)
+* Tue Jan 24 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc5.git1.1
+- Linux v4.10-rc5-71-ga4685d2
-* Thu Feb 18 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2015-8812 cxgb3 use after free (rhbz 1303532 1309548)
+* Tue Jan 24 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc5.git0.2
+- Reenable debugging options.
-* Wed Feb 17 2016 Laura Abbott <labbott@fedoraproject.org>
-- Linux v4.4.2
+* Mon Jan 23 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc5.git0.1
+- Linux v4.10-rc5
+- Disable debugging options.
-* Tue Feb 16 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Backport fix for elantech touchpads (rhbz 1306987)
+* Fri Jan 20 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc4.git4.1
+- Linux v4.10-rc4-199-ge90665a
-* Mon Feb 15 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-2383 incorrect branch fixups for eBPG allow arbitrary reads (rhbz 1308452 1308453)
-- CVE-2016-2384 double free in usb-audio from invalid USB descriptor (rhbz 1308444 1308445)
+* Fri Jan 20 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- Initial DT support for Hummingboard 2 (Edge/Gate)
-* Fri Feb 12 2016 Laura Abbott <labbott@fedoraproject.org>
-- Turn off W+X warnings (rhbz 1306885)
+* Thu Jan 19 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc4.git3.1
+- Linux v4.10-rc4-122-g81aaeaa
-* Tue Feb 09 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-0617 fix hugetlbfs inode.c issues (rhbz 1305803 1305804)
+* Wed Jan 18 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc4.git2.1
+- Linux v4.10-rc4-101-gfa19a76
-* Mon Feb 01 2016 Laura Abbott <labbott@fedoraproject.org>
-- Linux v4.4.1
+* Wed Jan 18 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- Enable bcm283x VEC composite output
-* Fri Jan 29 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Backport HID sony patch to fix some gamepads (rhbz 1255235)
+* Tue Jan 17 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc4.git1.1
+- Linux v4.10-rc4-78-g4b19a9e
-* Thu Jan 28 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Fix issues with ivtv driver on PVR350 devices (rhbz 1278942)
-- Add patches to fix suprious NEWLINK netlink messages (rhbz 1302037)
+* Tue Jan 17 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc4.git0.3
+- Reenable debugging options.
-* Mon Jan 25 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Add patch to fix some Elan touchpads (rhbz 1296677)
+* Mon Jan 16 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc4.git0.1
+- Disable debugging options.
+- Linux v4.10-rc4
-* Fri Jan 22 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Fix backtrace from PNP conflict on Haswell-ULT (rhbz 1300955)
-- Fix backtrace from PNP conflict on Broadwell (rhbz 1083853)
+* Mon Jan 16 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- Minor ARM updates
-* Thu Jan 21 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- Fix incorrect country code issue on RTL8812AE devices (rhbz 1279653)
+* Fri Jan 13 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc3.git4.1
+- Linux v4.10-rc3-187-g557ed56
-* Wed Jan 20 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-0723 memory disclosure and crash in tty layer (rhbz 1296253 1300224)
-- CVE-2013-4312 file descr passed over unix sockects not properly accounted (rhbz 1297813 1300216)
+* Thu Jan 12 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc3.git3.1
+- Linux v4.10-rc3-163-ge28ac1f
-* Tue Jan 19 2016 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2016-0728 Keys: reference leak in join_session_keyring (rhbz 1296623 1297475)
+* Wed Jan 11 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc3.git2.1
+- Linux v4.10-rc3-98-gcff3b2c
-* Thu Jan 14 2016 Laura Abbott <labbott@fedoraproject.org>
-- Linux v4.4
+* Tue Jan 10 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc3.git1.1
+- Linux v4.10-rc3-52-gbd5d742
-* Fri Dec 18 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2015-8575 information leak in sco_sock_bind (rhbz 1292840 1292841)
+* Tue Jan 10 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc3.git0.2
+- Reenable debugging options.
-* Thu Dec 17 2015 Justin M. Forbes <jforbes@fedoraproject.org>
-- Fix for memory leak in vrf
+* Mon Jan 09 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc3.git0.1
+- Disable debugging options.
+- Linux v4.10-rc3
-* Thu Dec 17 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2015-8569 info leak from getsockname (rhbz 1292045 1292047)
+* Mon Jan 9 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- Add patch to improve MMC/SD speed on Raspberry Pi (bcm283x)
-* Tue Dec 15 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2015-8543 ipv6: DoS via NULL pointer dereference (rhbz 1290475 1290477)
+* Fri Jan 06 2017 Laura Abbott <labbott@fedoraproject.org>
+- Disable JVMTI for perf (rhbz 1410296)
-* Tue Dec 15 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- Linux v4.3.3
+* Fri Jan 06 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc2.git4.1
+- Linux v4.10-rc2-207-g88ba6ca
-* Mon Dec 14 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2015-7550 Race between read and revoke keys (rhbz 1291197 1291198)
-- CVE-XXXX-XXXX permission bypass on overlayfs (rhbz 1291329 1291332)
+* Fri Jan 6 2017 Peter Robinson <pbrobinson@fedoraproject.org>
+- Minor ARM config updates
-* Fri Dec 11 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- Linux v4.3.2
-- CVE-2013-7446 unix sockects use after free (rhbz 1282688 1282712)
+* Thu Jan 05 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc2.git3.1
+- Linux v4.10-rc2-183-gc433eb7
-* Thu Dec 10 2015 Laura Abbott <labbott@redhat.com>
-- Ignore errors from scsi_dh_add_device (rhbz 1288687)
+* Wed Jan 04 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc2.git2.1
+- Linux v4.10-rc2-43-g62f8c40
-* Thu Dec 10 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- Fix rfkill issues on ideapad Y700-17ISK (rhbz 1286293)
+* Tue Jan 03 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc2.git1.1
+- Linux v4.10-rc2-20-g0f64df3
-* Wed Dec 09 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- Linux v4.3.1
+* Tue Jan 03 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc2.git0.3
+- Reenable debugging options.
-* Thu Dec 03 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- Add patch to fix palm rejection on certain touchpads (rhbz 1287819)
+* Tue Jan 03 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc2.git0.2
+- Disable debugging options.
-* Tue Dec 01 2015 Laura Abbott <labbott@redhat.com>
-- Enable CONFIG_X86_INTEL_MPX (rhbz 1287279)
+* Mon Jan 02 2017 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc2.git0.1
+- Linux v4.10-rc2
-* Tue Dec 01 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2015-7515 aiptek: crash on invalid device descriptors (rhbz 1285326 1285331)
-- CVE-2015-7833 usbvision: crash on invalid device descriptors (rhbz 1270158 1270160)
+* Thu Dec 29 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc1.git1.1
+- Linux v4.10-rc1-17-g2d706e7
+- Fix generate-git-snapshtot.sh to work with SHA512 sources
-* Mon Nov 30 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- Fix crash in add_key (rhbz 1284059)
-- CVE-2015-8374 btrfs: info leak when truncating compressed/inlined extents (rhbz 1286261 1286262)
+* Tue Dec 27 2016 Peter Robinson <pbrobinson@fedoraproject.org>
+- Linux v4.10-rc1
+- ARM config updates, minor general config cleanups
+- Enable Amlogic (meson) SoCs for ARMv7/aarch64
-* Sun Nov 22 2015 Peter Robinson <pbrobinson@fedoraproject.org>
-- Fix sound issue on some ARM devices (tested on Arndale)
+* Fri Dec 23 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git9.1
+- Linux v4.9-11999-g50f6584
-* Mon Nov 16 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- Fix ipset netfilter issues (rhbz 1279189)
-- Add queued 4.3 net stable fixes
+* Thu Dec 22 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git8.1
+- Linux v4.9-11937-g52bce91
-* Thu Nov 12 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- CVE-2015-5327 x509 time validation
+* Wed Dec 21 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git7.1
+- Linux v4.9-11893-gba6d973
-* Wed Nov 11 2015 Josh Boyer <jwboyer@fedoraproject.org>
-- Linux v4.3
-- Fix Yoga 900 rfkill switch issues (rhbz 1275490)
-- Fix incorrect size calculations in megaraid with 64K pages (rhbz 1269300)
-- CVE-2015-8104 kvm: DoS infinite loop in microcode DB exception (rhbz 1278496 1279691)
-- CVE-2015-5307 kvm: DoS infinite loop in microcode AC exception (rhbz 1277172 1279688)
-- Disable Exynos IOMMU as it crashes
-- Enable some IIO sensors (temp/humidity) on ARMv7
-- Move iscsi_tcp and related modules to kernel-core (rhbz 1249424)
-- CVE-2015-7799 slip:crash when using PPP char dev driver (rhbz 1271134 1271135)
-- Add patch to fix crash in omap_wdt (headed upstream)
-- Build in ARM generic crypto optomisation modules
-- Minor ARM updates
+* Tue Dec 20 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git6.1
+- Linux v4.9-11815-ge93b1cc
+
+* Tue Dec 20 2016 Peter Robinson <pbrobinson@fedoraproject.org>
+- Minor ARM config updates
+- Enable some Qualcomm QDF2432 server platform options
+
+* Mon Dec 19 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git5.1
+- Linux v4.9-11744-gb0b3a37
+
+* Fri Dec 16 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git4.1
+- Linux v4.9-10415-g73e2e0c
+
+* Thu Dec 15 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git3.1
+- Linux v4.9-8648-g5cc60ae
+
+* Wed Dec 14 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git2.1
+- Linux v4.9-7150-gcdb98c2
+
+* Tue Dec 13 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.10.0-0.rc0.git1.1
+- Linux v4.9-2682-ge7aa8c2
+
+* Tue Dec 13 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.9.0-2
+- Reenable debugging options.
+
+* Mon Dec 12 2016 Laura Abbott <labbott@fedoraproject.org> - 4.9.0-1
+- Linux v4.9
###
# The following Emacs magic makes C-c C-e use UTC dates.