summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec36
1 files changed, 18 insertions, 18 deletions
diff --git a/kernel.spec b/kernel.spec
index b3c4c07cc..fe8da6751 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -46,7 +46,7 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 150
+%global baserelease 102
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
@@ -556,6 +556,8 @@ Patch325: arm64-usb-host-xhci-tegra-set-MODULE_FIRMWARE-for-tegra186.patch
# 400 - IBM (ppc/s390x) patches
# 500 - Temp fixes/CVEs etc
+Patch500: PATCH-v2-selinux-allow-labeling-before-policy-is-loaded.patch
+
# rhbz 1431375
Patch501: input-rmi4-remove-the-need-for-artifical-IRQ.patch
@@ -566,12 +568,10 @@ Patch502: 0001-Drop-that-for-now.patch
# Submitted upstream at https://lkml.org/lkml/2019/4/23/89
Patch503: KEYS-Make-use-of-platform-keyring-for-module-signature.patch
-Patch500: PATCH-v2-selinux-allow-labeling-before-policy-is-loaded.patch
-
# it seems CONFIG_OPTIMIZE_INLINING has been forced now and is causing issues on ARMv7
# https://lore.kernel.org/patchwork/patch/1132459/
# https://lkml.org/lkml/2019/8/29/1772
-Patch505: ARM-fix-__get_user_check-in-case-uaccess_-calls-are-not-inlined.patch
+Patch504: ARM-fix-__get_user_check-in-case-uaccess_-calls-are-not-inlined.patch
# CVE-2019-19068 rhbz 1774963 1774965
Patch511: rtl8xxxu-prevent-leaking-urb.patch
@@ -586,7 +586,7 @@ Patch513: scsi-bfa-release-allocated-memory-in-case-of-error.patch
Patch514: ipmi-Fix-memory-leak-in-__ipmi_bmc_register.patch
# CVE-2019-19064 rhbz 1775010 1775011
-Patch516: spi-lpspi-fix-memory-leak-in-fsl_lpspi_probe.patch
+Patch515: spi-lpspi-fix-memory-leak-in-fsl_lpspi_probe.patch
# CVE-2019-19053 rhbz 1775956 1775110
Patch521: rpmsg-char-release-allocated-memory.patch
@@ -595,29 +595,26 @@ Patch521: rpmsg-char-release-allocated-memory.patch
Patch522: mwifiex-pcie-fix-memory-leak-in-mwifiex_pcie_alloc_cmdrsp_buf.patch
# CVE-2019-19054 rhbz 1775063 1775117
-Patch524: media-rc-prevent-memory-leak-in-cx23888_ir_probe.patch
+Patch523: media-rc-prevent-memory-leak-in-cx23888_ir_probe.patch
# CVE-2019-14895 rhbz 1774870 1776139
-Patch526: mwifiex-fix-possible-heap-overflow-in-mwifiex_process_country_ie.patch
+Patch524: mwifiex-fix-possible-heap-overflow-in-mwifiex_process_country_ie.patch
# CVE-2019-14896 rhbz 1774875 1776143
# CVE-2019-14897 rhbz 1774879 1776146
-Patch527: libertas-Fix-two-buffer-overflows-at-parsing-bss-descriptor.patch
-
-# CVE-2019-14901 rhbz 1773519 1776184
-Patch528: mwifiex-Fix-heap-overflow-in-mmwifiex_process_tdls_action_frame.patch
+Patch525: libertas-Fix-two-buffer-overflows-at-parsing-bss-descriptor.patch
# CVE-2019-19078 rhbz 1776354 1776353
-Patch529: ath10k-fix-memory-leak.patch
+Patch526: ath10k-fix-memory-leak.patch
# CVE-2019-18808 rhbz 1777418 1777421
-Patch531: 0001-crypto-ccp-Release-all-allocated-memory-if-sha-type-.patch
-
-# rhbz 1781288
-Patch610: 0001-tracing-Do-not-create-directories-if-lockdown-is-in-.patch
+Patch527: 0001-crypto-ccp-Release-all-allocated-memory-if-sha-type-.patch
# rhbz 1788653
-Patch611: tpm-handle-negative-priv--response_len-in-tpm_common_read.patch
+Patch530: tpm-handle-negative-priv--response_len-in-tpm_common_read.patch
+
+# https://gitlab.freedesktop.org/drm/intel/issues/673
+Patch612: drm-i915-gt-Detect-if-we-miss-WaIdleLiteRestore.patch
# END OF PATCH DEFINITIONS
@@ -1338,7 +1335,6 @@ BuildKernel() {
cp Module.markers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
fi
# then drop all but the needed Makefiles/Kconfig files
- rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
@@ -1862,6 +1858,10 @@ fi
#
#
%changelog
+* Mon Jan 13 2020 Justin M. Forbes <jforbes@fedoraproject.org> - 5.4.10-102
+- Add Documentation back to kernel-devel as it has Kconfig now (rhbz 1789641)
+- Linux v5.4.11
+
* Thu Jan 09 2020 Jeremy Cline <jcline@redhat.com> - 5.4.10-100
- Linux v5.4.10