summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/kernel.spec b/kernel.spec
index 05600011e..abdac81b9 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -305,7 +305,7 @@ Summary: The Linux kernel
%if %{with_vdso_install}
# These arches install vdso/ directories.
-%define vdso_arches %{all_x86} x86_64 ppc ppc64 s390 s390x
+%define vdso_arches %{all_x86} x86_64 ppc ppc64 ppc64p7 s390 s390x
%endif
# Overrides for generic default options
@@ -335,12 +335,12 @@ Summary: The Linux kernel
%endif
# bootwrapper is only on ppc
-%ifnarch ppc ppc64
+%ifnarch ppc ppc64 ppc64p7
%define with_bootwrapper 0
%endif
# sparse blows up on ppc64 and sparc64
-%ifarch ppc64 ppc sparc64
+%ifarch ppc64 ppc sparc64 ppc64p7
%define with_sparse 0
%endif
@@ -361,7 +361,7 @@ Summary: The Linux kernel
%define kernel_image arch/x86/boot/bzImage
%endif
-%ifarch ppc64
+%ifarch ppc64 ppc64p7
%define asmarch powerpc
%define hdrarch powerpc
%define all_arch_configs kernel-%{version}-ppc64*.config
@@ -448,7 +448,7 @@ Summary: The Linux kernel
%endif
# Architectures we build tools/cpupower on
-%define cpupowerarchs %{ix86} x86_64 ppc ppc64 %{arm}
+%define cpupowerarchs %{ix86} x86_64 ppc ppc64 ppc64p7 %{arm}
#
# Three sets of minimum package version requirements in the form of Conflicts:
@@ -518,7 +518,7 @@ Version: %{rpmversion}
Release: %{pkg_release}
# DO NOT CHANGE THE 'ExclusiveArch' LINE TO TEMPORARILY EXCLUDE AN ARCHITECTURE BUILD.
# SET %%nobuildarches (ABOVE) INSTEAD
-ExclusiveArch: noarch %{all_x86} x86_64 ppc ppc64 %{sparc} s390 s390x %{arm}
+ExclusiveArch: noarch %{all_x86} x86_64 ppc ppc64 ppc64p7 %{sparc} s390 s390x %{arm}
ExclusiveOS: Linux
%kernel_reqprovconf
@@ -579,6 +579,7 @@ Source50: config-powerpc-generic
Source51: config-powerpc32-generic
Source52: config-powerpc32-smp
Source53: config-powerpc64
+Source54: config-powerpc64p7
Source70: config-s390x
@@ -1661,7 +1662,7 @@ BuildKernel() {
fi
rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
-%ifarch ppc ppc64
+%ifarch ppc ppc64 ppc64p7
cp -a --parents arch/powerpc/lib/crtsavres.[So] $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
%endif
if [ -d arch/%{asmarch}/include ]; then
@@ -2304,6 +2305,9 @@ fi
# ||----w |
# || ||
%changelog
+* Tue Aug 07 2012 Josh Boyer <jwboyer@redhat.com>
+- Add support for ppc64p7 subarch
+
* Mon Aug 06 2012 Josh Boyer <jwboyer@redhat.com> - 3.6.0-0.rc1.git2.1
- Linux v3.6-rc1-133-g42a579a