summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec29
1 files changed, 21 insertions, 8 deletions
diff --git a/kernel.spec b/kernel.spec
index 5e7b954d4..679db587e 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -85,9 +85,9 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
# to build the base kernel using the debug configuration. (Specifying
# the --with-release option overrides this setting.)
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
-%global distro_build 0.rc3.89
+%global distro_build 0.rc3.20220209gite6251ab4551f.91
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -134,13 +134,13 @@ Summary: The Linux kernel
%define rpmversion 5.17.0
%define patchversion 5.17
-%define pkgrelease 0.rc3.89
+%define pkgrelease 0.rc3.20220209gite6251ab4551f.91
# This is needed to do merge window version magic
%define patchlevel 17
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc3.89%{?buildid}%{?dist}
+%define specrelease 0.rc3.20220209gite6251ab4551f.91%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -587,6 +587,9 @@ BuildRequires: net-tools, hostname, bc, elfutils-devel
BuildRequires: dwarves
BuildRequires: python3-devel
BuildRequires: gcc-plugin-devel
+# glibc-static is required for a consistent build environment (specifically
+# CONFIG_CC_CAN_LINK_STATIC=y).
+BuildRequires: glibc-static
%ifnarch %{nobuildarches} noarch
BuildRequires: bpftool
%endif
@@ -694,7 +697,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.17-rc3.tar.xz
+Source0: linux-5.17-rc3-29-ge6251ab4551f.tar.xz
Source1: Makefile.rhelver
@@ -1393,8 +1396,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.17-rc3 -c
-mv linux-5.17-rc3 linux-%{KVERREL}
+%setup -q -n kernel-5.17-rc3-29-ge6251ab4551f -c
+mv linux-5.17-rc3-29-ge6251ab4551f linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
@@ -3015,10 +3018,20 @@ fi
#
#
%changelog
-* Mon Feb 07 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc3.89]
+* Wed Feb 09 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc3.e6251ab4551f.91]
- mm/sparsemem: Fix 'mem_section' will never be NULL gcc 12 warning (Waiman Long)
- Workaround for gcc12 compile issues in ubcmd-util.h (Justin M. Forbes)
+* Wed Feb 09 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc3.e6251ab4551f.90]
+- Change CONFIG_TEST_BPF to a module (Justin M. Forbes)
+- Change CONFIG_TEST_BPF to module in pending MR coming for proper review (Justin M. Forbes)
+
+* Tue Feb 08 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc3.555f3d7be91a.89]
+- redhat/configs: Enable CONFIG_TEST_BPF (Viktor Malik)
+- Enable KUNIT tests for testing (Nico Pache)
+- Makefile: Check PKGRELEASE size on dist-brew targets (Prarit Bhargava)
+- kernel.spec: Add glibc-static build requirement (Prarit Bhargava)
+
* Sat Feb 05 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.17-0.rc2.20220205git0457e5153e0e.86]
- Enable iSER on s390x (Stefan Schulze Frielinghaus)