summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec38
1 files changed, 24 insertions, 14 deletions
diff --git a/kernel.spec b/kernel.spec
index f60fb38ce..af11e6297 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -77,7 +77,7 @@ Summary: The Linux kernel
# kernel release. (This includes prepatch or "rc" releases.)
# Set released_kernel to 0 when the upstream source tarball contains an
# unreleased kernel development snapshot.
-%global released_kernel 0
+%global released_kernel 1
# Set debugbuildsenabled to 1 to build separate base and debug kernels
# (on supported architectures). The kernel-debug-* subpackages will
@@ -119,6 +119,8 @@ Summary: The Linux kernel
%endif
# define buildid .local
+%define packager Thorsten Leemhuis https://fedoraproject.org/wiki/Kernel_Vanilla_Repositories
+%define buildid .vanilla.1
%if 0%{?fedora}
@@ -126,19 +128,21 @@ Summary: The Linux kernel
%else
%define primary_target rhel
%endif
+%define fedorabase 5.16.0
+
# The kernel tarball/base version
%define kversion 5.16
%define rpmversion 5.16.0
%define patchversion 5.16
-%define pkgrelease 60
+%define pkgrelease 60.1
# This is needed to do merge window version magic
%define patchlevel 16
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 60%{?buildid}%{?dist}
+%define specrelease 60.1%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -155,7 +159,7 @@ Summary: The Linux kernel
# kernel PAE (only valid for ARM (lpae))
%define with_pae %{?_without_pae: 0} %{?!_without_pae: 1}
# kernel-debug
-%define with_debug %{?_without_debug: 0} %{?!_without_debug: 1}
+%define with_debug %{?_with_debug: 1} %{?!_with_debug: 0}
# kernel-zfcpdump (s390 specific kernel for zfcpdump)
%define with_zfcpdump %{?_without_zfcpdump: 0} %{?!_without_zfcpdump: 1}
# kernel-doc
@@ -206,7 +210,7 @@ Summary: The Linux kernel
%define with_cross %{?_with_cross: 1} %{?!_with_cross: 0}
#
# build a release kernel on rawhide
-%define with_release %{?_with_release: 1} %{?!_with_release: 0}
+%define with_release %{?_without_release: 0} %{?!_without_release: 1}
# verbose build, i.e. no silent rules and V=1
%define with_verbose %{?_with_verbose: 1} %{?!_with_verbose: 0}
@@ -224,7 +228,7 @@ Summary: The Linux kernel
%define with_ipaclones %{?_without_ipaclones: 0} %{?!_without_ipaclones: 1}
# Want to build a vanilla kernel build without any non-upstream patches?
-%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
+%define with_vanilla %{?_without_vanilla: 0} %{?!_without_vanilla: 1}
%if 0%{?fedora}
# Kernel headers are being split out into a separate package
@@ -643,7 +647,7 @@ BuildConflicts: dwarves < 1.13
%undefine _debugsource_packages
%undefine _debuginfo_subpackages
%global _find_debuginfo_opts -r
-%global _missing_build_ids_terminate_build 1
+%global _missing_build_ids_terminate_build 0
%global _no_recompute_build_ids 1
%endif
%if %{with_kabidwchk} || %{with_kabidw_base}
@@ -689,7 +693,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.16.tar.xz
+Source0: linux-5.16.1.tar.xz
Source1: Makefile.rhelver
@@ -828,8 +832,8 @@ Source211: Module.kabi_dup_ppc64le
Source212: Module.kabi_dup_s390x
Source213: Module.kabi_dup_x86_64
-Source300: kernel-abi-stablelists-%{rpmversion}-%{distro_build}.tar.bz2
-Source301: kernel-kabi-dw-%{rpmversion}-%{distro_build}.tar.bz2
+Source300: kernel-abi-stablelists-%{fedorabase}-%{distro_build}.tar.bz2
+Source301: kernel-kabi-dw-%{fedorabase}-%{distro_build}.tar.bz2
# Sources for kernel-tools
Source2000: cpupower.service
@@ -1383,11 +1387,11 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.16 -c
-mv linux-5.16 linux-%{KVERREL}
+%setup -q -n kernel-5.16.1 -c
+mv linux-5.16.1 linux-%{KVERREL}
cd linux-%{KVERREL}
-cp -a %{SOURCE1} .
+# cp -a %{SOURCE1} .
%if !%{nopatches}
@@ -1398,6 +1402,8 @@ ApplyOptionalPatch linux-kernel-test.patch
# END OF PATCH APPLICATIONS
+head Makefile
+
# Any further pre-build tree manipulations happen here.
chmod +x scripts/checkpatch.pl
@@ -2110,7 +2116,11 @@ BuildKernel() {
%ifnarch armv7hl
# Generate vmlinux.h and put it to kernel-devel path
- bpftool btf dump file vmlinux format c > $RPM_BUILD_ROOT/$DevelDir/vmlinux.h
+
+ # tmp disabled for vanilla builds, as it fails on x86_64 with
+ # "Error: failed to load BTF from vmlinux: No such file or directory"
+ # (and yes, the file exists)
+ # bpftool btf dump file vmlinux format c > $RPM_BUILD_ROOT/$DevelDir/vmlinux.h
%endif
# prune junk from kernel-devel