summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec20
1 files changed, 13 insertions, 7 deletions
diff --git a/kernel.spec b/kernel.spec
index 493a84d2e..d4d57db54 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -77,7 +77,7 @@ Summary: The Linux kernel
# kernel release. (This includes prepatch or "rc" releases.)
# Set released_kernel to 0 when the upstream source tarball contains an
# unreleased kernel development snapshot.
-%global released_kernel 0
+%global released_kernel 1
# Set debugbuildsenabled to 1 to build separate base and debug kernels
# (on supported architectures). The kernel-debug-* subpackages will
@@ -119,6 +119,8 @@ Summary: The Linux kernel
%endif
# define buildid .local
+%define packager Thorsten Leemhuis https://fedoraproject.org/wiki/Kernel_Vanilla_Repositories
+%define buildid .vanilla.1
%if 0%{?fedora}
@@ -155,7 +157,7 @@ Summary: The Linux kernel
# kernel PAE (only valid for ARM (lpae))
%define with_pae %{?_without_pae: 0} %{?!_without_pae: 1}
# kernel-debug
-%define with_debug %{?_without_debug: 0} %{?!_without_debug: 1}
+%define with_debug %{?_with_debug: 1} %{?!_with_debug: 0}
# kernel-zfcpdump (s390 specific kernel for zfcpdump)
%define with_zfcpdump %{?_without_zfcpdump: 0} %{?!_without_zfcpdump: 1}
# kernel-doc
@@ -206,7 +208,7 @@ Summary: The Linux kernel
%define with_cross %{?_with_cross: 1} %{?!_with_cross: 0}
#
# build a release kernel on rawhide
-%define with_release %{?_with_release: 1} %{?!_with_release: 0}
+%define with_release %{?_without_release: 0} %{?!_without_release: 1}
# verbose build, i.e. no silent rules and V=1
%define with_verbose %{?_with_verbose: 1} %{?!_with_verbose: 0}
@@ -224,7 +226,7 @@ Summary: The Linux kernel
%define with_ipaclones %{?_without_ipaclones: 0} %{?!_without_ipaclones: 1}
# Want to build a vanilla kernel build without any non-upstream patches?
-%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
+%define with_vanilla %{?_without_vanilla: 0} %{?!_without_vanilla: 1}
%if 0%{?fedora}
# Kernel headers are being split out into a separate package
@@ -643,7 +645,7 @@ BuildConflicts: dwarves < 1.13
%undefine _debugsource_packages
%undefine _debuginfo_subpackages
%global _find_debuginfo_opts -r
-%global _missing_build_ids_terminate_build 1
+%global _missing_build_ids_terminate_build 0
%global _no_recompute_build_ids 1
%endif
%if %{with_kabidwchk} || %{with_kabidw_base}
@@ -1387,7 +1389,7 @@ ApplyOptionalPatch()
mv linux-5.16-rc7-9-ge7c124bd0463 linux-%{KVERREL}
cd linux-%{KVERREL}
-cp -a %{SOURCE1} .
+# cp -a %{SOURCE1} .
%if !%{nopatches}
@@ -2110,7 +2112,11 @@ BuildKernel() {
%ifnarch armv7hl
# Generate vmlinux.h and put it to kernel-devel path
- bpftool btf dump file vmlinux format c > $RPM_BUILD_ROOT/$DevelDir/vmlinux.h
+
+ # tmp disabled for vanilla builds, as it fails on x86_64 with
+ # "Error: failed to load BTF from vmlinux: No such file or directory"
+ # (and yes, the file exists)
+ # bpftool btf dump file vmlinux format c > $RPM_BUILD_ROOT/$DevelDir/vmlinux.h
%endif
# prune junk from kernel-devel