summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec21
1 files changed, 11 insertions, 10 deletions
diff --git a/kernel.spec b/kernel.spec
index cccbe2927..4d7588882 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -83,9 +83,9 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
# to build the base kernel using the debug configuration. (Specifying
# the --with-release option overrides this setting.)
-%define debugbuildsenabled 0
+%define debugbuildsenabled 1
-%global distro_build 0.rc0.20211112git5833291ab6de.12
+%global distro_build 0.rc1.20211115git8ab774587903.14
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -130,13 +130,13 @@ Summary: The Linux kernel
%define rpmversion 5.16.0
%define patchversion 5.16
-%define pkgrelease 0.rc0.20211112git5833291ab6de.12
+%define pkgrelease 0.rc1.20211115git8ab774587903.14
# This is needed to do merge window version magic
%define patchlevel 16
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc0.20211112git5833291ab6de.12%{?buildid}%{?dist}
+%define specrelease 0.rc1.20211115git8ab774587903.14%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -682,7 +682,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.15-12452-g5833291ab6de.tar.xz
+Source0: linux-5.16-rc1-3-g8ab774587903.tar.xz
Source1: Makefile.rhelver
@@ -1374,8 +1374,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.15-12452-g5833291ab6de -c
-mv linux-5.15-12452-g5833291ab6de linux-%{KVERREL}
+%setup -q -n kernel-5.16-rc1-3-g8ab774587903 -c
+mv linux-5.16-rc1-3-g8ab774587903 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@@ -2184,7 +2184,7 @@ InitBuildVars
%global perf_build_extra_opts CORESIGHT=1
%endif
%global perf_make \
- %{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
+ %{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 LIBTRACEEVENT_DYNAMIC=1 %{?perf_build_extra_opts} prefix=%{_prefix} PYTHON=%{__python3}
%if %{with_perf}
# perf
# make sure check-headers.sh is executable
@@ -2972,8 +2972,9 @@ fi
#
#
%changelog
-* Fri Nov 12 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc0.20211112git5833291ab6de.12]
-- drm/virtio: Fix NULL dereference error in virtio_gpu_poll (Vivek Kasireddy)
+* Sat Nov 13 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc0.20211113git66f4beaa6c1d.12]
+- Turn on CONFIG_HID_NINTENDO for controller support (Dave Olsthoorn)
+- Fedora: Enable MediaTek bluetooth pieces (Peter Robinson)
* Thu Nov 11 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.16-0.rc0.20211111gitdebe436e77c7.10]
- Add rebase notes to check for PCI patches (Justin M. Forbes)