summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec31
1 files changed, 23 insertions, 8 deletions
diff --git a/kernel.spec b/kernel.spec
index fb39d10c2..d97cbc2fc 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -85,7 +85,7 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
-%global distro_build 0.rc3.20211001git4de593fb965f.30
+%global distro_build 0.rc4.20211006git60a9483534ed.34
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -132,13 +132,13 @@ Summary: The Linux kernel
%define rpmversion 5.15.0
%define patchversion 5.15
-%define pkgrelease 0.rc3.20211001git4de593fb965f.30
+%define pkgrelease 0.rc4.20211006git60a9483534ed.34
# This is needed to do merge window version magic
%define patchlevel 15
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc3.20211001git4de593fb965f.30%{?buildid}%{?dist}
+%define specrelease 0.rc4.20211006git60a9483534ed.34%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -679,7 +679,7 @@ BuildRequires: lld
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.15-rc3-240-g4de593fb965f.tar.xz
+Source0: linux-5.15-rc4-15-g60a9483534ed.tar.xz
Source1: Makefile.rhelver
@@ -1370,8 +1370,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.15-rc3-240-g4de593fb965f -c
-mv linux-5.15-rc3-240-g4de593fb965f linux-%{KVERREL}
+%setup -q -n kernel-5.15-rc4-15-g60a9483534ed -c
+mv linux-5.15-rc4-15-g60a9483534ed linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
@@ -2260,7 +2260,7 @@ export BPFTOOL=$(pwd)/tools/bpf/bpftool/bpftool
pushd tools/testing/selftests
# We need to install here because we need to call make with ARCH set which
# doesn't seem possible to do in the install section.
-%{make} %{?_smp_mflags} ARCH=$Arch V=1 TARGETS="bpf livepatch net net/forwarding net/mptcp netfilter tc-testing" SKIP_TARGETS="" FORCE_TARGETS=1 INSTALL_PATH=%{buildroot}%{_libexecdir}/kselftests VMLINUX_H="${RPM_VMLINUX_H}" install
+%{make} %{?_smp_mflags} ARCH=$Arch V=1 TARGETS="bpf livepatch net net/forwarding net/mptcp netfilter tc-testing" SKIP_TARGETS="" INSTALL_PATH=%{buildroot}%{_libexecdir}/kselftests VMLINUX_H="${RPM_VMLINUX_H}" install
# 'make install' for bpf is broken and upstream refuses to fix it.
# Install the needed files manually.
@@ -2974,8 +2974,23 @@ fi
#
#
%changelog
-* Fri Oct 01 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc3.20211001git4de593fb965f.30]
+* Wed Oct 06 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.15-0.rc4.20211006git60a9483534ed.34]
+- Testing upstream bpf selftests (Justin M. Forbes)
+
+* Wed Oct 06 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc4.20211006git60a9483534ed.34]
+- Revert "Merge branch 'ppcbpfselftest' into 'os-build'" (Justin M. Forbes)
+
+* Tue Oct 05 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc4.20211005gitf6274b06e326.33]
+- Fix ordering in genspec args (Justin M. Forbes)
+
+* Sat Oct 02 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc3.20211002git53d5fc89d66a.30]
+- redhat/configs: Enable Hyper-V guests on ARM64 (Vitaly Kuznetsov) [2007430]
+- redhat: configs: Enable CONFIG_THINKPAD_LMI (Hans de Goede)
+- redhat/docs: update Koji link to avoid redirect (Joel Savitz)
+- redhat: add support for different profiles with dist*-brew (Herton R. Krzesinski)
- Fix BPF selftests build on ppc64 (Justin M. Forbes)
+- redhat: configs: Disable xtables and ipset (Phil Sutter) [1945179]
+- redhat: Add mark_driver_deprecated() (Phil Sutter) [1945179]
* Fri Oct 01 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.15-0.rc3.20211001git4de593fb965f.29]
- Change s390x CONFIG_NODES_SHIFT from 4 to 1 (Justin M. Forbes)