summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec21
1 files changed, 13 insertions, 8 deletions
diff --git a/kernel.spec b/kernel.spec
index 8c52381be..c8eee6b61 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -71,9 +71,9 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 0 to not build a separate debug kernel, but
# to build the base kernel using the debug configuration. (Specifying
# the --with-release option overrides this setting.)
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
-%global distro_build 0.rc5.38
+%global distro_build 0.rc5.20210608git368094df48e6.39
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -117,13 +117,13 @@ Summary: The Linux kernel
%define kversion 5.13
%define rpmversion 5.13.0
-%define pkgrelease 0.rc5.38
+%define pkgrelease 0.rc5.20210608git368094df48e6.39
# This is needed to do merge window version magic
%define patchlevel 13
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc5.38%{?buildid}%{?dist}
+%define specrelease 0.rc5.20210608git368094df48e6.39%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -647,7 +647,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.13-rc5.tar.xz
+Source0: linux-5.13-rc5-36-g368094df48e6.tar.xz
Source1: Makefile.rhelver
@@ -1316,8 +1316,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.13-rc5 -c
-mv linux-5.13-rc5 linux-%{KVERREL}
+%setup -q -n kernel-5.13-rc5-36-g368094df48e6 -c
+mv linux-5.13-rc5-36-g368094df48e6 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@@ -2871,7 +2871,7 @@ fi
#
#
%changelog
-* Mon Jun 07 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc5.38]
+* Tue Jun 08 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc5.20210608git368094df48e6.39]
- spec: Enable sefltests rpm build (Jiri Olsa)
- spec: Allow bpf selftest/samples to fail (Jiri Olsa)
- kvm: Add kvm_stat.service file and kvm_stat logrotate config to the tools (Jiri Benc)
@@ -2902,6 +2902,11 @@ fi
- kernel.spec: selftests should not depend on modules-internal (Jiri Benc)
- kernel.spec: build samples (Jiri Benc)
- kernel.spec: tools: sync missing options with RHEL 8 (Jiri Benc)
+- configs/ark/s390: set CONFIG_MARCH_Z14 and CONFIG_TUNE_Z15 (Philipp Rudo) [1876435]
+- configs/common/s390: Clean up CONFIG_{MARCH,TUNE}_Z* (Philipp Rudo)
+- configs/process_configs.sh: make use of dummy-tools (Philipp Rudo)
+- configs/common: disable CONFIG_INIT_STACK_ALL_{PATTERN,ZERO} (Philipp Rudo)
+- configs/common/aarch64: disable CONFIG_RELR (Philipp Rudo)
* Sat Jun 05 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc4.20210604gitf88cd3fb9df2.36]
- RHEL: disable io_uring support (Jeff Moyer)