summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec54
1 files changed, 39 insertions, 15 deletions
diff --git a/kernel.spec b/kernel.spec
index 3e3f8348f..68c49a255 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -56,7 +56,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
-%global distro_build 0.rc2.114
+%global distro_build 0.rc2.20210106git36bbbd0e234d.117
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -97,13 +97,13 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.11.0
-%define pkgrelease 0.rc2.114
+%define pkgrelease 0.rc2.20210106git36bbbd0e234d.117
# This is needed to do merge window version magic
%define patchlevel 11
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc2.114%{?buildid}%{?dist}
+%define specrelease 0.rc2.20210106git36bbbd0e234d.117%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -193,7 +193,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
# The kernel tarball/base version
%define kversion 5.11
@@ -502,11 +502,10 @@ Requires: kernel-modules-uname-r = %{KVERREL}%{?variant}
#
BuildRequires: kmod, patch, bash, tar, git-core
BuildRequires: bzip2, xz, findutils, gzip, m4, perl-interpreter, perl-Carp, perl-devel, perl-generators, make, diffutils, gawk
-BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc, bison, flex
+BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc, bison, flex, gcc-c++
BuildRequires: net-tools, hostname, bc, elfutils-devel
BuildRequires: dwarves
BuildRequires: python3-devel
-BuildRequires: gcc-plugin-devel, gcc-c++
%if %{with_headers}
BuildRequires: rsync
%endif
@@ -592,7 +591,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.11-rc2.tar.xz
+Source0: linux-20210106git36bbbd0e234d.tar.xz
Source1: Makefile.rhelver
@@ -742,9 +741,6 @@ Source4000: README.rst
%if !%{nopatches}
Patch1: patch-%{rpmversion}-redhat.patch
-Patch2: secureboot_merge_fix.patch
-Patch3: gcc11-plugins-fix.patch
-Patch4: aarch64build.patch
%endif
# empty final patch to facilitate testing of kernel patches
@@ -1239,8 +1235,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.11-rc2 -c
-mv linux-5.11-rc2 linux-%{KVERREL}
+%setup -q -n kernel-20210106git36bbbd0e234d -c
+mv linux-20210106git36bbbd0e234d linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@@ -1248,9 +1244,6 @@ cp -a %{SOURCE1} .
%if !%{nopatches}
ApplyOptionalPatch patch-%{rpmversion}-redhat.patch
-ApplyOptionalPatch secureboot_merge_fix.patch
-ApplyOptionalPatch gcc11-plugins-fix.patch
-ApplyOptionalPatch aarch64build.patch
%endif
ApplyOptionalPatch linux-kernel-test.patch
@@ -2731,6 +2724,37 @@ fi
#
#
%changelog
+* Wed Jan 06 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc2.20210106git36bbbd0e234d.117]
+- Add gcc-c++ to BuildRequires ("Justin M. Forbes")
+- irq: export irq_check_status_bit (Levi Yun)
+- Turn off vdso_install for ppc ("Justin M. Forbes")
+
+* Wed Jan 06 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc2.20210106git36bbbd0e234d.116]
+- Update CONFIG_KASAN_HW_TAGS ("Justin M. Forbes")
+- gcc-plugins: fix gcc 11 indigestion with plugins... (=?UTF-8?q?Valdis=20Kl=C4=93tnieks?=)
+- fedora: arm: move generic power off/reset to all arm (Peter Robinson)
+- fedora: ARMv7: build in DEVFREQ_GOV_SIMPLE_ONDEMAND until I work out why it's changed (Peter Robinson)
+- fedora: cleanup joystick_adc (Peter Robinson)
+- fedora: update some display options (Peter Robinson)
+- fedora: arm: enable TI PRU options (Peter Robinson)
+- fedora: arm: minor exynos plaform updates (Peter Robinson)
+- arm: SoC: disable Toshiba Visconti SoC (Peter Robinson)
+- common: disable ARCH_BCM4908 (NFC) (Peter Robinson)
+- fedora: minor arm config updates (Peter Robinson)
+- fedora: enable Tegra 234 SoC (Peter Robinson)
+- fedora: arm: enable new Hikey 3xx options (Peter Robinson)
+- Fedora: USB updates (Peter Robinson)
+- fedora: enable the GNSS receiver subsystem (Peter Robinson)
+- Remove POWER_AVS as no longer upstream (Peter Robinson)
+- Cleanup RESET_RASPBERRYPI (Peter Robinson)
+- Cleanup GPIO_CDEV_V1 options. (Peter Robinson)
+- fedora: arm crypto updates (Peter Robinson)
+
+* Tue Jan 05 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc2.20210105git36bbbd0e234d.115]
+- Revert "Merge branch 'ark-enable-structleak' into 'os-build'" (Justin Forbes)
+- CONFIG_KASAN_HW_TAGS for aarch64 ("Justin M. Forbes")
+- Fix up bad merge with efi: generalize efi_get_secureboot ("Justin M. Forbes")
+
* Sun Jan 03 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc1.20210103giteda809aef534.113]
- Fedora: cleanup PCMCIA configs, move to x86 (Peter Robinson)