summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec16
1 files changed, 15 insertions, 1 deletions
diff --git a/kernel.spec b/kernel.spec
index bbe27896e..46f4df2f2 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -546,6 +546,10 @@ Source90: config-sparc64-generic
Source100: config-arm
+# This file is intentionally left empty in the stock kernel. Its a nicety
+# added for those wanting to do custom rebuilds with altered config opts.
+Source1000: config-local
+
# Here should be only the patches up to the upstream canonical Linus tree.
# For a stable release kernel
@@ -1127,6 +1131,14 @@ make -f %{SOURCE20} VERSION=%{version} configs
done
%endif
+# Merge in any user-provided local config option changes
+for i in %{all_arch_configs}
+do
+ mv $i $i.tmp
+ ./merge.pl %{SOURCE1000} $i.tmp > $i
+ rm $i.tmp
+done
+
ApplyOptionalPatch git-linus.diff
ApplyPatch linux-2.6-makefile-after_link.patch
@@ -1957,8 +1969,10 @@ fi
# (__)\ )\/\
# ||----w |
# || ||
-
%changelog
+* Mon Jan 10 2011 Jarod Wilson <jarod@redhat.com>
+- Add support for local rebuild config option overrides
+
* Fri Jan 07 2011 Kyle McMartin <kmcmartin@redhat.com> 2.6.37-2
- drm_i915-check-eDP-encoder-correctly-when-setting-modes.patch reported to
fix HP/Sony eDP issues by adamw and airlied.