summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec49
1 files changed, 41 insertions, 8 deletions
diff --git a/kernel.spec b/kernel.spec
index b2b0eeca7..44328668b 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -7,6 +7,14 @@
%global _lto_cflags %{nil}
+# Cross compile on copr for arm
+# See https://bugzilla.redhat.com/1879599
+%if 0%{?_with_cross_arm:1}
+%global _target_cpu armv7hl
+%global _arch arm
+%global _build_arch arm
+%global _with_cross 1
+%endif
# The kernel's %%install section is special
# Normally the %%install section starts by cleaning up the BUILD_ROOT
@@ -56,7 +64,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
-%global distro_build 0.rc3.122
+%global distro_build 0.rc3.20210114git65f0d2414b70.125
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -99,13 +107,13 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.11.0
-%define pkgrelease 0.rc3.122
+%define pkgrelease 0.rc3.20210114git65f0d2414b70.125
# This is needed to do merge window version magic
%define patchlevel 11
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc3.122%{?buildid}%{?dist}
+%define specrelease 0.rc3.20210114git65f0d2414b70.125%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -195,7 +203,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
# The kernel tarball/base version
%define kversion 5.11
@@ -578,6 +586,7 @@ BuildRequires: pesign >= 0.10-4
%if %{with_cross}
BuildRequires: binutils-%{_build_arch}-linux-gnu, gcc-%{_build_arch}-linux-gnu
%define cross_opts CROSS_COMPILE=%{_build_arch}-linux-gnu-
+%define __strip %{_build_arch}-linux-gnu-strip
%endif
# These below are required to build man pages
@@ -594,7 +603,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.11-rc3.tar.xz
+Source0: linux-20210114git65f0d2414b70.tar.xz
Source1: Makefile.rhelver
@@ -1241,8 +1250,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.11-rc3 -c
-mv linux-5.11-rc3 linux-%{KVERREL}
+%setup -q -n kernel-20210114git65f0d2414b70 -c
+mv linux-20210114git65f0d2414b70 linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
@@ -2724,10 +2733,34 @@ fi
#
#
%changelog
-* Mon Jan 11 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc3.122]
+* Thu Jan 14 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc3.20210114git65f0d2414b70.125]
- irq: export irq_check_status_bit (Levi Yun)
- Turn off vdso_install for ppc ("Justin M. Forbes")
+* Thu Jan 14 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc3.20210114git65f0d2414b70.124]
+- Reword comment (Nicolas Chauvet)
+- Add with_cross_arm conditional (Nicolas Chauvet)
+- Redefines __strip if with_cross (Nicolas Chauvet)
+
+* Wed Jan 13 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc3.20210113gite609571b5ffa.123]
+- fedora: only enable ACPI_CONFIGFS, ACPI_CUSTOM_METHOD in debug kernels (Peter Robinson)
+- fedora: User the same EFI_CUSTOM_SSDT_OVERLAYS as ARK (Peter Robinson)
+- all: all arches/kernels enable the same DMI options (Peter Robinson)
+- all: move SENSORS_ACPI_POWER to common/generic (Peter Robinson)
+- fedora: PCIE_HISI_ERR is already in common (Peter Robinson)
+- all: all ACPI platforms enable ATA_ACPI so move it to common (Peter Robinson)
+- all: x86: move shared x86 acpi config options to generic (Peter Robinson)
+- All: x86: Move ACPI_VIDEO to common/x86 (Peter Robinson)
+- All: x86: Enable ACPI_DPTF (Intel DPTF) (Peter Robinson)
+- All: enable ACPI_BGRT for all ACPI platforms. (Peter Robinson)
+- All: Only build ACPI_EC_DEBUGFS for debug kernels (Peter Robinson)
+- All: Disable Intel Classmate PC ACPI_CMPC option (Peter Robinson)
+- cleanup: ACPI_PROCFS_POWER was removed upstream (Peter Robinson)
+- All: ACPI: De-dupe the ACPI options that are the same across ark/fedora on x86/arm (Peter Robinson)
+
+* Tue Jan 12 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc3.20210112gita0d54b4f5b21.122]
+- Enable the vkms module in Fedora (Jeremy Cline)
+
* Sat Jan 09 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc2.20210109git996e435fd401.119]
- Revert "Merge branch 'revert-29a48502' into 'os-build'" (Justin Forbes)