summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec19
1 files changed, 12 insertions, 7 deletions
diff --git a/kernel.spec b/kernel.spec
index 7bc23fbec..f9adc5692 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -56,7 +56,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
-%global distro_build 0.rc1.20201229gitdea8dcf2a9fa.109
+%global distro_build 0.rc2.114
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -99,13 +99,13 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.11.0
-%define pkgrelease 0.rc1.20201229gitdea8dcf2a9fa.109
+%define pkgrelease 0.rc2.114
# This is needed to do merge window version magic
%define patchlevel 11
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc1.20201229gitdea8dcf2a9fa.109%{?buildid}%{?dist}
+%define specrelease 0.rc2.114%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -507,7 +507,7 @@ BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc, bison, flex, gcc-c++
BuildRequires: net-tools, hostname, bc, elfutils-devel
BuildRequires: dwarves
BuildRequires: python3-devel
-BuildRequires: gcc-plugin-devel
+BuildRequires: gcc-plugin-devel, gcc-c++
%if %{with_headers}
BuildRequires: rsync
%endif
@@ -593,7 +593,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-20201229gitdea8dcf2a9fa.tar.xz
+Source0: linux-5.11-rc2.tar.xz
Source1: Makefile.rhelver
@@ -743,6 +743,7 @@ Source4000: README.rst
%if !%{nopatches}
Patch1: patch-%{rpmversion}-redhat.patch
+Patch2: secureboot_merge_fix.patch
%endif
# empty final patch to facilitate testing of kernel patches
@@ -1237,8 +1238,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-20201229gitdea8dcf2a9fa -c
-mv linux-20201229gitdea8dcf2a9fa linux-%{KVERREL}
+%setup -q -n kernel-5.11-rc2 -c
+mv linux-5.11-rc2 linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
@@ -1246,6 +1247,7 @@ cd linux-%{KVERREL}
%if !%{nopatches}
ApplyOptionalPatch patch-%{rpmversion}-redhat.patch
+ApplyOptionalPatch secureboot_merge_fix.patch
%endif
ApplyOptionalPatch linux-kernel-test.patch
@@ -2716,6 +2718,9 @@ fi
#
#
%changelog
+* Sun Jan 03 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc1.20210103giteda809aef534.113]
+- Fedora: cleanup PCMCIA configs, move to x86 (Peter Robinson)
+
* Wed Dec 23 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.11.0-0.rc0.20201223git614cb5894306.107]
- New configs in drivers/rtc (Fedora Kernel Team)
- redhat/configs: Enable CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL (Josh Poimboeuf)