summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec32
1 files changed, 22 insertions, 10 deletions
diff --git a/kernel.spec b/kernel.spec
index 18498e031..522dc6d55 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -30,7 +30,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
-%global distro_build 0.rc6.13
+%global distro_build 0.rc6.20200922git98477740630f.14
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -71,13 +71,13 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.9.0
-%define pkgrelease 0.rc6.13
+%define pkgrelease 0.rc6.20200922git98477740630f.14
# This is needed to do merge window version magic
%define patchlevel 9
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc6.13%{?buildid}%{?dist}
+%define specrelease 0.rc6.20200922git98477740630f.14%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -168,7 +168,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
# The kernel tarball/base version
%define kversion 5.9
@@ -183,11 +183,11 @@ Summary: The Linux kernel
%define with_ipaclones 0
# no whitelist
%define with_kernel_abi_whitelists 0
-%endif
# Fedora builds these separately
%define with_perf 0
%define with_tools 0
%define with_bpftool 0
+%endif
%if %{with_verbose}
%define make_opts V=1
@@ -568,7 +568,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.9-rc6.tar.xz
+Source0: linux-20200922git98477740630f.tar.xz
Source1: Makefile.rhelver
@@ -791,7 +791,6 @@ Patch72: 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.patch
Patch73: 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
Patch74: 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
Patch75: 0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
-Patch76: 0001-dax-Fix-compilation-for-CONFIG_DAX-CONFIG_FS_DAX.patch
%endif
@@ -1287,8 +1286,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.9-rc6 -c
-mv linux-5.9-rc6 linux-%{KVERREL}
+%setup -q -n kernel-20200922git98477740630f -c
+mv linux-20200922git98477740630f linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
@@ -1369,7 +1368,6 @@ ApplyOptionalPatch 0001-Fixes-acpi-prefer-booting-with-ACPI-over-DTS-to-be-R.pat
ApplyOptionalPatch 0001-Work-around-for-gcc-bug-https-gcc.gnu.org-bugzilla-s.patch
ApplyOptionalPatch 0001-Temporarily-remove-cdomain-from-sphinx-documentation.patch
ApplyOptionalPatch 0001-Filter-out-LTO-build-options-from-the-perl-ccopts.patch
-ApplyOptionalPatch 0001-dax-Fix-compilation-for-CONFIG_DAX-CONFIG_FS_DAX.patch
%endif
@@ -2074,6 +2072,7 @@ BuildKernel %make_target %kernel_image %{_use_vdso}
%global perf_make \
%{__make} -s EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 prefix=%{_prefix} PYTHON=%{__python3}
%if %{with_perf}
+%global _lto_cflags %{nil}
# perf
# make sure check-headers.sh is executable
chmod +x tools/perf/check-headers.sh
@@ -2788,6 +2787,19 @@ fi
#
#
%changelog
+* Tue Sep 22 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc6.20200922git98477740630f.13]
+- Merge ark-patches
+
+* Tue Sep 22 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc6.20200922git98477740630f.12.test]
+- 98477740630f rebase
+- dax: Fix compilation for CONFIG_DAX && !CONFIG_FS_DAX (Jan Kara)
+- Updated changelog for the release based on v5.9-rc6 (Fedora Kernel Team)
+- Revert "KVM: Check the allocation of pv cpu mask" (Vitaly Kuznetsov)
+- KVM: arm64: Remove S1PTW check from kvm_vcpu_dabt_iswrite() (Marc Zyngier)
+- KVM: arm64: Assume write fault on S1PTW permission fault on instruction fetch (Marc Zyngier)
+- rcu-tasks: Prevent complaints of unused show_rcu_tasks_classic_gp_kthread() ("Paul E. McKenney")
+- docs: kvm: add documentation for KVM_CAP_S390_DIAG318 (Collin Walling)
+
* Mon Sep 21 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc6.12]
- Merge ark-patches