summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec36
1 files changed, 23 insertions, 13 deletions
diff --git a/kernel.spec b/kernel.spec
index 817ff0768..a4b40e21e 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -30,7 +30,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
-%global distro_build 36
+%global distro_build 0.rc0.20201013gitc4439713e82a.40
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -70,14 +70,14 @@ Summary: The Linux kernel
%define primary_target rhel
%endif
-%define rpmversion 5.9.0
-%define pkgrelease 36
+%define rpmversion 5.10.0
+%define pkgrelease 0.rc0.20201013gitc4439713e82a.40
# This is needed to do merge window version magic
-%define patchlevel 9
+%define patchlevel 10
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 36%{?buildid}%{?dist}
+%define specrelease 0.rc0.20201013gitc4439713e82a.40%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -168,10 +168,10 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
# The kernel tarball/base version
-%define kversion 5.9
+%define kversion 5.10
%if 0%{?fedora}
# Kernel headers are being split out into a separate package
@@ -184,10 +184,10 @@ Summary: The Linux kernel
# no whitelist
%define with_kernel_abi_whitelists 0
# Fedora builds these separately
-%endif
%define with_perf 0
%define with_tools 0
%define with_bpftool 0
+%endif
%if %{with_verbose}
%define make_opts V=1
@@ -568,7 +568,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.9.tar.xz
+Source0: linux-20201013gitc4439713e82a.tar.xz
Source1: Makefile.rhelver
@@ -1212,8 +1212,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.9 -c
-mv linux-5.9 linux-%{KVERREL}
+%setup -q -n kernel-20201013gitc4439713e82a -c
+mv linux-20201013gitc4439713e82a linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
@@ -1924,6 +1924,7 @@ BuildKernel %make_target %kernel_image %{_use_vdso}
%global perf_make \
%{__make} -s EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 prefix=%{_prefix} PYTHON=%{__python3}
%if %{with_perf}
+%global _lto_cflags %{nil}
# perf
# make sure check-headers.sh is executable
chmod +x tools/perf/check-headers.sh
@@ -2638,11 +2639,20 @@ fi
#
#
%changelog
-* Mon Oct 12 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-35]
+* Tue Oct 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201013gitc4439713e82a.39]
- Filter out LTO build options from the perl ccopts ("Justin M. Forbes")
-- Temporarily remove cdomain from sphinx documentation ("Justin M. Forbes")
- Work around for gcc bug https://gcc.gnu.org/bugzilla/show_bug.cgi?id=96377 ("Justin M. Forbes")
+* Tue Oct 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201013gitc4439713e82a.38.test]
+- c4439713e82a rebase
+
+* Tue Oct 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.10.0-0.rc0.20201013git865c50e1d279.37.test]
+- 865c50e1d279 rebase
+
+* Tue Oct 13 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-35.test]
+- Disable Speakup synth DECEXT ("Justin M. Forbes")
+- Enable Speakup for Fedora since it is out of staging ("Justin M. Forbes")
+
* Mon Oct 12 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-34.test]
- v5.9 rebase