summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec20
1 files changed, 13 insertions, 7 deletions
diff --git a/kernel.spec b/kernel.spec
index 8713109ae..ef0f7997f 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -631,6 +631,8 @@ Patch331: bcm2835-cpufreq-add-CPU-frequency-control-driver.patch
Patch332: bcm2835-hwmon-Add-support-for-RPi-voltage-sensor.patch
+Patch334: bcm283x-drm-vc4-set-is_yuv-to-false-when-num_planes-1.patch
+
# Patches enabling device specific brcm firmware nvram
# https://www.spinics.net/lists/linux-wireless/msg178827.html
Patch340: brcmfmac-Remove-firmware-loading-code-duplication.patch
@@ -682,9 +684,6 @@ Patch528: 0008-console-dummycon-export-dummycon_-un-register_output.patch
Patch529: 0009-fbcon-Only-defer-console-takeover-if-the-current-con.patch
Patch530: 0010-fbcon-Do-not-takeover-the-console-from-atomic-contex.patch
-# CVE-2018-15471 rhbz 1610555 1618414
-Patch531: xsa270.patch
-
# rhbz 1572944
Patch533: 0001-random-add-a-config-option-to-trust-the-CPU-s-hwrng.patch
Patch534: 0001-random-make-CPU-trust-a-boot-parameter.patch
@@ -1343,7 +1342,7 @@ BuildKernel() {
%ifarch %{arm} aarch64
%{make} %{?make_opts} ARCH=$Arch dtbs dtbs_install INSTALL_DTBS_PATH=$RPM_BUILD_ROOT/%{image_install_path}/dtb-$KernelVer
cp -r $RPM_BUILD_ROOT/%{image_install_path}/dtb-$KernelVer $RPM_BUILD_ROOT/lib/modules/$KernelVer/dtb
- find arch/$Arch/boot/dts -name '*.dtb' -type f | xargs rm -f
+ find arch/$Arch/boot/dts -name '*.dtb' -type f -delete
%endif
# Start installing the results
@@ -1624,7 +1623,7 @@ BuildKernel() {
ln -sf $DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
# prune junk from kernel-devel
- find $RPM_BUILD_ROOT/usr/src/kernels -name ".*.cmd" -exec rm -f {} \;
+ find $RPM_BUILD_ROOT/usr/src/kernels -name ".*.cmd" -delete
# build a BLS config for this kernel
%{SOURCE43} "$KernelVer" "$RPM_BUILD_ROOT" "%{?variant}"
@@ -1734,7 +1733,7 @@ make ARCH=%{hdrarch} INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr headers_install
find $RPM_BUILD_ROOT/usr/include \
\( -name .install -o -name .check -o \
- -name ..install.cmd -o -name ..check.cmd \) | xargs rm -f
+ -name ..install.cmd -o -name ..check.cmd \) -delete
%endif
@@ -1744,7 +1743,7 @@ make ARCH=%{hdrarch} INSTALL_HDR_PATH=$RPM_BUILD_ROOT/usr/tmp-headers headers_in
find $RPM_BUILD_ROOT/usr/tmp-headers/include \
\( -name .install -o -name .check -o \
- -name ..install.cmd -o -name ..check.cmd \) | xargs rm -f
+ -name ..install.cmd -o -name ..check.cmd \) -delete
# Copy all the architectures we care about to their respective asm directories
for arch in arm arm64 powerpc s390 x86 ; do
@@ -1954,6 +1953,13 @@ fi
#
#
%changelog
+* Tue Oct 16 2018 Peter Robinson <pbrobinson@fedoraproject.org>
+- Fixes to Rock960 series of devices, improves stability considerably
+- Raspberry Pi graphics fix
+
+* Mon Oct 15 2018 Justin M. Forbes <jforbes@fedoraproject.org> - 4.18.14-300
+- Linux v4.18.14
+
* Fri Oct 12 2018 Peter Robinson <pbrobinson@fedoraproject.org>
- Rebase device specific NVRAM files on brcm WiFi devices to latest