summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec37
1 files changed, 23 insertions, 14 deletions
diff --git a/kernel.spec b/kernel.spec
index 2ed2e1014..afe672161 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -6,7 +6,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1. For rawhide
# and/or a kernel built from an rc or git snapshot, released_kernel should
# be 0.
-%global released_kernel 1
+%global released_kernel 0
# Sign modules on x86. Make sure the config files match this setting if more
# architectures are added.
@@ -77,7 +77,7 @@ Summary: The Linux kernel
# The rc snapshot level
%global rcrev 0
# The git snapshot level
-%define gitrev 0
+%define gitrev 1
# Set rpm version accordingly
%define rpmversion 4.%{upstream_sublevel}.0
%endif
@@ -132,7 +132,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
%if %{with_verbose}
%define make_opts V=1
@@ -523,9 +523,6 @@ Source5000: patch-4.%{base_sublevel}-git%{gitrev}.xz
# ongoing complaint, full discussion delayed until ksummit/plumbers
Patch002: 0001-iio-Use-event-header-from-kernel-tree.patch
-# gcc -Werror=aliasing workaround
-Patch003: 0001-Temporarily-work-around-gcc-aliasing-warning-error.patch
-
%if !%{nopatches}
# Git trees.
@@ -605,9 +602,6 @@ Patch305: qcom-msm89xx-fixes.patch
# https://patchwork.kernel.org/patch/10173115/
Patch306: arm-dts-imx6qdl-udoo-Disable-usbh1-to-avoid-kernel-hang.patch
-# Fix USB on the RPi https://patchwork.kernel.org/patch/9879371/
-Patch307: bcm283x-dma-mapping-skip-USB-devices-when-configuring-DMA-during-probe.patch
-
# http://patches.linaro.org/patch/131764/
Patch308: wcn36xx-Fix-firmware-crash-due-to-corrupted-buffer-address.patch
@@ -617,18 +611,25 @@ Patch309: wcn36xx-reduce-verbosity-of-drivers-messages.patch
# https://www.spinics.net/lists/arm-kernel/msg632925.html
Patch313: arm-crypto-sunxi-ss-Add-MODULE_ALIAS-to-sun4i-ss.patch
-Patch314: bcm283x-gpio-expander.patch
+# Fix USB on the RPi https://patchwork.kernel.org/patch/9879371/
+Patch320: bcm283x-dma-mapping-skip-USB-devices-when-configuring-DMA-during-probe.patch
# https://www.spinics.net/lists/arm-kernel/msg621982.html
-Patch315: bcm283x-Fix-probing-of-bcm2835-i2s.patch
+Patch321: bcm283x-Fix-probing-of-bcm2835-i2s.patch
# https://www.spinics.net/lists/arm-kernel/msg633942.html
-Patch316: mmc-sdhci-iproc-Disable-preset-values-for-BCM2835.patch
+Patch322: mmc-sdhci-iproc-Disable-preset-values-for-BCM2835.patch
# https://www.spinics.net/lists/arm-kernel/msg633945.html
-Patch317: bcm2835-hwrng-Handle-deferred-clock-properly.patch
+Patch323: bcm2835-hwrng-Handle-deferred-clock-properly.patch
-Patch318: bcm2837-rpi-initial-support-for-the-3.patch
+Patch324: bcm283x-clk-audio-fixes.patch
+
+# Enabling Patches for the RPi3+
+Patch330: bcm2837-rpi-initial-support-for-the-3.patch
+Patch331: bcm2837-gpio-expander.patch
+Patch332: bcm2837-enable-pmu.patch
+Patch333: bcm2837-lan78xx-fixes.patch
# 400 - IBM (ppc/s390x) patches
@@ -1898,6 +1899,14 @@ fi
#
#
%changelog
+* Tue Apr 03 2018 Justin M. Forbes <jforbes@fedoraproject.org> - 4.17.0-0.rc0.git1.1
+- Linux v4.16-2520-g642e7fd23353
+- Reenable debugging options.
+
+* Mon Apr 2 2018 Peter Robinson <pbrobinson@fedoraproject.org> 4.16.0-2
+- Improvements for the Raspberry Pi 3+
+- Fixes and minor improvements to Raspberry Pi 2/3
+
* Mon Apr 02 2018 Jeremy Cline <jeremy@jcline.org> - 4.16.0-1
- Linux v4.16
- Disable debugging options.