summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorThorsten Leemhuis <fedora@leemhuis.info>2022-10-21 14:15:57 +0200
committerThorsten Leemhuis <fedora@leemhuis.info>2022-10-21 14:15:57 +0200
commitfa42048be31c2590b505e694b47b8381c39e38a5 (patch)
treef19d63f9395663ac07475e1855b7833480699c22 /kernel.spec
parent599924728e5ed30ceb23e04f20974d6acf620c8b (diff)
parentc74d9c2380cf94d663aaf57a2dec70295dc9fdb9 (diff)
downloadkernel-fa42048be31c2590b505e694b47b8381c39e38a5.tar.gz
kernel-fa42048be31c2590b505e694b47b8381c39e38a5.tar.xz
kernel-fa42048be31c2590b505e694b47b8381c39e38a5.zip
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec34
1 files changed, 18 insertions, 16 deletions
diff --git a/kernel.spec b/kernel.spec
index 5c04d0df3..e98f3ec77 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -126,17 +126,17 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 1
# define buildid .local
-%define specversion 6.0.2
+%define specversion 6.0.3
%define patchversion 6.0
%define pkgrelease 325
%define kversion 6
-%define tarfile_release 6.0.2
+%define tarfile_release 6.0.3
# This is needed to do merge window version magic
%define patchlevel 0
# This allows pkg_release to have configurable %%{?dist} tag
%define specrelease 325%{?buildid}%{?dist}
# This defines the kabi tarball version
-%define kabiversion 6.0.1
+%define kabiversion 6.0.2
# If this variable is set to 1, a bpf selftests build failure will cause a
# fatal kernel package build error
@@ -579,7 +579,7 @@ Requires: kernel-modules-uname-r = %{KVERREL}
#
# List the packages used during the kernel build
#
-BuildRequires: kmod, bash, coreutils, tar, git-core, which
+BuildRequires: kmod, patch, bash, coreutils, tar, git-core, which
BuildRequires: bzip2, xz, findutils, gzip, m4, perl-interpreter, perl-Carp, perl-devel, perl-generators, make, diffutils, gawk
BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc, bison, flex, gcc-c++
BuildRequires: net-tools, hostname, bc, elfutils-devel
@@ -1396,7 +1396,7 @@ if [ "%{patches}" != "%%{patches}" ] ; then
done
fi 2>/dev/null
-patch_command='git apply'
+patch_command='patch -p1 -F1 -s'
ApplyPatch()
{
local patch=$1
@@ -2200,18 +2200,13 @@ BuildKernel() {
# the F17 UsrMove feature.
ln -sf $DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
-%ifnarch armv7hl
+# %ifnarch armv7hl
# Generate vmlinux.h and put it to kernel-devel path
# zfcpdump build does not have btf anymore
- if [ "$Variant" != "zfcpdump" ]; then
- # disabled for vanilla builds, to avoid a build problem:
- #
- # + bpftool btf dump file vmlinux format c
- # Error: failed to load BTF from vmlinux: Unknown error -2
- # bpftool btf dump file vmlinux format c > $RPM_BUILD_ROOT/$DevelDir/vmlinux.h
- :
- fi
-%endif
+# if [ "$Variant" != "zfcpdump" ]; then
+# bpftool btf dump file vmlinux format c > $RPM_BUILD_ROOT/$DevelDir/vmlinux.h
+# fi
+# %endif
# prune junk from kernel-devel
find $RPM_BUILD_ROOT/usr/src/kernels -name ".*.cmd" -delete
@@ -3191,9 +3186,16 @@ fi
#
#
%changelog
-* Wed Oct 12 2022 Justin M. Forbes <jforbes@fedoraproject.org> [6.0.1-300]
+* Sun Oct 16 2022 Justin M. Forbes <jforbes@fedoraproject.org> [6.0.2-301]
+- Revert "redhat: properly handle binary files in patches" (Justin M. Forbes)
+
+* Sat Oct 15 2022 Justin M. Forbes <jforbes@fedoraproject.org> [6.0.2-0]
+- phy: rockchip-inno-usb2: Return zero after otg sync (Peter Geis)
+- drm/vc4: hdmi: Check the HSM rate at runtime_resume (Maxime Ripard)
+- drm/vc4: hdmi: Enforce the minimum rate at runtime_resume (Maxime Ripard)
- drm/i915/bios: Use hardcoded fp_timing size for generating LFP data pointers (Mark Pearson)
- Trim changelog before 6.0 reset (Justin M. Forbes)
+- Linux v6.0.2
* Wed Oct 12 2022 Justin M. Forbes <jforbes@fedoraproject.org> [6.0.1-0]
- scsi: stex: Properly zero out the passthrough command structure (Linus Torvalds)