summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorChuck Ebbert <cebbert@redhat.com>2011-11-07 08:16:50 -0500
committerChuck Ebbert <cebbert@redhat.com>2011-11-07 08:16:50 -0500
commit7cfa6899ffd5580ad97e1f840edee9cf5ca51eab (patch)
treee10d45fe29898cf82dc7edc26fb5dd91415a6b2f /kernel.spec
parent2b4d1d83799c3dafb3b2f4cabf3b36dab722c6bb (diff)
downloadkernel-7cfa6899ffd5580ad97e1f840edee9cf5ca51eab.tar.gz
kernel-7cfa6899ffd5580ad97e1f840edee9cf5ca51eab.tar.xz
kernel-7cfa6899ffd5580ad97e1f840edee9cf5ca51eab.zip
Add support for .xz compressed patches
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec5
1 files changed, 3 insertions, 2 deletions
diff --git a/kernel.spec b/kernel.spec
index 43fa760c7..e5a4fc6db 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -509,7 +509,7 @@ ExclusiveOS: Linux
# List the packages used during the kernel build
#
BuildRequires: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
-BuildRequires: bzip2, findutils, gzip, m4, perl, make >= 3.78, diffutils, gawk
+BuildRequires: bzip2, xz, findutils, gzip, m4, perl, make >= 3.78, diffutils, gawk
BuildRequires: gcc >= 3.4.2, binutils >= 2.12, redhat-rpm-config
BuildRequires: net-tools
BuildRequires: xmlto, asciidoc
@@ -996,7 +996,8 @@ ApplyPatch()
%endif
case "$patch" in
*.bz2) bunzip2 < "$RPM_SOURCE_DIR/$patch" | $patch_command ${1+"$@"} ;;
- *.gz) gunzip < "$RPM_SOURCE_DIR/$patch" | $patch_command ${1+"$@"} ;;
+ *.gz) gunzip < "$RPM_SOURCE_DIR/$patch" | $patch_command ${1+"$@"} ;;
+ *.xz) unxz < "$RPM_SOURCE_DIR/$patch" | $patch_command ${1+"$@"} ;;
*) $patch_command ${1+"$@"} < "$RPM_SOURCE_DIR/$patch" ;;
esac
}