summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorThorsten Leemhuis <fedora@leemhuis.info>2022-10-10 18:10:41 +0200
committerThorsten Leemhuis <fedora@leemhuis.info>2022-10-10 18:10:41 +0200
commit236f7365717ffd466e3a79ce63fedad42f7ca092 (patch)
treed4fa26070325ab1bb243173431bf3e1e354ad716 /kernel.spec
parent89e69122456a7828871fc2620fcde8dd0a6453ab (diff)
parent9e3155cd9e8e3f8313c10cccc060056933b0fcd4 (diff)
downloadkernel-236f7365717ffd466e3a79ce63fedad42f7ca092.tar.gz
kernel-236f7365717ffd466e3a79ce63fedad42f7ca092.tar.xz
kernel-236f7365717ffd466e3a79ce63fedad42f7ca092.zip
Merge remote-tracking branch 'origin/rawhide' into rawhide-user-thl-vanilla-fedora
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec29
1 files changed, 23 insertions, 6 deletions
diff --git a/kernel.spec b/kernel.spec
index 9271b1d9d..53aa10fa6 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -128,13 +128,13 @@ Summary: The Linux kernel
# define buildid .local
%define specversion 6.1.0
%define patchversion 6.1
-%define pkgrelease 0.rc0.20221007git4c86114194e6.5
+%define pkgrelease 0.rc0.20221010git493ffd6605b2.7
%define kversion 6
-%define tarfile_release 6.0-6475-g4c86114194e6
+%define tarfile_release 6.0-9423-g493ffd6605b2
# This is needed to do merge window version magic
%define patchlevel 1
# This allows pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc0.20221007git4c86114194e6.5%{?buildid}%{?dist}
+%define specrelease 0.rc0.20221010git493ffd6605b2.7%{?buildid}%{?dist}
# This defines the kabi tarball version
%define kabiversion 6.1.0
@@ -1681,6 +1681,9 @@ BuildKernel() {
find arch/$Arch/boot/dts -name '*.dtb' -type f -delete
%endif
+ # Remove large intermediate files we no longer need to save space
+ rm vmlinux.o .tmp_vmlinux.btf
+
# Start installing the results
install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
install -m 644 .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/config
@@ -2024,9 +2027,11 @@ BuildKernel() {
#
# save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
+ # (use mv + symlink instead of cp to reduce disk space requirements)
#
mkdir -p $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer
- cp vmlinux $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer
+ mv vmlinux $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer
+ ln -s $RPM_BUILD_ROOT%{debuginfodir}/lib/modules/$KernelVer/vmlinux vmlinux
if [ -n "%{vmlinux_decompressor}" ]; then
eu-readelf -n %{vmlinux_decompressor} | grep "Build ID" | awk '{print $NF}' > vmlinux.decompressor.id
# Without build-id the build will fail. But for s390 the build-id
@@ -2336,7 +2341,7 @@ pushd tools/gpio/
popd
# build VM tools
pushd tools/vm/
-%{tools_make} slabinfo page_owner_sort
+%{tools_make} CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" slabinfo page_owner_sort
popd
pushd tools/tracing/rtla
%{tools_make}
@@ -3189,10 +3194,22 @@ fi
#
#
%changelog
-* Fri Oct 07 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc0.4c86114194e6.5]
+* Mon Oct 10 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc0.493ffd6605b2.7]
- Add acpi video to the filter_modules.sh for rhel (Justin M. Forbes)
- Change acpi_bus_get_acpi_device to acpi_get_acpi_dev (Justin M. Forbes)
+- Turn on ACPI_VIDEO for arm (Justin M. Forbes)
+- Turn on CONFIG_PRIME_NUMBERS as a module (Justin M. Forbes)
- Add new drm kunit tests to mod-internal.list (Justin M. Forbes)
+- redhat: fix elf got hardening for vm tools (Frantisek Hrbata)
+- kernel.spec.template: remove some temporary files early (Ondrej Mosnacek)
+- kernel.spec.template: avoid keeping two copies of vmlinux (Ondrej Mosnacek)
+- Linux v6.1.0-0.rc0.493ffd6605b2
+
+* Sun Oct 09 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc0.a6afa4199d3d.6]
+- Linux v6.1.0-0.rc0.a6afa4199d3d
+
+* Sat Oct 08 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc0.e8bc52cb8df8.5]
+- Linux v6.1.0-0.rc0.e8bc52cb8df8
* Fri Oct 07 2022 Fedora Kernel Team <kernel-team@fedoraproject.org> [6.1.0-0.rc0.4c86114194e6.4]
- Add fortify_kunit to mod-internal.list (Justin M. Forbes)