summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorLaura Abbott <labbott@redhat.com>2019-03-11 13:35:25 -0700
committerLaura Abbott <labbott@redhat.com>2019-03-11 13:59:25 -0700
commit2d62e0d70f99987e98fedec648a10a286000eab0 (patch)
treeb7c04f62e6915fe7865db2fafadd0ade3a323981 /kernel.spec
parent4c7c358c38e94d1ccbc1f848e6cb98711fa9284c (diff)
downloadkernel-2d62e0d70f99987e98fedec648a10a286000eab0.tar.gz
kernel-2d62e0d70f99987e98fedec648a10a286000eab0.tar.xz
kernel-2d62e0d70f99987e98fedec648a10a286000eab0.zip
Linux v5.0.1 rebase
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec111
1 files changed, 52 insertions, 59 deletions
diff --git a/kernel.spec b/kernel.spec
index fdd532afd..0b434f383 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -42,36 +42,38 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 200
+%global baserelease 300
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
# which yields a base_sublevel of 0.
-%define base_sublevel 20
+%define base_sublevel 0
## If this is a released kernel ##
%if 0%{?released_kernel}
# Do we have a -stable update to apply?
-%define stable_update 3
+%define stable_update 1
# Set rpm version accordingly
%if 0%{?stable_update}
%define stablerev %{stable_update}
%define stable_base %{stable_update}
%endif
-%define rpmversion 4.%{base_sublevel}.%{stable_update}
+%define rpmversion 5.%{base_sublevel}.%{stable_update}
## The not-released-kernel case ##
%else
# The next upstream release sublevel (base_sublevel+1)
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
+# Work around for major version bump
+%define upstream_sublevel 0
# The rc snapshot level
-%global rcrev 7
+%global rcrev 0
# The git snapshot level
%define gitrev 0
# Set rpm version accordingly
-%define rpmversion 4.%{upstream_sublevel}.0
+%define rpmversion 5.%{upstream_sublevel}.0
%endif
# Nb: The above rcrev and gitrev values automagically define Patch00 and Patch01 below.
@@ -162,7 +164,7 @@ Summary: The Linux kernel
%endif
# The kernel tarball/base version
-%define kversion 4.%{base_sublevel}
+%define kversion 5.%{base_sublevel}
%define make_target bzImage
%define image_install_path boot
@@ -387,8 +389,10 @@ BuildRequires: kmod, patch, bash, tar, git-core
BuildRequires: bzip2, xz, findutils, gzip, m4, perl-interpreter, perl-Carp, perl-devel, perl-generators, make, diffutils, gawk
BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc, bison, flex
BuildRequires: net-tools, hostname, bc, elfutils-devel, gcc-plugin-devel
+%if 0%{?fedora}
# Used to mangle unversioned shebangs to be Python 3
BuildRequires: /usr/bin/pathfix.py
+%endif
%if %{with_sparse}
BuildRequires: sparse
%endif
@@ -422,7 +426,7 @@ BuildRequires: binutils-%{_build_arch}-linux-gnu, gcc-%{_build_arch}-linux-gnu
%define cross_opts CROSS_COMPILE=%{_build_arch}-linux-gnu-
%endif
-Source0: https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{kversion}.tar.xz
+Source0: https://www.kernel.org/pub/linux/kernel/v5.x/linux-%{kversion}.tar.xz
Source11: x509.genkey
Source12: remove-binary-diff.pl
@@ -469,7 +473,7 @@ Source1000: kernel-local
# For a stable release kernel
%if 0%{?stable_update}
%if 0%{?stable_base}
-%define stable_patch_00 patch-4.%{base_sublevel}.%{stable_base}.xz
+%define stable_patch_00 patch-5.%{base_sublevel}.%{stable_base}.xz
Source5000: %{stable_patch_00}
%endif
@@ -478,14 +482,14 @@ Source5000: %{stable_patch_00}
# near the top of this spec file.
%else
%if 0%{?rcrev}
-Source5000: patch-4.%{upstream_sublevel}-rc%{rcrev}.xz
+Source5000: patch-5.%{upstream_sublevel}-rc%{rcrev}.xz
%if 0%{?gitrev}
-Source5001: patch-4.%{upstream_sublevel}-rc%{rcrev}-git%{gitrev}.xz
+Source5001: patch-5.%{upstream_sublevel}-rc%{rcrev}-git%{gitrev}.xz
%endif
%else
# pre-{base_sublevel+1}-rc1 case
%if 0%{?gitrev}
-Source5000: patch-4.%{base_sublevel}-git%{gitrev}.xz
+Source5000: patch-5.%{base_sublevel}-git%{gitrev}.xz
%endif
%endif
%endif
@@ -539,14 +543,6 @@ Patch201: efi-lockdown.patch
Patch202: KEYS-Allow-unrestricted-boot-time-addition-of-keys-t.patch
-Patch203: Add-EFI-signature-data-types.patch
-
-Patch204: Add-an-EFI-signature-blob-parser-and-key-loader.patch
-
-Patch205: MODSIGN-Import-certificates-from-UEFI-Secure-Boot.patch
-
-Patch206: MODSIGN-Support-not-importing-certs-from-db.patch
-
# bz 1497559 - Make kernel MODSIGN code not error on missing variables
Patch207: 0001-Make-get_cert_list-not-complain-about-cert-lists-tha.patch
Patch208: 0002-Add-efi_status_to_str-and-rework-efi_status_to_err.patch
@@ -577,32 +573,23 @@ Patch305: qcom-msm89xx-fixes.patch
# https://patchwork.kernel.org/project/linux-mmc/list/?submitter=71861
Patch306: arm-sdhci-esdhc-imx-fixes.patch
-# https://patchwork.kernel.org/patch/10686407/
-Patch331: raspberrypi-Fix-firmware-calls-with-large-buffers.patch
+# https://patchwork.kernel.org/patch/10778815/
+Patch308: drm-enable-uncached-DMA-optimization-for-ARM-and-arm64.patch
-# Improve raspberry pi camera and analog audio
-Patch332: bcm2836-Improve-VCHIQ-cache-line-size-handling.patch
-Patch333: bcm2835-vc04_services-Improve-driver-load-unload.patch
+Patch310: arm64-rock960-enable-hdmi-audio.patch
+Patch311: arm64-rock960-add-onboard-wifi-bt.patch
+Patch312: arm64-rock960-enable-tsadc.patch
# Initall support for the 3A+
-Patch334: bcm2837-dts-add-Raspberry-Pi-3-A.patch
-
-# Fixes for bcm2835 mmc (sdcard) driver
-Patch335: bcm2835-mmc-Several-fixes-for-bcm2835-driver.patch
-
-# https://patchwork.kernel.org/patch/10741809/
-Patch336: bcm2835-mmc-sdhci-iproc-handle-mmc_of_parse-errors-during-probe.patch
+Patch330: bcm2837-dts-add-Raspberry-Pi-3-A.patch
# https://www.spinics.net/lists/arm-kernel/msg699583.html
-Patch337: ARM-dts-bcm283x-Several-DTS-improvements.patch
+Patch331: ARM-dts-bcm283x-Several-DTS-improvements.patch
-Patch339: bcm2835-cpufreq-add-CPU-frequency-control-driver.patch
-
-# Patches enabling device specific brcm firmware nvram
-# https://www.spinics.net/lists/linux-wireless/msg178827.html
-Patch340: brcmfmac-Remove-firmware-loading-code-duplication.patch
+# https://patchwork.freedesktop.org/patch/290632/
+Patch332: drm-vc4-Use-16bpp-by-default-for-the-fbdev-buffer.patch
-Patch341: brcmfmac-Call-brcmf_dmi_probe-before-brcmf_of_probe.patch
+Patch339: bcm2835-cpufreq-add-CPU-frequency-control-driver.patch
# Fix for AllWinner A64 Timer Errata, still not final
# https://www.spinics.net/lists/arm-kernel/msg699622.html
@@ -612,23 +599,24 @@ Patch350: Allwinner-A64-timer-workaround.patch
# 500 - Temp fixes/CVEs etc
-# rhbz 1476467
-Patch501: Fix-for-module-sig-verification.patch
-
# rhbz 1431375
-Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
+Patch501: input-rmi4-remove-the-need-for-artifical-IRQ.patch
-# rhbz 1526312 (accelerometer part of the bug), patches pending upstream
-Patch504: iio-accel-kxcjk1013-Add-more-hardware-ids.patch
+# https://patchwork.kernel.org/patch/10752253/
+Patch504: efi-use-32-bit-alignment-for-efi_guid_t.patch
-# rhbz 1645070 patch queued upstream for merging into 4.21
-Patch505: asus-fx503-keyb.patch
+# gcc9 fixes
+Patch506: 0001-s390-jump_label-Correct-asm-contraint.patch
+Patch507: 0001-Drop-that-for-now.patch
-# CVE-2019-3701 rhbz 1663729 1663730
-Patch506: CVE-2019-3701.patch
+# patches for https://fedoraproject.org/wiki/Changes/FlickerFreeBoot
+# fixes, queued in -next for merging into 5.1
+Patch508: i915-fixes-for-fastboot.patch
+# fastboot by default on Skylake and newer, queued in -next for merging into 5.1
+Patch509: i915-enable-fastboot-on-skylake.patch
+# fastboot by default on VLV/CHV (BYT/CHT), queued in -next for merging into 5.1
+Patch510: i915-enable-fastboot-on-vlv-chv.patch
-# CVE-2019-3459 and CVE-2019-3460 rhbz 1663176 1663179 1665925
-Patch507: CVE-2019-3459-and-CVE-2019-3460.patch
# END OF PATCH DEFINITIONS
@@ -900,7 +888,7 @@ ApplyPatch()
exit 1
fi
if ! grep -E "^Patch[0-9]+: $patch\$" %{_specdir}/${RPM_PACKAGE_NAME%%%%%{?variant}}.spec ; then
- if [ "${patch:0:8}" != "patch-4." ] ; then
+ if [ "${patch:0:8}" != "patch-5." ] ; then
echo "ERROR: Patch $patch not listed as a source patch in specfile"
exit 1
fi
@@ -933,20 +921,20 @@ ApplyOptionalPatch()
# Update to latest upstream.
%if 0%{?released_kernel}
-%define vanillaversion 4.%{base_sublevel}
+%define vanillaversion 5.%{base_sublevel}
# non-released_kernel case
%else
%if 0%{?rcrev}
-%define vanillaversion 4.%{upstream_sublevel}-rc%{rcrev}
+%define vanillaversion 5.%{upstream_sublevel}-rc%{rcrev}
%if 0%{?gitrev}
-%define vanillaversion 4.%{upstream_sublevel}-rc%{rcrev}-git%{gitrev}
+%define vanillaversion 5.%{upstream_sublevel}-rc%{rcrev}-git%{gitrev}
%endif
%else
# pre-{base_sublevel+1}-rc1 case
%if 0%{?gitrev}
-%define vanillaversion 4.%{base_sublevel}-git%{gitrev}
+%define vanillaversion 5.%{base_sublevel}-git%{gitrev}
%else
-%define vanillaversion 4.%{base_sublevel}
+%define vanillaversion 5.%{base_sublevel}
%endif
%endif
%endif
@@ -959,7 +947,7 @@ ApplyOptionalPatch()
# Build a list of the other top-level kernel tree directories.
# This will be used to hardlink identical vanilla subdirs.
-sharedirs=$(find "$PWD" -maxdepth 1 -type d -name 'kernel-4.*' \
+sharedirs=$(find "$PWD" -maxdepth 1 -type d -name 'kernel-5.*' \
| grep -x -v "$PWD"/kernel-%{kversion}%{?dist}) ||:
# Delete all old stale trees.
@@ -1175,6 +1163,7 @@ find . \( -name "*.orig" -o -name "*~" \) -delete >/dev/null
# remove unnecessary SCM files
find . -name .gitignore -delete >/dev/null
+%if 0%{?fedora}
# Mangle /usr/bin/python shebangs to /usr/bin/python3
# Mangle all Python shebangs to be Python 3 explicitly
# -p preserves timestamps
@@ -1184,6 +1173,7 @@ pathfix.py -pni "%{__python3} %{py3_shbang_opts}" scripts/
pathfix.py -pni "%{__python3} %{py3_shbang_opts}" scripts/diffconfig
pathfix.py -pni "%{__python3} %{py3_shbang_opts}" scripts/bloat-o-meter
pathfix.py -pni "%{__python3} %{py3_shbang_opts}" scripts/show_delta
+%endif
cd ..
@@ -1252,7 +1242,7 @@ BuildKernel() {
# make sure EXTRAVERSION says what we want it to say
# Trim the release if this is a CI build, since KERNELVERSION is limited to 64 characters
- ShortRel=$(python3 -c "import re; print(re.sub(r'\.pr\.[0-9A-Fa-f]{32}', '', '%{release}'))")
+ ShortRel=$(perl -e "print \"%{release}\" =~ s/\.pr\.[0-9A-Fa-f]{32}//r")
perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -${ShortRel}.%{_target_cpu}${Flav}/" Makefile
# if pre-rc1 devel kernel, must fix up PATCHLEVEL for our versioning scheme
@@ -1901,6 +1891,9 @@ fi
#
#
%changelog
+* Mon Mar 11 2019 Laura Abbott <labbott@redhat.com> - 5.0.1-300
+- Linux v5.0.1
+
* Wed Jan 16 2019 Jeremy Cline <jeremy@jcline.org>
- Fix CVE-2019-3459 and CVE-2019-3460 (rhbz 1663176 1663179 1665925)