summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJosh Boyer <jwboyer@redhat.com>2011-12-13 10:01:29 -0500
committerJosh Boyer <jwboyer@redhat.com>2011-12-13 10:01:29 -0500
commitd496e06781739677e02de7853faf91fd5df96332 (patch)
tree21e43b5c380f3d6984154bfdc153a3571e9dd694 /kernel.spec
parent98db752ff892c37e5aa61f38b2984bb697d2c6eb (diff)
downloadkernel-d496e06781739677e02de7853faf91fd5df96332.tar.gz
kernel-d496e06781739677e02de7853faf91fd5df96332.tar.xz
kernel-d496e06781739677e02de7853faf91fd5df96332.zip
mod-extras: Don't fail the build if a module is listed that isn't built
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec7
1 files changed, 5 insertions, 2 deletions
diff --git a/kernel.spec b/kernel.spec
index ad3b5e9a2..8a8015182 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -54,7 +54,7 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 2
+%global baserelease 3
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
@@ -1739,7 +1739,7 @@ BuildKernel() {
for mod in `cat mod-extra3.list`
do
# get the path for the module
- modpath=`grep /$mod modnames`
+ modpath=`grep /$mod modnames` ||:
[ -z "$modpath" ] && continue;
echo $modpath >> dep.list
done
@@ -2229,6 +2229,9 @@ fi
# ||----w |
# || ||
%changelog
+* Tue Dec 13 2011 Josh Boyer <jwboyer@redhat.com>
+- mod-extras: Don't fail the build if a module is listed that isn't built
+
* Mon Dec 12 2011 John W. Linville <linville@redhat.com>
- Turn-off backports until TAINT_OOT_MODULE issue is resolved