summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorKyle McMartin <kyle@redhat.com>2013-06-12 13:39:46 -0400
committerKyle McMartin <kyle@redhat.com>2013-06-12 13:41:05 -0400
commitbe52afe362ad1949af0a306b0ba1a0c31567720f (patch)
treede1f1f7819ef467ca63e65ffd24868dd10fb74a3 /kernel.spec
parentbc5f99d50a38dbde20f7e1bdb25eb1315ee983ad (diff)
downloadkernel-be52afe362ad1949af0a306b0ba1a0c31567720f.tar.gz
kernel-be52afe362ad1949af0a306b0ba1a0c31567720f.tar.xz
kernel-be52afe362ad1949af0a306b0ba1a0c31567720f.zip
Fix thinko in last commit
kernel-PAE will be "used" (but not populated) for all but armv7hl. On !i686 and !arm, it still needs to exist for some of the other macros to expand properly.
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec6
1 files changed, 2 insertions, 4 deletions
diff --git a/kernel.spec b/kernel.spec
index 312018b42..f810e77c4 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -1012,7 +1012,7 @@ hyperthreading technology.
Install the kernel-smp package if your machine uses two or more CPUs.
-%ifarch %{ix86}
+%ifnarch armv7hl
%define variant_summary The Linux kernel compiled for PAE capable machines
%kernel_variant_package %{pae}
%description %{pae}
@@ -1020,15 +1020,13 @@ This package includes a version of the Linux kernel with support for up to
64GB of high memory. It requires a CPU with Physical Address Extensions (PAE).
The non-PAE kernel can only address up to 4GB of memory.
Install the kernel-PAE package if your machine has more than 4GB of memory.
-%endif
-%ifarch armv7hl
+%else
%define variant_summary The Linux kernel compiled for Cortex-A15
%kernel_variant_package %{pae}
%description %{pae}
This package includes a version of the Linux kernel with support for
Cortex-A15 devices with LPAE and HW virtualisation support
%endif
-%endif
%define variant_summary The Linux kernel compiled with extra debugging enabled for PAE capable machines