summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorDennis Gilmore <dennis@ausil.us>2011-12-09 13:29:38 -0600
committerDennis Gilmore <dennis@ausil.us>2011-12-23 10:28:47 -0600
commit534352f358b444bf67c24181516d90d4ca59ed46 (patch)
tree8a0ea260280d9173edbe6cc04de1c609b541489e /kernel.spec
parent2569ae132a91594cc77ebbcc47805b289e340249 (diff)
downloadkernel-534352f358b444bf67c24181516d90d4ca59ed46.tar.gz
kernel-534352f358b444bf67c24181516d90d4ca59ed46.tar.xz
kernel-534352f358b444bf67c24181516d90d4ca59ed46.zip
iadd support for building highbank, imx and kirkwood kernel images on arm
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec61
1 files changed, 60 insertions, 1 deletions
diff --git a/kernel.spec b/kernel.spec
index 933a1f1f1..00261c4cd 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -128,6 +128,12 @@ Summary: The Linux kernel
%define with_omap %{?_without_omap: 0} %{?!_without_omap: 1}
# kernel-tegra (only valid for arm)
%define with_tegra %{?_without_tegra: 0} %{?!_without_tegra: 1}
+# kernel-kirkwood (only valid for arm)
+%define with_kirkwood %{?_without_kirkwood: 0} %{?!_without_kirkwood: 1}
+# kernel-imx (only valid for arm)
+%define with_imx %{?_without_imx: 0} %{?!_without_imx: 1}
+# kernel-highbank (only valid for arm)
+%define with_highbank %{?_without_highbank: 0} %{?!_without_highbank: 1}
#
# Additional options for user-friendly one-off kernel building:
#
@@ -258,10 +264,17 @@ Summary: The Linux kernel
%define with_pae 0
%endif
-# kernel-tegra and omap is only built on armv7 hard and softfp
+# kernel-tegra, omap, imx and highbank are only built on armv7 hard and softfp
%ifnarch armv7hl armv7l
%define with_tegra 0
%define with_omap 0
+%define with_imx 0
+%define with_highbank 0
+%endif
+
+# kernel-kirkwood is only built for armv5
+%ifnarch armv5tel
+%define with_kirkwood 0
%endif
# if requested, only build base kernel
@@ -583,6 +596,9 @@ Source90: config-sparc64-generic
Source100: config-arm-generic
Source110: config-arm-omap-generic
Source111: config-arm-tegra
+Source112: config-arm-kirkwood
+Source113: config-arm-imx
+Source114: config-arm-highbank
Source200: config-backports
@@ -716,6 +732,7 @@ Patch20000: utrace.patch
# Flattened devicetree support
Patch21000: arm-omap-dt-compat.patch
Patch21001: arm-smsc-support-reading-mac-address-from-device-tree.patch
+Patch21002: pci-fix-ats-compile.patch
Patch21080: sysfs-msi-irq-per-device.patch
@@ -1001,6 +1018,23 @@ This variant of the kernel has numerous debugging options enabled.
It should only be installed when trying to gather additional information
on kernel bugs, as some of these options impact performance noticably.
+%define variant_summary The Linux kernel compiled for marvell kirkwood boards
+%kernel_variant_package kirkwood
+%description kirkwood
+This package includes a version of the Linux kernel with support for
+marvell kirkwood based systems, i.e., guruplug, sheevaplug
+
+%define variant_summary The Linux kernel compiled for freescale boards
+%kernel_variant_package imx
+%description imx
+This package includes a version of the Linux kernel with support for
+freescale based systems, i.e., efika smartbook.
+
+%define variant_summary The Linux kernel compiled for Calxeda boards
+%kernel_variant_package highbank
+%description highbank
+This package includes a version of the Linux kernel with support for
+Calxeda based systems, i.e., HP arm servers.
%define variant_summary The Linux kernel compiled for TI-OMAP boards
%kernel_variant_package omap
@@ -1279,6 +1313,7 @@ ApplyPatch linux-2.6-i386-nx-emulation.patch
#
ApplyPatch arm-omap-dt-compat.patch
ApplyPatch arm-smsc-support-reading-mac-address-from-device-tree.patch
+ApplyPatch pci-fix-ats-compile.patch
#
# bugfixes to drivers and filesystems
@@ -1806,6 +1841,18 @@ BuildKernel %make_target %kernel_image PAEdebug
BuildKernel %make_target %kernel_image PAE
%endif
+%if %{with_kirkwood}
+BuildKernel %make_target %kernel_image kirkwood
+%endif
+
+%if %{with_imx}
+BuildKernel %make_target %kernel_image imx
+%endif
+
+%if %{with_highbank}
+BuildKernel %make_target %kernel_image highbank
+%endif
+
%if %{with_omap}
BuildKernel %make_target %kernel_image omap
%endif
@@ -2071,6 +2118,15 @@ fi}\
%kernel_variant_post -v PAEdebug -r (kernel|kernel-smp)
%kernel_variant_preun PAEdebug
+%kernel_variant_preun kirkwood
+%kernel_variant_post -v kirkwood
+
+%kernel_variant_preun imx
+%kernel_variant_post -v imx
+
+%kernel_variant_preun highbank
+%kernel_variant_post -v highbank
+
%kernel_variant_preun omap
%kernel_variant_post -v omap
@@ -2207,6 +2263,9 @@ fi
%kernel_variant_files %{with_debug} debug
%kernel_variant_files %{with_pae} PAE
%kernel_variant_files %{with_pae_debug} PAEdebug
+%kernel_variant_files %{with_kirkwood} kirkwood
+%kernel_variant_files %{with_imx} imx
+%kernel_variant_files %{with_highbank} highbank
%kernel_variant_files %{with_omap} omap
%kernel_variant_files %{with_tegra} tegra