summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJosh Boyer <jwboyer@redhat.com>2014-03-06 14:35:35 -0500
committerJosh Boyer <jwboyer@redhat.com>2014-03-06 14:35:39 -0500
commit5a77287012c36ca39549f2f745d6c3a2e2879ffa (patch)
treefbddc8a370fd586af875f423195268e4b4ccc0c2 /kernel.spec
parente23ada199817b855a47229107c376689af21ee8c (diff)
downloadkernel-5a77287012c36ca39549f2f745d6c3a2e2879ffa.tar.gz
kernel-5a77287012c36ca39549f2f745d6c3a2e2879ffa.tar.xz
kernel-5a77287012c36ca39549f2f745d6c3a2e2879ffa.zip
Add ppc64le support from Brent Baude (rhbz 1073102)
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec27
1 files changed, 23 insertions, 4 deletions
diff --git a/kernel.spec b/kernel.spec
index b662cf51d..86102a6c8 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -222,7 +222,7 @@ Summary: The Linux kernel
%if %{with_vdso_install}
# These arches install vdso/ directories.
-%define vdso_arches %{all_x86} x86_64 ppc ppc64 ppc64p7 s390 s390x aarch64
+%define vdso_arches %{all_x86} x86_64 ppc ppc64 ppc64p7 s390 s390x aarch64 ppc64le
%endif
# Overrides for generic default options
@@ -252,7 +252,7 @@ Summary: The Linux kernel
%endif
# sparse blows up on ppc64 and sparc64
-%ifarch ppc64 ppc ppc64p7
+%ifarch ppc64 ppc ppc64p7 ppc64le
%define with_sparse 0
%endif
@@ -284,6 +284,17 @@ Summary: The Linux kernel
%define kernel_image_elf 1
%endif
+%ifarch ppc64le
+%define asmarch powerpc
+%define hdrarch powerpc
+%define all_arch_configs kernel-%{version}-ppc64le.config
+%define image_install_path boot
+%define make_target vmlinux
+%define kernel_image vmlinux
+%define kernel_image_elf 1
+%define with_tools 0
+%endif
+
%ifarch s390x
%define asmarch s390
%define hdrarch s390
@@ -365,7 +376,7 @@ Summary: The Linux kernel
%endif
# Architectures we build tools/cpupower on
-%define cpupowerarchs %{ix86} x86_64 ppc ppc64 ppc64p7 %{arm} aarch64
+%define cpupowerarchs %{ix86} x86_64 ppc ppc64 ppc64p7 %{arm} aarch64 ppc64le
#
# Packages that need to be installed before the kernel is, because the %%post
@@ -406,7 +417,7 @@ Version: %{rpmversion}
Release: %{pkg_release}
# DO NOT CHANGE THE 'ExclusiveArch' LINE TO TEMPORARILY EXCLUDE AN ARCHITECTURE BUILD.
# SET %%nobuildarches (ABOVE) INSTEAD
-ExclusiveArch: noarch %{all_x86} x86_64 ppc ppc64 ppc64p7 s390 s390x %{arm} aarch64
+ExclusiveArch: noarch %{all_x86} x86_64 ppc ppc64 ppc64p7 s390 s390x %{arm} aarch64 ppc64le
ExclusiveOS: Linux
%kernel_reqprovconf
@@ -473,6 +484,7 @@ Source51: config-powerpc32-generic
Source52: config-powerpc32-smp
Source53: config-powerpc64
Source54: config-powerpc64p7
+Source55: config-powerpc64le
Source70: config-s390x
@@ -637,6 +649,9 @@ Patch25034: bug-1071998.patch
#rhbz 1051748
Patch25035: Bluetooth-allocate-static-minor-for-vhci.patch
+#Fixes module loading on ppc64le
+Patch25036: ppc64le_module_fix.patch
+
# END OF PATCH DEFINITIONS
%endif
@@ -1293,6 +1308,9 @@ ApplyPatch bug-1071998.patch
#rhbz 1051748
ApplyPatch Bluetooth-allocate-static-minor-for-vhci.patch
+# Fixes module loading on ppc64le
+ApplyPatch ppc64le_module_fix.patch
+
# END OF PATCH APPLICATIONS
%endif
@@ -2073,6 +2091,7 @@ fi
# || ||
%changelog
* Thu Mar 06 2014 Josh Boyer <jwboyer@fedoraproject.org>
+- Add ppc64le support from Brent Baude (rhbz 1073102)
- Fix depmod error message from hci_vhci module (rhbz 1051748)
- Fix bogus WARN in iwlwifi (rhbz 1071998)