summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJosh Boyer <jwboyer@fedoraproject.org>2014-06-10 08:31:19 -0400
committerJosh Boyer <jwboyer@fedoraproject.org>2014-06-10 08:31:19 -0400
commit9b82ecdfb861cd3daf9d01b050c4937391aec003 (patch)
tree04c35507c2c3b5cabd7ba2fcb217af3e8285c129 /kernel.spec
parent38d8cd2ec1088b1ea6afe3520826405f20e9adcb (diff)
downloadkernel-9b82ecdfb861cd3daf9d01b050c4937391aec003.tar.gz
kernel-9b82ecdfb861cd3daf9d01b050c4937391aec003.tar.xz
kernel-9b82ecdfb861cd3daf9d01b050c4937391aec003.zip
Update to Linux v3.15
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec128
1 files changed, 69 insertions, 59 deletions
diff --git a/kernel.spec b/kernel.spec
index f882411b6..7afc11e44 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -62,19 +62,19 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 1
+%global baserelease 2
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
# which yields a base_sublevel of 0.
-%define base_sublevel 14
+%define base_sublevel 15
## If this is a released kernel ##
%if 0%{?released_kernel}
# Do we have a -stable update to apply?
-%define stable_update 1
+%define stable_update 0
# Is it a -stable RC?
%define stable_rc 0
# Set rpm version accordingly
@@ -665,23 +665,13 @@ Patch15000: nowatchdog-on-virt.patch
# ARM
-# lpae
-Patch21001: arm-lpae-ax88796.patch
-Patch21004: arm-sound-soc-samsung-dma-avoid-another-64bit-division.patch
-
-# ARM omap
-Patch21010: arm-omap-load-tfp410.patch
-
# ARM tegra
Patch21020: arm-tegra-usb-no-reset-linux33.patch
-# Add panel support for tegra paz00
-# Backported from linux-next scheduled for 3.15
-Patch21021: arm-tegra-paz00-panel-dts.patch
-
# ARM i.MX6
-# http://www.spinics.net/lists/devicetree/msg08276.html
-Patch21025: arm-imx6-utilite.patch
+
+# ARM sunxi (AllWinner)
+Patch21025: 0001-ARM-sunxi-Add-driver-for-SD-MMC-hosts-found-on-Allwi.patch
#rhbz 754518
Patch21235: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
@@ -696,29 +686,41 @@ Patch22000: weird-root-dentry-name-debug.patch
Patch25047: drm-radeon-Disable-writeback-by-default-on-ppc.patch
-#rhbz 1051748
-Patch25035: Bluetooth-allocate-static-minor-for-vhci.patch
-
-#rhbz 1046495
-Patch25044: iwlwifi-dvm-take-mutex-when-sending-SYNC-BT-config-command.patch
-
-#CVE-2014-0155 rhbz 1081589 1085016
-Patch25036: KVM-ioapic-fix-assignment-of-ioapic-rtc_status-pending_eoi.patch
+#rhbz 1025603
+Patch25063: disable-libdw-unwind-on-non-x86.patch
#rhbz 1048314
Patch25062: 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
-#rhbz 1074235
-Patch25055: lib-percpu_counter.c-fix-bad-percpu-counter-state-du.patch
+#rhbz 1089583
+Patch25064: 0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
+
+#rhbz 1090161
+Patch25072: HID-rmi-do-not-fetch-more-than-16-bytes-in-a-query.patch
+
+#rhbz 983342 1093120
+Patch25069: 0001-acpi-video-Add-4-new-models-to-the-use_native_backli.patch
-#CVE-2014-2851 rhbz 1086730 1087420
-Patch25059: net-ipv4-current-group_info-should-be-put-after-using.patch
+Patch25071: s390-appldata-add-slab.h-for-kzalloc-kfree.patch
-#rhbz 1085582 1085697 1088588
-Patch25060: 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
+# CVE-2014-3917 rhbz 1102571 1102715
+Patch25093: auditsc-audit_krule-mask-accesses-need-bounds-checking.patch
-#rhbz 1089689
-Patch25061: 0001-synaptics-Add-min-max-quirk-for-ThinkPad-Edge-E431.patch
+# Patch series from Hans for various backlight and platform driver fixes
+Patch26001: thinkpad_acpi-Add-mappings-for-F9-F12-hotkeys-on-X24.patch
+Patch26002: samsung-laptop-Add-broken-acpi-video-quirk-for-NC210.patch
+Patch26003: ideapad-laptop-Blacklist-rfkill-control-on-the-Lenov.patch
+Patch26004: asus-wmi-Add-a-no-backlight-quirk.patch
+Patch26005: eeepc-wmi-Add-no-backlight-quirk-for-Asus-H87I-PLUS-.patch
+Patch26006: acpi-video-Don-t-register-acpi_video_resume-notifier.patch
+Patch26007: acpi-video-Add-an-acpi_video_unregister_backlight-fu.patch
+Patch26008: acer-wmi-Switch-to-acpi_video_unregister_backlight.patch
+Patch26009: acer-wmi-Add-Aspire-5741-to-video_vendor_dmi_table.patch
+Patch26010: nouveau-Don-t-check-acpi_video_backlight_support-bef.patch
+Patch26011: backlight-Add-backlight-device-un-registration-notif.patch
+Patch26012: acpi-video-Unregister-the-backlight-device-if-a-raw-.patch
+Patch26013: acpi-video-Add-use-native-backlight-quirk-for-the-Th.patch
+Patch26014: acpi-video-Add-use_native_backlight-quirk-for-HP-Pro.patch
# END OF PATCH DEFINITIONS
@@ -1269,13 +1271,8 @@ ApplyPatch 0001-lib-cpumask-Make-CPUMASK_OFFSTACK-usable-without-deb.patch
#
# ARM
#
-ApplyPatch arm-lpae-ax88796.patch
-ApplyPatch arm-sound-soc-samsung-dma-avoid-another-64bit-division.patch
-ApplyPatch arm-omap-load-tfp410.patch
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
-ApplyPatch arm-tegra-paz00-panel-dts.patch
-ApplyPatch arm-imx6-utilite.patch
-
+ApplyPatch 0001-ARM-sunxi-Add-driver-for-SD-MMC-hosts-found-on-Allwi.patch
#
# bugfixes to drivers and filesystems
@@ -1381,29 +1378,39 @@ ApplyPatch ath9k_rx_dma_stop_check.patch
ApplyPatch drm-radeon-Disable-writeback-by-default-on-ppc.patch
-#rhbz 1051748
-ApplyPatch Bluetooth-allocate-static-minor-for-vhci.patch
-
-#rhbz 1046495
-ApplyPatch iwlwifi-dvm-take-mutex-when-sending-SYNC-BT-config-command.patch
-
-#CVE-2014-0155 rhbz 1081589 1085016
-ApplyPatch KVM-ioapic-fix-assignment-of-ioapic-rtc_status-pending_eoi.patch
-
#rhbz 1048314
ApplyPatch 0001-HID-rmi-introduce-RMI-driver-for-Synaptics-touchpads.patch
-
-#rhbz 1074235
-ApplyPatch lib-percpu_counter.c-fix-bad-percpu-counter-state-du.patch
-
-#CVE-2014-2851 rhbz 1086730 1087420
-ApplyPatch net-ipv4-current-group_info-should-be-put-after-using.patch
-
-#rhbz 1085582 1085697
-ApplyPatch 0001-synaptics-Add-min-max-quirk-for-ThinkPad-T431s-L440-.patch
-
-#rhbz 1089689
-ApplyPatch 0001-synaptics-Add-min-max-quirk-for-ThinkPad-Edge-E431.patch
+#rhbz 1089583
+ApplyPatch 0001-HID-rmi-do-not-handle-touchscreens-through-hid-rmi.patch
+#rhbz 1090161
+ApplyPatch HID-rmi-do-not-fetch-more-than-16-bytes-in-a-query.patch
+
+#rhbz 1025603
+ApplyPatch disable-libdw-unwind-on-non-x86.patch
+
+#rhbz 983342 1093120
+ApplyPatch 0001-acpi-video-Add-4-new-models-to-the-use_native_backli.patch
+
+ApplyPatch s390-appldata-add-slab.h-for-kzalloc-kfree.patch
+
+# CVE-2014-3917 rhbz 1102571 1102715
+ApplyPatch auditsc-audit_krule-mask-accesses-need-bounds-checking.patch
+
+# Patch series from Hans for various backlight and platform driver fixes
+ApplyPatch thinkpad_acpi-Add-mappings-for-F9-F12-hotkeys-on-X24.patch
+ApplyPatch samsung-laptop-Add-broken-acpi-video-quirk-for-NC210.patch
+ApplyPatch ideapad-laptop-Blacklist-rfkill-control-on-the-Lenov.patch
+ApplyPatch asus-wmi-Add-a-no-backlight-quirk.patch
+ApplyPatch eeepc-wmi-Add-no-backlight-quirk-for-Asus-H87I-PLUS-.patch
+ApplyPatch acpi-video-Don-t-register-acpi_video_resume-notifier.patch
+ApplyPatch acpi-video-Add-an-acpi_video_unregister_backlight-fu.patch
+ApplyPatch acer-wmi-Switch-to-acpi_video_unregister_backlight.patch
+ApplyPatch acer-wmi-Add-Aspire-5741-to-video_vendor_dmi_table.patch
+ApplyPatch nouveau-Don-t-check-acpi_video_backlight_support-bef.patch
+ApplyPatch backlight-Add-backlight-device-un-registration-notif.patch
+ApplyPatch acpi-video-Unregister-the-backlight-device-if-a-raw-.patch
+ApplyPatch acpi-video-Add-use-native-backlight-quirk-for-the-Th.patch
+ApplyPatch acpi-video-Add-use_native_backlight-quirk-for-HP-Pro.patch
# END OF PATCH APPLICATIONS
@@ -2217,6 +2224,9 @@ fi
# ||----w |
# || ||
%changelog
+* Mon Jun 09 2014 Josh Boyer <jwboyer@fedoraproject.org>
+- Update to Linux v3.15
+
* Fri Apr 25 2014 Hans de Goede <hdegoede@redhat.com>
- Add synaptics min-max quirk for ThinkPad Edge E431 (rhbz#1089689)