summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJosh Boyer <jwboyer@fedoraproject.org>2014-09-08 14:43:02 -0400
committerJosh Boyer <jwboyer@fedoraproject.org>2014-09-08 14:43:02 -0400
commit9a6acd5adddc5dd0604a3f7ada6608885e445293 (patch)
tree9c74106b6a9df5dedc90b75bcc7545af7561d7a9 /kernel.spec
parent964596a34c3cf842eddee09b128009c28b5629ba (diff)
downloadkernel-9a6acd5adddc5dd0604a3f7ada6608885e445293.tar.gz
kernel-9a6acd5adddc5dd0604a3f7ada6608885e445293.tar.xz
kernel-9a6acd5adddc5dd0604a3f7ada6608885e445293.zip
Remove ppc32 support
The powerpc secondary arch team has disabled all ppc32 builds in koji for F21 and beyond: https://lists.fedoraproject.org/pipermail/ppc/2014-May/002801.html FESCo also recently said that dropped or new architectures must essentially prove they have an active and viable effort behind them before being considered for Secondary Arch support. This effort has not materialized in the interim since the current powerpc team dropped ppc32. There's little point in keeping support for ppc32 support in the kernel package when it will never be built. This also removes the -smp variant and with_smp* support, as that was only used on ppc32.
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec70
1 files changed, 8 insertions, 62 deletions
diff --git a/kernel.spec b/kernel.spec
index f17b502ba..e0f55731b 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -86,8 +86,6 @@ Summary: The Linux kernel
#
# standard kernel
%define with_up %{?_without_up: 0} %{?!_without_up: 1}
-# kernel-smp (only valid for ppc 32-bit)
-%define with_smp %{?_without_smp: 0} %{?!_without_smp: 1}
# kernel PAE (only valid for i686 (PAE) and ARM (lpae))
%define with_pae %{?_without_pae: 0} %{?!_without_pae: 1}
# kernel-debug
@@ -109,8 +107,6 @@ Summary: The Linux kernel
#
# Only build the base kernel (--with baseonly):
%define with_baseonly %{?_with_baseonly: 1} %{?!_with_baseonly: 0}
-# Only build the smp kernel (--with smponly):
-%define with_smponly %{?_with_smponly: 1} %{?!_with_smponly: 0}
# Only build the pae kernel (--with paeonly):
%define with_paeonly %{?_with_paeonly: 1} %{?!_with_paeonly: 0}
# Only build the debug kernel (--with dbgonly):
@@ -193,14 +189,6 @@ Summary: The Linux kernel
# if requested, only build base kernel
%if %{with_baseonly}
-%define with_smp 0
-%define with_pae 0
-%define with_debug 0
-%endif
-
-# if requested, only build smp kernel
-%if %{with_smponly}
-%define with_up 0
%define with_pae 0
%define with_debug 0
%endif
@@ -208,7 +196,6 @@ Summary: The Linux kernel
# if requested, only build pae kernel
%if %{with_paeonly}
%define with_up 0
-%define with_smp 0
%define with_debug 0
%endif
@@ -218,7 +205,6 @@ Summary: The Linux kernel
%define with_up 0
%define with_pae 0
%endif
-%define with_smp 0
%define with_pae 0
%define with_tools 0
%define with_perf 0
@@ -228,16 +214,11 @@ Summary: The Linux kernel
%if %{with_vdso_install}
# These arches install vdso/ directories.
-%define vdso_arches %{all_x86} x86_64 ppc %{power64} s390 s390x aarch64
+%define vdso_arches %{all_x86} x86_64 %{power64} s390 s390x aarch64
%endif
# Overrides for generic default options
-# only ppc needs a separate smp kernel
-%ifnarch ppc
-%define with_smp 0
-%endif
-
# don't do debug builds on anything but i686 and x86_64
%ifnarch i686 x86_64
%define with_debug 0
@@ -254,7 +235,7 @@ Summary: The Linux kernel
# bootwrapper is only on ppc
# sparse blows up on ppc
-%ifnarch ppc %{power64}
+%ifnarch %{power64}
%define with_bootwrapper 0
%define with_sparse 0
%endif
@@ -302,16 +283,6 @@ Summary: The Linux kernel
%define with_tools 0
%endif
-%ifarch ppc
-%define asmarch powerpc
-%define hdrarch powerpc
-%define all_arch_configs kernel-%{version}-ppc{-,.}*config
-%define image_install_path boot
-%define make_target vmlinux
-%define kernel_image vmlinux
-%define kernel_image_elf 1
-%endif
-
%ifarch %{arm}
%define all_arch_configs kernel-%{version}-arm*.config
%define image_install_path boot
@@ -363,7 +334,6 @@ Summary: The Linux kernel
%ifarch %nobuildarches
%define with_up 0
-%define with_smp 0
%define with_pae 0
%define with_debuginfo 0
%define with_perf 0
@@ -377,7 +347,7 @@ Summary: The Linux kernel
%endif
# Architectures we build tools/cpupower on
-%define cpupowerarchs %{ix86} x86_64 ppc %{power64} %{arm} aarch64
+%define cpupowerarchs %{ix86} x86_64 %{power64} %{arm} aarch64
#
# Packages that need to be installed before the kernel is, because the %%post
@@ -395,7 +365,7 @@ Version: %{rpmversion}
Release: %{pkg_release}
# DO NOT CHANGE THE 'ExclusiveArch' LINE TO TEMPORARILY EXCLUDE AN ARCHITECTURE BUILD.
# SET %%nobuildarches (ABOVE) INSTEAD
-ExclusiveArch: %{all_x86} x86_64 ppc ppc64 ppc64p7 s390 s390x %{arm} aarch64 ppc64le
+ExclusiveArch: %{all_x86} x86_64 ppc64 ppc64p7 s390 s390x %{arm} aarch64 ppc64le
ExclusiveOS: Linux
%ifnarch %{nobuildarches}
Requires: kernel-%{?variant:%{variant}-}core-uname-r = %{KVERREL}%{?variant}
@@ -449,7 +419,6 @@ Source90: filter-x86_64.sh
Source91: filter-armv7hl.sh
Source92: filter-i686.sh
Source93: filter-aarch64.sh
-Source94: filter-ppc.sh
Source95: filter-ppc64.sh
Source96: filter-ppc64le.sh
Source97: filter-s390x.sh
@@ -471,8 +440,6 @@ Source32: config-x86-32-generic
Source40: config-x86_64-generic
Source50: config-powerpc-generic
-Source51: config-powerpc32-generic
-Source52: config-powerpc32-smp
Source53: config-powerpc64
Source54: config-powerpc64p7
Source55: config-powerpc64le
@@ -925,15 +892,6 @@ Provides: kernel-%{?1:%{1}-}core-uname-r = %{KVERREL}%{?1:+%{1}}\
# Now, each variant package.
-%define variant_summary The Linux kernel compiled for SMP machines
-%kernel_variant_package -n SMP smp
-%description smp-core
-This package includes a SMP version of the Linux kernel. It is
-required only on machines with two or more CPUs as well as machines with
-hyperthreading technology.
-
-Install the kernel-smp package if your machine uses two or more CPUs.
-
%ifnarch armv7hl
%define variant_summary The Linux kernel compiled for PAE capable machines
%kernel_variant_package %{pae}
@@ -997,13 +955,6 @@ exit 1
%endif
%endif
-%if %{with_smponly}
-%if !%{with_smp}
-echo "Cannot build --with smponly, smp build is disabled"
-exit 1
-%endif
-%endif
-
%if "%{baserelease}" == "0"
echo "baserelease must be greater than zero"
exit 1
@@ -1614,7 +1565,7 @@ BuildKernel() {
fi
rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
-%ifarch ppc %{power64}
+%ifarch %{power64}
cp -a --parents arch/powerpc/lib/crtsavres.[So] $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
%endif
if [ -d arch/%{asmarch}/include ]; then
@@ -1797,10 +1748,6 @@ BuildKernel %make_target %kernel_image %{pae}
BuildKernel %make_target %kernel_image
%endif
-%if %{with_smp}
-BuildKernel %make_target %kernel_image smp
-%endif
-
%global perf_make \
make -s %{?cross_opts} %{?_smp_mflags} -C tools/perf V=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_LIBNUMA=1 NO_STRLCPY=1 NO_BIONIC=1 prefix=%{_prefix}
%if %{with_perf}
@@ -2084,9 +2031,6 @@ fi}\
%kernel_variant_preun
%kernel_variant_post -r kernel-smp
-%kernel_variant_preun smp
-%kernel_variant_post -v smp
-
%kernel_variant_preun %{pae}
%kernel_variant_post -v %{pae} -r (kernel|kernel-smp)
@@ -2241,7 +2185,6 @@ fi
%kernel_variant_files %{with_up}
-%kernel_variant_files %{with_smp} smp
%kernel_variant_files %{with_debug} debug
%kernel_variant_files %{with_pae} %{pae}
%kernel_variant_files %{with_pae_debug} %{pae}debug
@@ -2260,6 +2203,9 @@ fi
# ||----w |
# || ||
%changelog
+* Mon Sep 08 2014 Josh Boyer <jwboyer@fedoraproject.org>
+- Remove ppc32 support
+
* Mon Sep 8 2014 Peter Robinson <pbrobinson@fedoraproject.org>
- Build tools on ppc64le (rhbz 1138884)
- Some minor ppc64 cleanups